Modem on HP-UX 10.20


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Modem on HP-UX 10.20
# 1  
Network

Hi everyone
I am having some real difficulties getting a dial in modem to work on one of my HP boxes. It's a mux modem on port 7 which I have set up at 9600 baud.

I can dial in, the handshakes are completed, but then it returns incoherent characters on the emulation screen. I think my dial in machine and the modem are not negotiating on the same terms. It's not the emulation type since I know this is a vt100 and set it accordingly.

I am going down the path of this being a problem with parity settings (8 or 7 and odd,even,none), usually 8, none with 1 stop bit works, but this doesnt seem to be the case.

Does anyone have a similar configuration? /dev/ttyd0p7, I realise some changes need to be made to /etc/gettydefs - does anyone have an existing amended file they can paste the relevant baud section for me? All entries are in inittab, and things respawn fine - that clearly isnt the problem since the handshake are completed successfully, I just need to know what relevant flags to have set in /etc/gettydefs, or maybe I'm missing something.

Thanks in advance.

Regards.
alwayslearningunix
# 2  
MySQL Got It

Just to anyone who was wondering the solution:

I gave up on SAM and decided to go manual. used ioscan to find the hardware path of the modem - ioscan -C tty -fn. Then I made the relevant device files using mkfs, a separate command line for dial out and dial in device files:

# /usr/sbin/mksf -d asio0 -H <hardware path> -a1 -v

# /usr/sbin/mksf -d asio0 -H <hardware path> -a2 -v

1 and 2 states here define dial out/in status.

I then manually entered an inittab entry to respawn the uugetty process (uugetty and not getty because of dial out capacity):

a0:3:respawn:/usr/lbin/uucp/uugetty -r -t 60 -h ttyd0p7 19200M

The baud rate on the end is NOT the baud rate of the modem, but the one to be set for those dialling in - this is important if you need to set the baud and parity on your connecting client. I say parity because the next step involved creating a specific entry in /etc/gettydefs to correspond to this inittab process, and hence this modem. This was for 19200M - and all the flags that go with it (man on stty will show you) - just to note take out PARENB to disable parity checking, and set the data bits (CSx) to 8.

Once this is done run

# /etc/getty -c /etc/gettydefs | more

Then look for the entry you created and make sure it parsed without errors. ps for the getty process, and kill it. init q to reload the inittab and then kill the getty process again to make sure it respawns. Dial in, and presto, one working dial in modem, one happy manager and one tires system admin.

Spread the wealth by spreading knowledge and experience.

Regards.
alwayslearningunix
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #34
Difficulty: Medium
When a computer is first powered on, the special type of absolute loader is known as the pre-boot loader.
True or False?

10 More Discussions You Might Find Interesting

1. IP Networking

modem detection

How to get information that where is my modem configured in /dev. I have two modems configured in my device .. one is USB and other is PCI modem.. USB is detected as /dev/USB0. but how to see about PCI modem? (0 Replies)
Discussion started by: s123.radha
0 Replies

2. Solaris

Modem

hi folks, i am looking for a analog modem to use it with a solaris9 sparc mashine. as far as i know, solaris communicates with the modem using AT-commands. so do i need a special modem for solaris or just a modem? i am open for everything. PCI-modem, seriell modem, usb modem. what are you using? i... (1 Reply)
Discussion started by: pressy
1 Replies

3. Solaris

Is the cable you are using a null modem cable or a modem cable

Hi all, Is there any difference between a null modem cable or a modem cable ? i assume that a null modem cable is a normal cable that i used from cpu serial ports to a modem for dialup. please correct if i am wrong, thks (2 Replies)
Discussion started by: waterbear
2 Replies

4. UNIX for Dummies Questions & Answers

Dial-Up Modem

Im using Kinternet with a Lucent modem on Suse 9.0 Ive installed the ltmodem driver and suse says the device is ready and configured. Ive configured it at /dev/ttyS0 This is the log that Kinternet gives after trying to connect: SuSE Meta pppd (smpppd-ifcfg), Version 1.06 on linux. Status... (0 Replies)
Discussion started by: Synbios
0 Replies

5. UNIX for Dummies Questions & Answers

Modem - Test /dev/modem

Ok. I tried following the directions from some of the other threads, but I've hit a road block. I have red hat 7.3 and I installed the hcf package: hcfpcimodem-0.99lnxtbeta03042700k2.4.18_3-1rh.i386.rpm It installed ok, no errors, but I still can't get linux to find my modem. I've tried... (2 Replies)
Discussion started by: lawadm1
2 Replies

6. UNIX for Dummies Questions & Answers

modem

I have got Suse 8.0 by using a modem (US Robotics 56K Faxmodem Ext). During connection i got the error 16. I tried it under RedHat and Mandrake too.....same problem. What can i do ? Thanx...a lot... Logfile: SuSE Meta pppd (smpppd), Version 0.73 on zuhause. wwwoffle not is running ... (1 Reply)
Discussion started by: Pennywize
1 Replies

7. UNIX for Dummies Questions & Answers

Modem

Pleaseee... Helpppp.... !!! I am using SCO Open Server 5.05. Recently, i have upgraded the system which means transfer all apps and data to the new system. Everything work well except one thing. On my old system i have an external modem which to dial out. Now that i use the same modem on... (4 Replies)
Discussion started by: jackpotp
4 Replies

8. UNIX for Dummies Questions & Answers

Modem Volume

Specs: Dlink DFE-560EL external modem. RedHat 7.1 How do you turn off the modem volume? I am getting annoyed of it beeping everytime I use it but there is no switch on the hardware to tune down the volume. I have tried using minicom and use the following commands: ATL0 ATM0 Next, I... (2 Replies)
Discussion started by: arz
2 Replies

9. UNIX for Dummies Questions & Answers

Modem problem: "Sorry, modem is busy"

Hi! I have a little prob with dialing up to the internet... When I try connect, it says "Sorry, modem is busy"... Specs: Laptop 56K modem Slackware 8.0 Kernel 2.4.5 Cheers;) (4 Replies)
Discussion started by: satan404
4 Replies

10. UNIX for Advanced & Expert Users

Modem

I've spent enough time trying to put on work Lucent Winmodem in my armada M300 (compaq laptop) I use Mandrake 8.0 but as soon as i get connected and prompmts appears modem shutsdown. Does any one had a similar situation, solved it? cheers (2 Replies)
Discussion started by: alex blanco
2 Replies

Featured Tech Videos