Can't empty trash in OS X!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Can't empty trash in OS X!
# 1  
Data Can't empty trash in OS X!

I trashed Adobe Acrobat (not Acrobat Reader today) because Adobe screwed up my licensing; their solution was to issue me a new serial number (thanks, guys). Anyhoo, I can't delete all of the Acrobat folder from my trash in OS X, nor can I move it out of the trash (it just copies). Any suggestions? I can't boot from OS 9 because I won't have access to the same trash bin, nor can I login as root for the same reason. I tried Pseudo and was able to get a crack at it, but the permissions won't budge. Help!
# 2  
I had this problem with .mov files before. What I did was try to delete it, log out and log back in. I can't remember if it was gone by the time I log back in, or it let me delete it.

If that doesn't work try logging in as root in your Terminal and go to ~(your username)/Desktop/Trash

I just looked at my Trash can through the terminal and there were files I deleted, but I don't think since I shut off my computer.

Just some thoughts, but you know, next time I would take this question to Macfixit.com or apple support MB.
# 3  
Computer Bizarre...

This is odd... I tried to move the undeleteable files to the desktop and to my OS X partition with no avail (the Finder would COPY the files, but not move them out of the Trash), BUT...when I tried to copy them back to their original location on my OS 9 partition, no problem! After that, it was easy to login as the superuser and delete them. Is this a documented UNIX thing, or is it something Apple added to FreeBSD 4.x?
# 4  
Personaly I think it's something with Aqua. Don't get me wrong, I love it and the entire platform, but there are still a few bugs. I could be wrong though, I am a lot; you know, Darwin BSD is just as new.
# 5  
Computer No problem with Aqua!

No, no, no--no problem with Aqua at all. Acrobat 5.0 was a Classic application, meaning its code hadn't had the ~10% rewrite necessary to run natively in both OS 9.x and OS X, meaning that its component files hadn't been given UNIX permissions. The owner of those files was "System," but since I couldn't remove them from the trash (except, as I later discovered) to their original location, I couldn't get to them because each username has its own Trash, and I couldn't find the one that had the files when I logged in as the superuser (this is a failing on my part).
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #652
Difficulty: Easy
Puffy is the mascot of Linux Mint.
True or False?

9 More Discussions You Might Find Interesting

1. Homework & Coursework Questions

Delete restore and empty trash

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: A set of Linux shell scripts is required to allow users to ‘remove’ files without them really disappearing... (1 Reply)
Discussion started by: mr100perecent
1 Replies

2. Linux

empty trash

Hello i am trying to empty the trash using rm or rmdir command . Any idea how to delete the folders and subfolders using one of the above commands? Thank You (2 Replies)
Discussion started by: exhumation
2 Replies

3. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

4. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

5. Email Antispam Techniques and Email Filtering

Procmail recipe: blocking 'unsubscribe and opt-out' messages....

Here is a crude procmail recipe that I quickly created (NOT a procmail recipe expert, btw) that has been catching lots of spam (current second after the charset_spam recipe posted earlier): :0B * .*If.you.do.not.wish.to.receive...* more_spam :0B * You.requested.to.receive.this.mailing... (0 Replies)
Discussion started by: Neo
0 Replies

6. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

7. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

8. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies

9. UNIX for Dummies Questions & Answers

How to subtract 2 hours from 'date' in shell ( /bin/sh ) script ?

I write a sh script that zip and copy to tape all files that older then 2 hours. 1. The way I choose is - touch a file with "now - 2 hours", then use fine with '! -newer' 2. Do you have any other idea to do it ? tnx. (1 Reply)
Discussion started by: yairon
1 Replies

Featured Tech Videos