Visit Our UNIX and Linux User Community


Password unknown??? solaris 2.8 vs 2.6???


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Password unknown??? solaris 2.8 vs 2.6???
# 1  
Old 03-13-2002
Network Password unknown??? solaris 2.8 vs 2.6???

Hello all!!!
We just inherited a sun 220r from another department. The Department doesn't exist any more and we have no way of getting the login password or any account information. The 220r has solaris 2.8 on it and the only version that I have on disk is 2.6.

Question 1: Can I use 2.6 on the sun 220r?

Question 2:How do I recover the account info and use the existing OS?

Question 3: Can I recover the password and how do I do it?

I did a search of all the forums and found many previous postings.

Question 4: How do I get into single user mode. The space bar thing doesn't seem to work? Can this problem be corrected in single user mode?
# 2  
Old 03-13-2002
Yes I think you should beable to boot of the 2.6 CD , and then change the root password in /etc/shadow to be blank (after mounting /). Then boot off the hard disk, login as root, and then if you need to change the passwords for other users you can do that as root. By the way, it isn't 2.8, it is just plain 8. Solaris went from 2.6 to 7, then 8. They simply dropped the 2.X after 2.6
# 3  
Old 03-13-2002
Thanks But????

Thanks for the info. One more thing , I can't get the darn box to stop booting from disk. I've tried to hit the space bar to interrupt the boot sequence but it still continues on. How do I stop the initial boot sequence and get it to boot from the cdrom.

thanks in advance
# 4  
Old 03-13-2002
Have you tried hitting the Stop and A keys at the same time?

This should send it a halt and leave you at the boot prompt.
thehoghunter
# 5  
Old 03-13-2002
Thanks again..But????

Thanks again. I can't open the kernel/unix file. Any suggestions?
# 6  
Old 03-13-2002
After you hit Stop-A you should have a "ok" prompt.
boot the cdrom into single user

ok boot cdrom -s


I don't remember off-hand if it ask for a password but if it does, just hit return and you should be in.

Then you need to mount the boot DISK partition / onto /mnt
(it is probably c0t0d0s0 or c3t0d0s0)

# mount /dev/dsk/c0t0d0s0 /mnt

Then you cd to /mnt/etc, make sure your TERM is correct, vi passwd, and remove the x OR encrypted password from the root account - it will be the second field (colon separated fields)

root:x:0:1:Super-User:/root:/bin/ksh

save the file, cd /, umount /mnt, and fsck /dev/rdsk/c0t0d0s0 (or whatever the disk was). Then Stop-A and do

ok boot -s

This should put you into single user on the disk instead of cdrom.

Set the root password to whatever you want. Then it's Miller time.
thehoghunter
# 7  
Old 03-14-2002
Thanks...

Thanks, I will give it a try.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #482
Difficulty: Medium
in 2018, developers and programmers rarely used an Integrated Development Environment (IDE) that provided a text editor with code highlighting.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

How to force a same password in Solaris in Solaris 8?

hi all I need to add a user "abcd" and set the password same as the user id. But Solaris 8 is not allowing me to do it, is there any way we can force the password to be same as the user id. Any help would be appreciated. Thanks bash-3.00# cat /etc/release ... (9 Replies)
Discussion started by: imran721
9 Replies

2. Solaris

Solaris 8 - Asks for current root password when trying to change root password.

Hello All, I have several solaris boxes running Solaris 8. When changing root passwords on them, all will simply ask for the new root password to change and of course to re-type the new password. One of the systems however asks for the existing root password before it will display the new password... (8 Replies)
Discussion started by: tferrazz
8 Replies

3. UNIX for Advanced & Expert Users

Unknown process SYSCON in Sun Solaris

When i tried ps -fu command in solaris it is shown in a process called SYSCON ..:eek: do any one knows what is this process??? any idea how to stop it??:mad: (0 Replies)
Discussion started by: kiran@solaris
0 Replies

4. Solaris

PING - Unknown host 127.0.0.1, Unknown host localhost - Solaris 10

Hello, I have a problem - I created a chrooted jail for one user. When I'm logged in as root, everything work fine, but when I'm logged in as a chrooted user - I have many problems: 1. When I execute the command ping, I get weird results: bash-3.00$ usr/sbin/ping localhost ... (4 Replies)
Discussion started by: Przemek
4 Replies

5. Solaris

Solaris 9 Password

Hello, I'm new to solaris but am a certified systems administrator. I was recently brought the task of repairing a sunblade150 and was completely willing to take on this task without knowing the history behind this system. Apparently some slick S.O.B. from ebay bought this system, took the... (13 Replies)
Discussion started by: matt81
13 Replies

6. Solaris

Solaris root password

Bit of a strange problem I have never come across before.. I can log into the workstation going through the server as it is a trusted host but when I try and connect to the workstation through SSH or RSH directly it will not take the password, I changed the password when I logged in the machine... (5 Replies)
Discussion started by: Mr Pink
5 Replies

7. UNIX for Dummies Questions & Answers

Solaris - unknown hostname - how can I change hostname?

Hello, I am new to Solaris. I am using stand alone Solaris 10.0 for test/study purpose and connecting to internet via an ADSL modem which has DHCP server. My Solaris is working on VMWare within winXP. My WinXP and Solaris connects to internet by the same ADSL modem via its DHCP at the same... (1 Reply)
Discussion started by: XNOR
1 Replies

8. UNIX for Dummies Questions & Answers

unknown root password

hello, i've found at work an old Sun Ultra 10 box, with SunOS 5.9 operating system. I want to put into use this machine (particularly for training) . offcourse , the root password is unknown , as this is a very old machine which was not in use for long time... :confused: is there a way to... (1 Reply)
Discussion started by: paraaduma
1 Replies

9. Solaris

unknown iplanet db password

I'm trying to renew a ssl certificate on my SunFire 280R that is running iplanet on top of Solaris 8. The password that I was given for the Key Pair File Password doesn't work and the previous admin has no idea what it could possibly be. :o Does anyone have any idea how to crowbar the password... (3 Replies)
Discussion started by: antalexi
3 Replies

10. Solaris

how to reset the password in solaris

I forgot the password of root account of sun solaris .how to reset the root password. (1 Reply)
Discussion started by: mallesh
1 Replies

Featured Tech Videos