Visit Our UNIX and Linux User Community


netbsd


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers netbsd
# 1  
Old 01-22-2008
netbsd

which better freebsd and netbsd for server unix
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #837
Difficulty: Medium
SOAP was designed as an object-addressing protocol in 1998,
True or False?

8 More Discussions You Might Find Interesting

1. BSD

NetBSD on OLD laptop

I want to install NetBSD on the Compaq LTE 5000. ("Of course it runs NetBSD!!") But the laptop does NOT have a CD-ROM drive. How can I solve?? Thanks for any reply! :) PS: I hope i'm posting in the right item... (2 Replies)
Discussion started by: mghis
2 Replies

2. Virtualization and Cloud Computing

NetBSD on VirtualBox

Hello, guys! I use Ubuntu 9.04 as desktop operating system and I want to make some tests on NetBSD. I tried to install as a virtual sistem on VirtualBox but it doesn't want to install. You can see the error in the attached file. Do you guys have any clue about what the problem could be? (3 Replies)
Discussion started by: Sergiu-IT
3 Replies

3. BSD

netbsd

i have install netbsd but don't have gui?what happen?i want to a mount external usb hard drive but failure?what should i do? (5 Replies)
Discussion started by: ibnusina202003
5 Replies

4. BSD

Anyone using NetBSD pkgsrc on FreeBSD?

I confess, I'm getting a hair frustrated with the FreeBSD ports system. Is there a reasonably headache-free way of migrating all my installed apps to pkgsrc? Is it advisable or not? Or should I just change my systems over to NetBSD? Or stop worrying an learn to love FBSD ports? (0 Replies)
Discussion started by: criglerj
0 Replies

5. BSD

NetBSD Ports

They put NetBSD on a Dreamcast. Thats just awesome. What can't they put it on!? (1 Reply)
Discussion started by: Phobos
1 Replies

6. UNIX for Dummies Questions & Answers

bash in netbsd

i recently downloaded and installed bash on my netbsd box (1.5.2) and set my shell and my root shell using user mod to change the shell, command executed under root. bash is installed from my user home directory (home/joe) and i moved the bash executable to /bin/ and everything is fine, except i... (6 Replies)
Discussion started by: norsk hedensk
6 Replies

7. UNIX Desktop Questions & Answers

Starting X in NetBSD

Hi I have NetBSD and i am having a trouble Starting X. It keeps asking me for the config file and I run the text confing file but it messes up. I really want to be able to run the Graphical Setup. I read about the Graphical setup from a book but they didn't tell how to start it. help please!? (9 Replies)
Discussion started by: vertigo
9 Replies

8. UNIX Desktop Questions & Answers

NetBSD Troubles

HI, I just installed NetBSD i386 v. latest. I am having a few problems: For some reason X just won't start!? Another is I can't access My CDROM or Floppy. Thanks in advance! (3 Replies)
Discussion started by: vertigo
3 Replies
COMPAT_SVR4(8)						    BSD System Manager's Manual 					    COMPAT_SVR4(8)

NAME
compat_svr4 -- setup procedure for running SVR4/iBCS2 binaries compat_svr4_32 -- setup procedure for running 32-bit SVR4/iBCS2 binaries DESCRIPTION
NetBSD supports running SVR4/iBCS2 binaries. This code has been tested on i386 (with binaries from SCO OpenServer and XENIX), m68k (with binaries from AMIX) and sparc (with binaries from Solaris) systems. Most programs should work, but not ones that use or depend on: kernel internal data structures the /proc filesystem the ticotsord loopback RPC mechanism (NIS uses this) sound and video interfaces threads (ttsession uses threads) the streams administrative driver The SVR4 compatibility feature is active for kernels compiled with the COMPAT_SVR4 option enabled. Since support for ELF executables is included only if the kernel is compiled with the EXEC_ELF32 or EXEC_ELF64 options enabled, kernels which include COMPAT_SVR4 should also typ- ically include EXEC_ELF32 (for 32-bit ELF support) and/or EXEC_ELF64 (for 64-bit ELF support). Another compatibility feature is COMPAT_SVR4_32, which allows the execution of 32-bit SVR4 binaries on a machine with a 64-bit kernel. This requires EXEC_ELF32 and COMPAT_NETBSD32 options as well as COMPAT_SVR4. It is configured the same way as COMPAT_SVR4 but uses the /emul/svr4_32 directory instead of /emul/svr4. But typically, /emul/svr4_32 can be made to point to /emul/svr4 if the operating system donating the libraries has support for both 32-bit and 64-bit binaries. Execution of 32-bit SVR4 binaries on a machine with a 32-bit kernel uses COMPAT_SVR4, not COMPAT_SVR4_32. Most SVR4 programs are dynamically linked. This means that you will also need the shared libraries that the program depends on and the run- time linker. Also, you will need to create a ``shadow root'' directory for SVR4 binaries on your NetBSD system. This directory is named /emul/svr4. Any file operations done by SVR4 programs run under NetBSD will look in this directory first. So, if a SVR4 program opens, for example, /etc/passwd, NetBSD will first try to open /emul/svr4/etc/passwd, and if that does not exist open the 'real' /etc/passwd file. It is recommended that you install SVR4 packages that include configuration files, etc under /emul/svr4, to avoid naming conflicts with possible NetBSD counterparts. Shared libraries should also be installed in the shadow tree. The simplest way to set up your system for SVR4 binaries is: 1. Make the necessary directories: (me@netbsd) mkdir -p /emul/svr4/{dev,etc} (me@netbsd) mkdir -p /emul/svr4/usr/{bin,lib,ucblib} (me@netbsd) mkdir -p /emul/svr4/usr/openwin/{bin,lib} (me@netbsd) mkdir -p /emul/svr4/usr/dt/{bin,lib} 2. Copy files from an svr4 system: (me@svr4) cd /usr/lib (me@svr4) tar -cf - . | rsh netbsd 'cd /emul/svr4/usr/lib && tar -xpf -' (me@svr4) cd /usr/ucblib (me@svr4) tar -cf - . | rsh netbsd 'cd /emul/svr4/usr/ucblib && tar -xpf -' If you are running openwindows: (me@svr4) cd /usr/openwin/lib (me@svr4) tar -cf - . | rsh netbsd 'cd /emul/svr4/usr/openwin/lib && tar -xpf -' (me@svr4) cd /usr/dt/lib (me@svr4) tar -cf - . | rsh netbsd 'cd /emul/svr4/usr/dt/lib && tar -xpf -' 3. You will also probably need the timezone files from your Solaris system, otherwise emulated binaries will run on UTC time. (me@netbsd) mkdir -p /emul/svr4/usr/share/lib/zoneinfo (me@netbsd) mkdir -p /emul/svr4/etc/default (me@svr4) cd /usr/share/lib/zoneinfo (me@solaris) tar -cf -. | rsh netbsd 'cd /emul/svr4/usr/share/lib/zoneinfo && tar -xpf -' (me@netbsd) echo TZ=US/Pacific > /emul/svr4/etc/default/init 4. Set up the configuration files and devices: (me@netbsd) cd /usr/share/examples/emul/svr4/etc (me@netbsd) cp netconfig nsswitch.conf /emul/svr4/etc (me@netbsd) cp SVR4_MAKEDEV /emul/svr4/dev (me@netbsd) cd /emul/svr4/dev && sh SVR4_MAKEDEV all As the major number allocated for emulation of SVR4 devices may vary between NetBSD platforms, the SVR4_MAKEDEV script uses the uname(1) command to determine the architecture the devices nodes are being created for; this can be overridden by setting the MACHINE environment variable accordingly. An alternative method is to mount a whole SVR4 partition in /emul/svr4 and then override with other mounts /emul/svr4/etc and /emul/svr4/dev. BUGS
Many system calls are still not emulated. The streams emulation is incomplete (socketpair does not work yet). Most SVR4 executables can not handle directory offset cookies > 32 bits. More recent ones, compiled for large file support (Solaris 2.6 and up) can. With older programs, you will see the message ``svr4_getdents: dir offset too large for emulated program'' when this happens. Cur- rently, this can only happen on NFS mounted filesystems, mounted from servers that return offsets with information in the upper 32 bits. These errors should rarely happen, but can be avoided by mounting this filesystem with offset translation enabled. See the -X option to mount_nfs(8). The -2 option to mount_nfs(8) will also have the desired effect, but is less preferable. BSD
April 19, 1999 BSD

Featured Tech Videos