crtl-c not working

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers crtl-c not working
# 1  
Old 01-07-2008
crtl-c not working

After I log into a box I run a small script so my backspace works, but after running the script the ctrl-c will not work anymore to break.. Will work before.. The script I run is below... I am on AIX 5.2. Thanks.

set -o vi
export TERM=xterm
export HOST=`hostname`
export PS1='${USER}:${PWD%%*/} $ '

# 2  
Old 01-07-2008
I do not see any code that changes your backspace or anything that would affect how ctrl+c is handled. Can you post the script your running?
# 3  
Old 01-07-2008
It'll be the TERM variable. I'd wager your mapping has switched the control and shift (or sometimes capslock) keys around. Do you get a capital C printed to the screen when you try it from a command prompt? If so, try shift-c.
# 4  
Old 01-07-2008
When I do shift-c I get a cap C. I shell out to the command line as my user, then if I do a su - <other user> and run my prog it won't work but if I just do a su <other user> it will. I wasn't trying to stop a program per se, but I hit ctrl-c alot when I goof on typing something so I can type it again instead hitting enter and getting a error... Thanks.
# 5  
Old 01-07-2008
Are you sourcing that 'script' or running it? (ie . scripname or ./scriptname or scriptname?)

What shell does the user you are su'ing to run? (That syntax you have will only work in a small subset of shells)

su (without the - ) doesn't pick up the targetted user's environment.

What do you see on the screen when you try using control-c after running your script?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Disk Space Utilization in HTML format working in one environment and not working on the other

Hi Team, I have written the shell script which returns the result of the disk space filesystems which has crossed the threshold limit in HTML Format. Below mentioned is the script which worked perfectly on QA system. df -h | awk -v host=`hostname` ' BEGIN { print "<table border="4"... (13 Replies)
Discussion started by: Harihsun
13 Replies

2. Shell Programming and Scripting

Working web service call not working with curl

Hello, Newbie here, I have a perfectly well working web service call I can issue from chrome (PC Windows 10) and get the results I want (a dimmer being turned on in Fibaro Home Center 2 at level 40) I am not allowed to post urls but the below works with http and :// and... (3 Replies)
Discussion started by: abigbear
3 Replies

3. Shell Programming and Scripting

Automating pbrun /bin/su not working, whenever manually it is working using putty

I am trying to automate a script where I need to use pbrun /bin/su but for some reason it is not passing thru the pbrun as my code below. . ~/.bash_profile pbrun /bin/su - content c h 1 hpsvn up file path I am executing this from an external .sh file that is pointing to this scripts file... (14 Replies)
Discussion started by: jorgejac
14 Replies

4. Red Hat

Nslookup working but ping not working at windows client

Hi Team we have created a DNS server at RHEL6.2 environment in 10.20.203.x/24 network. Everything is going well on linux client as nslookup, ping by host etc in entire subnet. We are getting problem in windows client as nslookup working as well but not ping. all the firewall is disabled and... (5 Replies)
Discussion started by: boby.kumar
5 Replies

5. Shell Programming and Scripting

Comparing Data file with Crtl file

Hi, I need to compare a file with its contents matching to that of another file(filename , received date and record count). Lets say has File A original data Ex - 1,abc,1234 2,bcd,4567 3,cde,8901 and File B has details of File A Ex- FILEA.TXT|06/17|2010|3 (filename)|(received... (18 Replies)
Discussion started by: Prashanth B
18 Replies

6. Shell Programming and Scripting

Script not working in cron but working fine manually

Help. My script is working fine when executed manually but the cron seems not to catch up the command when registered. The script is as follow: #!/bin/sh for file in file_1.txt file_2.txt file_3.txt do awk '{ print "0" }' $file > tmp.tmp mv tmp.tmp $file done And the cron... (2 Replies)
Discussion started by: jasperux
2 Replies

7. Shell Programming and Scripting

Script is not working from cron while working manually

Hello, I am facing a very strange problem when I run my script manuallu ./Fetchcode which is using to connect with MKS integrity from linux end it workks fine but when I run it from cron it doesn't work.Can someone help me 1) How could I check my script when it is running from cron like... (3 Replies)
Discussion started by: anuragpgtgerman
3 Replies

8. UNIX for Dummies Questions & Answers

^ C = crtl+C ??

Why ^ C stands for crtl+C in ubuntu shell? also on gvim the shortcuts come this way too with weird symbols (like +gP). Where can I find a list of those? (1 Reply)
Discussion started by: frs
1 Replies

9. Shell Programming and Scripting

Enter Crtl+U character in shell script

hi I have some program which accepts "Crtl+U" input, Now i want to run it thorugh my written script ...all other inputs are accepted but how to supply this input. I am supplying input parameters to the program named EX as below. ================================= . . EX<<EOF... (3 Replies)
Discussion started by: ashish_uiit
3 Replies

10. UNIX for Dummies Questions & Answers


I want to beable to check whether ctrl-d has been pressed in a C++ program under unix. How is ctrl-d represented. any help would be appreciated. true (3 Replies)
Discussion started by: robocop
3 Replies
Login or Register to Ask a Question