forcing irq on PCMCIA card

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers forcing irq on PCMCIA card
# 1  
Old 03-01-2002
forcing irq on PCMCIA card

ENV: linux Version: Mandrake 8.1, PCMCIA card: longshine lcs-8534TB.
(supported according the PCMCIA docs)
laptop is P-II lifetec

PCIC=i82365 ( found via probe -m )
PCIC_OPTS="cs_irq=11 pci_irq_list=11,11 do_scan=0" ( you see i want to force irq 11 )

cat /dev/interrupts BEFORE running /etc/rc.d/init.t/pcmcia start ( in
maintenance mode )
0: 85822 XT-PIC timer
1: 141 XT-PIC keyboard
2: 0 XT-PIC cascade
8: 1 xT-PIC rtc
14: 3461 XT-PIC ide0

cat /dev/interrupts AFTER running /etc/rc.d/init.t/pcmcia start ( in
maintenance mode )
0: 48004 XT-PIC timer
1: 426 XT-PIC keyboard
2: 0 XT-PIC cascade
8: 1 xT-PIC rtc
13: 0 XT-PIC i82364
14: 3461 XT-PIC ide0, i82365
NMI: 0
ERR: 0

What ever i try, irq 13 is always taken. And why is there also a relation with irq 14?
I get a lot of error on the HDA. Eventualy the systems become horrible slow and locks up.

Windows 98 on this system works perfectly. But i want 100% linux on this machine with network support.
any help is welcome.

# 2  
Old 03-01-2002
i cant get your question, are you saying that you totally unable to install you PCMCIA Card in your Laptop. Diffrent Laptops have diffrent process of setting the PCMCIA (depends). Try this

edit etc/sysconfig/pcmcia add:

* this is done automatically during the installation but I want to point out a problem I had
** The PCMCIA services don't want to use the interrupts the way you want them to. (I had to force it to use a specific area of memory and a specific interrupt). If I didn't to this it either conflicted with the sound card or I couldn't get both PCMCIA slots to work. Under this solution I can only use one slot at a time but that isn't a problem for me.

Anyway check this link. (Configuring PCMCIA for laptops)
# 3  
Old 03-01-2002
I am able to install the PCMCIA card but it is giving conflict in a major way.

a fresh installed mandrake 8.1 indeed will set /etc/sysconfig/pcmcia to:

That is what i had too. But now i have a conflict with my IDE because.
as soon as i start pcmcia ( via /etc/rc.d/init.d/pcmcia start ) it goes
into conflict with the irq for my harddisk ( see /proc/interrupts in my first mail ).

cardctl status will give me the status that the pcmcia card installed.
But the laptop gets froozen. I can only try this in mantainance mode.

On normal boot-up, the loading of PCMCIA just freezes. I constanly
hear the harddisk clicking away. I am sure there is an IDE HDA - PCMCIA conflict.

That is why my initial question was, can i force the PCMCIA device to take another irq
then irq 13. I have tried different ways. Via excluding all the irq's in /etc/pcmcia/config.opts.

forcing it via irq_list, pci_irq_list, do_scan=0, ...

Nothing is helping. As i understand you correctly, it can not be forced?
Is this true??.
# 4  
Old 03-04-2002
possible solution at

Keep you informed
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. BSD


Hi there. I have an old laptop Toshiba Tecra 510 (P1, 147MB RAM, 30GB HDD) and I installed FreeBSD 7.2. For networking I have a PCMCIA card for wired network. The problem is that I cannot start and run PCMCIA As I know in Linux there is a tool pcmciautils for this pc-cards, but in FreeBSD I have... (1 Reply)
Discussion started by: hirohitosan
1 Replies

2. UNIX Desktop Questions & Answers

Does Red Hat Fedora support Nvidia card 8800GTX and 260 card?

Does Red Hat Fedora support Nvidia card 8800GTX and 260 card? Does any Linux OS support Nvidia card? (1 Reply)
Discussion started by: sito
1 Replies

3. UNIX for Advanced & Expert Users

Command to Analyze a PCMCIA Card

Is there a command that will verify what type of file system is located on a PCMCIA Card without having to mount the card? Thank you. (1 Reply)
Discussion started by: kilemark
1 Replies

4. UNIX for Dummies Questions & Answers

Error installing linksys pcm200 pcmcia card

Hi, I keep getting an error when I insert a pcm200 card on my laptop. The Error: Card type 32-bit cardbus is unsupported I am using freebsd 4.11 thanks lucky (2 Replies)
Discussion started by: luckyarab
2 Replies

5. UNIX for Dummies Questions & Answers

PCMCIA problems

Hi I recently installed Mandrake 9 on my laptop. It has 2 PCMCIA slots, and in one of them I usually keep one of my network cards (ones an Accton 2216, the other a Surecom EP-427). Under mandrake when my computer started up (and went into runlevel 5) it attempted to start 'network' and then... (2 Replies)
Discussion started by: KrazyGuyPaul
2 Replies

6. UNIX for Dummies Questions & Answers

Network card problem, wrong IRQ

I've installed mandrake 9 and from the start my network card wouldn't work. I ran the network configuration wizard several times and counldn't get it to work. I checked Linux and in the boot message said the IRQ for my network card was 0 but wheni checked windows XP it listed it as 23. I have a... (1 Reply)
Discussion started by: ripmc
1 Replies

7. UNIX for Dummies Questions & Answers

Solaris 8 and PCMCIA

Hi, I justed manged to install Solaris 8 on my Laptop, the only problem I have got is that It does not find my PCMCIA card. I need it to find my card so I can connect the Laptop to my LAN. I am using a 3Com LAN card model number is 3CCE589ET. This card work with Linux with no problems. ... (2 Replies)
Discussion started by: chamkila
2 Replies

8. UNIX Desktop Questions & Answers

How to configure Xircom pcmcia card to Red Hat 7.1?

I currently have an IBM Thinkpad with a built in 56k modem. RedHat 7.1 does not recognize my internal modem. I used a Xircom Ethernet 56 + 100 card. Linux knows the card is there. However, I have been unable to set it up. Please help is possible. (1 Reply)
Discussion started by: adrienb
1 Replies

9. UNIX for Dummies Questions & Answers

PCMCIA Hardware Problem

Hi, I have a Dell Inspiron 4000 that I am using to run Redhat Linux 7.1. This machine had 128Mb of RAM in it, and I upgraded to 512Mb. Since this, the PCMCIA cards have disappeared from the system running under Linux, although they still work under windows and the file "/var/lib/pcmcia/stab"... (1 Reply)
Discussion started by: ghoti
1 Replies

10. UNIX for Dummies Questions & Answers


where can i find the i/o and irq's in mandrake 8 help lost :D (2 Replies)
Discussion started by: RYRY46D9
2 Replies
Login or Register to Ask a Question