vi editor in cygwin

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers vi editor in cygwin
# 1  
Old 01-07-2008
vi editor in cygwin

I have downloaded latest cygwin editor for windows xp.
vi editor is not working on it.
the error i get is "vi : command not found"
I have already seen a post in this forum regarding the issue but the links in the post are broken.
So please help on this issue.
thanks in advance
# 2  
Old 01-07-2008
Use the Cygwin setup.exe to select the programs you want installed.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

vi editor on CYGWIN

vi editor is not working on CYGWIN.Please let me know how to make that work as soon as possible.My work is getting delayed due to this problem. (5 Replies)
Discussion started by: liyakathali
5 Replies

2. Shell Programming and Scripting

opening new instance of cygwin from withing cygwin

I'm using cygwin on win7, What I would like to do is something like this: cygstart cygwin tail -f /foo/test.log | perl -pe 's/error/\e I know I can start a new instance using either of these: mintty -e ... cygstart tail ... But neither of those open in ANSI mode, so I can't do... (0 Replies)
Discussion started by: Validatorian
0 Replies

3. Shell Programming and Scripting

vi Editor on Cygwin

I installed Cygwin today and my vi editor was not working i.e. on while using vi command, I was getting "command not found" error. I realized that many have faced this problem and the previous threads on this have been closed without complete answers. I tried something and it worked. Wanted to... (1 Reply)
Discussion started by: erora
1 Replies

4. UNIX for Dummies Questions & Answers

tip: Simple script won't run in cygwin - vim editor involved

I ran into this issue and thanks to various postings in various forums, was able to figure out the solution but didn't see one posting that laid the whole issue out cleanly. So thought the following might help others ... ------------------------------------------------------------------------... (2 Replies)
Discussion started by: oxysep
2 Replies

5. Shell Programming and Scripting

editor mode in cygwin

Hi, I am using CYGWIN for script testing. I have found that vi command does not work in this. Kindly suggest how can I edit a script that is stored in a file ??? (5 Replies)
Discussion started by: himvat
5 Replies

6. UNIX for Dummies Questions & Answers

cygwin vi editor

now i am new to unix... i installed cygwin on windows because i want to make c++ program... and i need vi editor... whenever i write (vi anything) in the cygwin terminal it says vi: command not found ...since i installed all the packages (1 Reply)
Discussion started by: mostafamagdy
1 Replies

7. Solaris

Epic Editor was not able to obtain a license for your use. Feature Epic Editor :Licen

Epic Editor was not able to obtain a license for your use. Feature Epic Editor :License server is down (1 Reply)
Discussion started by: durgaprasadr13
1 Replies

8. Shell Programming and Scripting

set EDITOR=vi -> default editor not setting for cron tab

Hi All, I am running a script , working very fine on cmd prompt. The problem is that when I open do crontab -e even after setting editor to vi by set EDITOR=vi it does not open a vi editor , rather it do as below..... ///////////////////////////////////////////////////// $ set... (6 Replies)
Discussion started by: aarora_98
6 Replies

9. UNIX for Dummies Questions & Answers

Pasting text in VI editor from a different editor

Hi, I knw its a silly question, but am a newbie to 'vi' editor. I'm forced to use this, hence kindly help me with this question. How can i paste a chunk 'copied from' a different editor(gedit) in 'vi editor'? As i see, p & P options does work only within 'vi'. (10 Replies)
Discussion started by: harishmitty
10 Replies

10. Shell Programming and Scripting

E:348 no string under cursor error comes in vi editor in cygwin

when i open a file to edit and type i to insert and the type # for #!/bin/bash in vi and vim editor the message come that no string under cursor plz somebody help (0 Replies)
Discussion started by: mrityunjay22
0 Replies
Login or Register to Ask a Question