Ultra10 ethernet troubleshooting

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Ultra10 ethernet troubleshooting
# 1  
Old 02-22-2002
Ultra10 troubleshooting!

The problem is alot worse that I thought. I ran the 'test net' after I did the 'stop a' thing and the system worked once, but the second time it froze. No matter what i tried I couldn't get the system out of a frozen state so I had to cycle the power.

I thought lemme check the entire system to see what's going on, so I did a "test scsi" which did nothing for a few seconds and then I was flooded with a "bus fault" message. The system seemed to keep on generating this message and it was stuck in this loop. Again, I had to cycle the power to get a functioning system.

While I am writing this, I tried this one more time. After I cycled the power the link light blinked on on my switch. I ran the 'test net' and everything seemed to check out. When I tried to run it again, the loopback test succeeded but the transceiver test failed with a return code = -1.

I've tried the 'test scsi' which doesn't seem to give any errors right now.

I'm completely lost here. I dunno what I should do. I'm thinking that the hardware is probably faulty which means the guy I bought it from ripped me off.

maybe this isn't entirely true, but i've noticed, that when I do a 'stop a' right after I boot the system I can run the test w/o an error or lockup (although, I seem to only be able to run 'test net' once, after that I get an error or the system freezes), BUT after the system does the filesystem cleanup (from the power off) and brings the integrated nic up, i get error messages.

Does something happen that results in these errors? If someone could explain the bootup workings of an Ultra10 i'd really appreciate it.

The following is the original message I posted:

I'm getting odd problems with my Ultra10's integrated ethernet port.

It seems that the unit works intermittantly. Today it took about 5 minutes before the port light was lit on my switch.

I disconnected the cable and then reconnected it and now the light is off.

Any ideas on this one? Is it hardware failure or is it a setting in Solaris 8 that requires the port to be activated or requires something to happen before the port becomes active?

Last edited by xyyz; 02-23-2002 at 06:02 AM..
# 2  
Old 02-27-2002
this problem has been somewhat resolved.

i was told I needed to add a strong at the end of my /etc/system file indicating auto negotiation for the port.

things seem to be working now, however, they are working at 10mbps instead of 100mbps.

any one know how I can change this?
# 3  
Old 03-06-2002
How to force the HME card to work at 100mb (full-duplex).

If the auto negotiate does not work, then the 100-MB full-duplex mode
can be forced to run at 100-MB, Full-Duplex using the following:

Please try (if using /etc/rc2.d/S99...)

ndd -set /dev/hme instance 0
ndd -set /dev/hme adv_100T4_cap 0
ndd -set /dev/hme adv_100fdx_cap 1
ndd -set /dev/hme adv_100hdx_cap 0
ndd -set /dev/hme adv_10fdx_cap 0
ndd -set /dev/hme adv_10hdx_cap 0
ndd -set /dev/hme adv_autoneg_cap 0

or (if using /etc/system)

set hme:hme_adv_autoneg_cap=0
set hme:hme_adv_100T4_cap=0
set hme:hme_adv_100fdx_cap=1
set hme:hme_adv_100hdx_cap=0
set hme:hme_adv_10fdx_cap=0
set hme:hme_adv_10hdx_cap=0

Note that the order does make a difference.
The link is re-negotiated when the interface is
ifconfig'ed up or when ndd ndd adv_autoneg_cap command is executed.
# 4  
Old 03-06-2002
thank you so much for the reply...

i was given these commands a bit earlier on a newsgroup...

the 'no connection' problem seems to be resolved here... but it brings up another problem.

this port is a 10/100 port... but for some reason the port runs at 10mbps.

any idea how to correct this problem?
# 5  
Old 03-11-2002
The commands given will set your card to work at 100 but the network card must be set to either 100 or to auto-negotiate. Ask your network guys or maybe there is one on this board.
# 6  
Old 03-11-2002
Originally posted by thehoghunter
The commands given will set your card to work at 100 but the network card must be set to either 100 or to auto-negotiate. Ask your network guys or maybe there is one on this board.
what's really odd is that once in a blue moon when the integrated nic actually worked before I entered these settings... it would work at 100mbps.

now, no matter what... it will not.

if anyone can help me configure the internal nick on a Sun AXi board... i'd be forever in your debt.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. IP Networking

TCP/IP troubleshooting

Hello all, Can somebody please tell what is the best book out there that can help me learn TCP troubleshooting and understaning the TCP options like window scaling, large receive offload? I would like to understand how all the TCP tuning parameters function. Is there a book out there that can... (4 Replies)
Discussion started by: Pouchie1
4 Replies

2. Solaris

prtdiag -v troubleshooting

selected lines from the output of the "prtdiag -v" command on a T5240 SUN server running Solaris 10. Are the following known as FRU names and what do they mean? MB/CMP0/BR0/CH0/D0 MB/CMP0/BR0/CH1/D0 SYS/FANBD0/FM0/F0 SYS/FANBD0/FM0/F1 SYS/MB/CMP0/BR1/CH0/D1 ... (1 Reply)
Discussion started by: snoman1
1 Replies

3. Solaris

Failed to recover root password in Solaris 10 on Sparc CPU Sun Ultra10

Failed to recover lost root password for Solaris SunSparc (On Sun Ultra10 - SPARC CPU Hardware, not x86 Intel CPU nor x64 AMD CPU) This Sun Ultra10 workstation comes with an old 6-in wafer probing station purchased from a Surplus equipment vendor. Computer: Sun Ultra 5/10 UPA/PCI... (21 Replies)
Discussion started by: fromtexas0
21 Replies

4. AIX

vio server ethernet to vio client ethernet(concepts confusing)

Hi In the vio server when I do # lsattr -El hdisk*, I get a PVID. The same PVID is also seen when I put the lspv command on the vio client partition. This way Im able to confirm the lun using the PVID. Similarly how does the vio client partition gets the virtual ethernet scsi client adapter... (1 Reply)
Discussion started by: newtoaixos
1 Replies

5. AIX

iSCSI troubleshooting

I have an Equallogic SAN that I connect to from AIX (as well as Windows) I had configured the connection and created the volumes and filesystems and all was working great. Then one day, no communication between the SAN and the AIX (I can ping though) Anything I do on the AIX box at this time... (2 Replies)
Discussion started by: oldmanjoe
2 Replies

6. Ubuntu

Help with troubleshooting crontab

Hello all, When I configured cron jobs that execute bash scripts a while back on my box they worked and the other day I tried to enable cron jobs that execute a bash script to run with no success. cron text file: test.sh file The script has execution rights (e.g. if I use bash... (2 Replies)
Discussion started by: LAVco
2 Replies

7. AIX

AIX troubleshooting

Hi guys, Is there a command in AIX similar to ps, but shows memory usage by application? I'm trying to track down a rogue application that's using up all 32GB of the available systems memory and causing the the system to page to disk. (4 Replies)
Discussion started by: bbbngowc
4 Replies

8. Solaris

help troubleshooting

Hi. I have a Solaris 10 server that's taking about 20secs to respond to telnet or ftp commands. Has anyone ever seen something like that? Can you tell me where to start troubleshooting please? I logged in and did a prtstat, but nothing is jumping out as an issue. (8 Replies)
Discussion started by: bbbngowc
8 Replies

9. UNIX for Dummies Questions & Answers

tftp troubleshooting

Hi I am trying to do a network install of Solaris 10 08_07 onto a Sunfire T2000. I have configured all my network-boot-arguments on the client server (named sundb1). I have installed my image of Solaris on my install server (sun1). But when I try to install using # boot net -s I get the... (0 Replies)
Discussion started by: Bobby76
0 Replies

10. Filesystems, Disks and Memory

adding disk to ultra10

I enquired before about adding another disk to an ultra 10... and was told it was possible... Well - since then I got my hands on another ultra 10 - and have taken the disk out of that one... I should be able to connect it up - but I am wondering - should this be mounted in any partiulcar... (2 Replies)
Discussion started by: frustrated1
2 Replies
Login or Register to Ask a Question