fatal: xmalloc: out of memory

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers fatal: xmalloc: out of memory
# 1  
Old 02-11-2002
Question fatal: xmalloc: out of memory


I was just checking the logs (syslog.dated/date/daemon.log) and came across the following....

Feb 9 06:00:32 xxxx sshd[21489]: fatal: xmalloc: out of memory (allocating 0 bytes)


sshd--> It's the secure shell daemon

We have 400 free pages (page size=8192) and no paging on the system!

What could be the issue?


# 2  
Old 02-11-2002
I have never heard of xmalloc, but that sounds like a private version of malloc. malloc tries to allocate space to a process's data segment. You may be bumping into the max size of the data segment which is typically controlled by a kernel parameter named maxdsiz. There is a system call called setrlimit that can further restrict a process's data segment size, but I doubt that it was invoked for a daemon.
# 3  
Old 02-11-2002
I am sorry, I fogot to mention that this is Tru64 UNIX 40f.

We had to change the shm-max parameter based on
Oracle's recommendation to 2139095040 (2GB-8MB).

But this was almost > a year ago and this is the first time.... we have seen any such message in the syslog.
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Fatal division by zero attempted

Hello. I'm writing an awk script that looks at a .csv file and calculates the weighted grade based on the scores and categories in the file. I keep getting a fatal division by zero attempted error and I know what it means but I've been looking over the code for awhile and am not sure what is... (4 Replies)
Discussion started by: Eric7giants
4 Replies

2. What is on Your Mind?

PHP Fatal Errors During SSL Cert Management - PHP Fatal error: xc_fcntl_mutex failed

Today, I noticed some errors in our SSL cert renewal log files, mostly related to domains where the IP address had changed. Concerned about this, rebuilt out SSL cert, which normally goes well without a hiccup. However, for today, for some reason which I cannot explain, there was a PHP error... (0 Replies)
Discussion started by: Neo
0 Replies

3. Shell Programming and Scripting

Error PHP Fatal error: Allowed memory size of 67108864 bytes exhausted(tried to allocate 401 bytes)

While running script I am getting an error like Few lines in data are not being processed. After googling it I came to know that adding such line would give some memory to it ini_set("memory_limit","64M"); my input file size is 1 GB. Is that memory limit is based on RAM we have on... (1 Reply)
Discussion started by: elamurugu
1 Replies

4. Web Development

PHP Fatal error: Allowed memory size of 134217728 bytes exhausted

Any clues on how to get rid of this PHP error? PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 71 bytes) in /website/www/includes/functions_manpages.php on line 58 PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 71... (4 Replies)
Discussion started by: Neo
4 Replies

5. UNIX for Advanced & Expert Users

fatal: record too large

while running a script to process a file , it ended in termination . I able to find from the logs that it ended due to the error : fatal: record too large 20480 . Then I tried lots to fix the issue and left in vain . Can any one help me in finding reason for it ? . If you provide me a solution , I... (1 Reply)
Discussion started by: sakthifire
1 Replies

6. Programming

ld: fatal error

i am trying to compile my program using a makefile and i keep getting this message: Undefined first referenced symbol in file main /usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.3/crt1.o ld: fatal: Symbol referencing errors. No output written to prog5 collect2: ld returned 1 exit status ***... (2 Replies)
Discussion started by: betterdayz
2 Replies

7. Programming

Fatal Error

Hi, I just pulled out my code from source control, then I compiled, the compilation is successful at that time. Then I modified one of the source file, Then I compiled, I got the following error ld: fatal: Symbol referencing errors. No output written to ../../CM/bin/cato Before... (1 Reply)
Discussion started by: sarwan
1 Replies

8. Programming

ld: fatal error

dear all , iam trying to compile a progam using gcc compiler on a sun 280 R machine running solaris 9 . iam getting an error in the last step when the compiler tries to link the objects , although the compiler executes some applicarions that contains no objects smoothly, the error that... (1 Reply)
Discussion started by: ppass
1 Replies

9. UNIX for Advanced & Expert Users

Fatal error in disk

I have a doubt with an error message, and i want to be sure if this is a normal situation or not. Situation: I was formating and installing a SCSI 36Gb HD with UNIX SCO 5.05, the problem happens when is making the division and filesystem on disk 1, and the message error is "Exit value 139... (1 Reply)
Discussion started by: jav_v
1 Replies
Login or Register to Ask a Question