What happened to mkisofs ?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers What happened to mkisofs ?
# 1  
Old 10-26-2007
Question What happened to mkisofs ?

I've been using a mkisofs line like this for years without problem

# mkisofs -J -R -V 'Vol Label' -o /output/path/FILE.ISO /input/path/

Now, however, it gives a UTR-8 character message at the start

INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.

And if there are any files with, er, special characters the program aborts with this message.

Incorrectly encoded string (Brobälläri.jpg) encountered.
Possibly creating an invalid Joliet extension. Aborting.

After considerable reading, I've come up with this added option and the ISO finishes being made.

-input-charset default

My problem is that I no longer feel confident with the file being generated and want to ask whether this is an appropriate solution. I'm on fedora 6 and I'm sure that has something to do with it. It's the first time on FC6 and I've never run into this problem before.

Issuing this command

# mkisofs -input-charset help

yeilds the following list of character sets but I'm unsure which gives the broadest coverage, or whether the 'default' option is good enough.

Known charsets are:, cp10081, cp10079, cp10029, cp10007, cp10006, cp10000, koi8-u, koi8-r, cp1251, cp1250, cp874, cp869, cp866, cp865, cp864, cp863, cp862, cp861, cp860, cp857, cp855, cp852, cp850, cp775, cp737, cp437, iso8859-15, iso8859-14, iso8859-9, iso8859-8, iso8859-7, iso8859-6, iso8859-5, iso8859-4, iso8859-3, iso8859-2, iso8859-1.

Comments, remarks, ideas, suggestions?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

mkisofs to create iso

Hi all, I got the following problem. I run this command. mkisofs -o mynew.iso -l -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table base images isolinux pc_doc and I get all files from base, images, isolinux and pc_doc in the root dir of the iso. I want a... (2 Replies)
Discussion started by: stinkefisch
2 Replies

2. Solaris

How use the cdrw and mkisofs command...

Hi Guys. I am trying to tranfer the explorer output to a CD .... But I have serious doubt about use the cdrw and mkisofs command.. with the proupose of to make and tranfer the contents. Thank in Advance. AGADEA (5 Replies)
Discussion started by: aggadtech08
5 Replies

3. Shell Programming and Scripting

Mp3 backup using find, mkisofs

Hi. I want to create a Linux script to find all local mp3 files, create an ISO image. Later I will attempt to use growisofs Something like this: find ~ -name "*.mp3" | xargs mkisofs -o musicbackup tried variations on this but no luck. (4 Replies)
Discussion started by: lancest
4 Replies

4. UNIX for Dummies Questions & Answers

Help with mkisofs

Hello, I am attempting to recreate an iso from a set of files. At this point I seem to be stuck on the creation process. I have reviewed man mkisofs, which returns genisofs. Below is the actual command, and what each piece of information seems to provide mike@presario:~$ sudo mkisofs -V... (2 Replies)
Discussion started by: mg92865
2 Replies

5. UNIX for Dummies Questions & Answers

What Happened :(

Hello, I have created a dosrename script and it was working fine unitl today. I can't think what i have changed (don't think i have to be honest). The error is when i run the script it says the file i am trying to rename does not exist when it blatently does. Or is it a typo when i run the... (4 Replies)
Discussion started by: jazz8146
4 Replies

6. Solaris

mkisofs and long file names

Well im using mkisofs to create iso images in Solaris 10 and then i use cdrw -i to burn the images to the cd the problem which i noticed recent ( im new to mkisofs) i noticed its break the long file names making them shorter i searched in its help and i find two parameters one -l and one... (2 Replies)
Discussion started by: XP_2600
2 Replies

7. Shell Programming and Scripting

What happened with AWK?

The second script seems not to work. (3 Replies)
Discussion started by: endeavour1985
3 Replies

8. What is on Your Mind?

what happened to ygor..??

:D anyone hear from ygor..? haven't seen him post in a while... wonder what he is up to..! the last i heard he was the D25khan.. that was him right guys ??? being a newbie myself that is one dude that i admire. him Norsk, Perdebro, RTM , Google and Zazzybob all real genius.. and the most... (2 Replies)
Discussion started by: moxxx68
2 Replies

9. Post Here to Contact Site Administrators and Moderators

what happened?

A few hours ago I made several reasonable posts to this forum and now they have dissapeared. I read and followed the rules, and I sure didn't break any, but gone they are :( I know I only joined the forum today, but do the posts have to be authorised or something? ... (14 Replies)
Discussion started by: cw1972
14 Replies

10. UNIX for Advanced & Expert Users

ISO creation problem :-: mkisofs

Hi, I am trying to burn a directory containing some install scripts/executables etc onto a cd. I am using redhat v7.0. I have tried using mkisofs, but so far have not been able to get the case of the filenames to be correct. one file is called: startInstaller but it always comes out as... (1 Reply)
Discussion started by: ghoti
1 Replies
Login or Register to Ask a Question