Visit Our UNIX and Linux User Community


how cat i run jar from sh


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers how cat i run jar from sh
# 1  
Old 10-03-2007
how cat i run jar from sh

Hello all
im trying to start jar with sh script
i have foo.jar
and i have this sh that does not work ...

PHP Code:
#!/bin/sh
exec java -cp .;foo.jar com.umen.Main 
what im doing wrong here ?
# 2  
Old 10-03-2007
Are you sure about that ".;"? Should it perhaps be "./"?
# 3  
Old 10-03-2007
its does not help
im getting this error :
./foo.jar: ./foo.jar: cannot execute binary file
# 4  
Old 10-03-2007
why do you need exec ? You can just do :
Code:
#!/bin/sh
java -jar path-to-jar

# 5  
Old 10-03-2007
i need to tell java about class path in my case the local place that is ->"."
im reading from there configuration files . so i can't run only the jar
even when i do without the sh
java -cp /.;foo.jar com.umen.Main
or
java -cp .;foo.jar com.umen.Main
im still getting the error :
./foo.jar: ./foo.jar: cannot execute binary file

but when i do :
java -cp foo.jar com.umen.Main (without the ".")
its working , but my java app failed Because it is looking for the configurations files from "."
so why i can't add the "." to -cp ?
# 6  
Old 10-03-2007
do you have the configuration file in the same directory as the jar? If so does the jar have a hard coded path of where the configuration file needs to be stored?
# 7  
Old 10-03-2007
no it does not it uses the java ResourceBundle mechanism
that basically takes the files from the classpath

even if i do :
java -classpath /home/umen;./foo.jar com.umen.Main
it still gives me the error:
/home/umen/foo.jar: /home/umen/foo.jar: cannot execute binary file
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #70
Difficulty: Easy
Unix was developed in AT&T's Bell Labs in the mid-to-late 1950's.
True or False?

7 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Shell file to run other shell files running jar files

Hi, I am trying to write a shell script that will go to another folder and run the script in that folder. The folder structure is kind of like this: /MainFolder/ |-> MainShellScript.sh | |-> Folder1/ |-----|-> script1.sh |-----|-> FileToRun1.jar | |-> Folder2/ |-----|-> script2.sh... (3 Replies)
Discussion started by: sleo
3 Replies

2. Shell Programming and Scripting

Want to write all the jar name in single with delimiter ":" in beween the jar name

Hi All, I am having 7 jar files in a dir. abc like listed below bash-3.00$ cd abc bash-3.00$ ls 123.jar 23wdawd.jar dfsa23.jar dsa.jar wew234.jar adsd234234.jar dfsda423.jarNow i want to assign all this jar files to a variable in the below format ... (6 Replies)
Discussion started by: natraj005
6 Replies

3. Shell Programming and Scripting

jar options..Help..

Hi, Is there an option with jar command which allows us to copy some class files(already existing,want to override)to a jar file without exploding it.? Thanks in advance. (1 Reply)
Discussion started by: dnam9917
1 Replies

4. Solaris

jar from a different folder

Hi , i use below command to create a jar from /home/surya jar -cvf foldername.jar jarfolderpath foldrename.jar= directorywhere jar file needs to be created including jar file name jarfolderpath: directory which needs to be included to create a jar Now taking below scenario:... (1 Reply)
Discussion started by: surya.jena
1 Replies

5. Shell Programming and Scripting

cat in the command line doesn't match cat in the script

Hello, So I sorted my file as I was supposed to: sort -n -r -k 2 -k 1 file1 | uniq > file2 and when I wrote > cat file2 in the command line, I got what I was expecting, but in the script itself ... sort -n -r -k 2 -k 1 averages | uniq > temp cat file2 It wrote a whole... (21 Replies)
Discussion started by: shira
21 Replies

6. UNIX for Dummies Questions & Answers

Difference between cat , cat > , cat >> and touch !!!

Hi Can anybody tell the difference between Difference between cat , cat > , cat >> and touch command in UNIX? Thanks (6 Replies)
Discussion started by: skyineyes
6 Replies

7. Solaris

Jar and tar

I am a beginner to Solaris In Solaris you will find 'jar'. I am used to 'tar' command in Linux. What makes the differenced between 'jar' and 'tar' ? Is 'jar' unique to Solaris? I found a command called 'compress' too in Solaris. It is not in my Linux. Is it something special to... (1 Reply)
Discussion started by: Angelo
1 Replies

Featured Tech Videos