Visit Our UNIX and Linux User Community


Network Card Problem On Linux


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Network Card Problem On Linux
# 1  
Old 02-01-2002
Network Card Problem On Linux

Hi


I just installed linux red hat 7.0 and i can't connect the machine on the network.
Even after i run linuxconfig, when the machine reboots ethernet card eth0 fails to initialize.

Any sugestion would be welcome.
# 2  
Old 02-01-2002
Hi

Personally I don't use RedHat but anyway this is what i would check/try .

What kind of network card you got ?
I suppose you use the standard redhat kernel. Check if the kernel supports your card.

If it does, try to figure out which module supports the card.

Then test the card like this :

modprobe modulename
(e.g. eepro100 for a Intel EtherExpress,
3c90x for a 3Com 905C-TX etc.)

ifconfig eth0 192.168.1.1 up

Obviously replace the IP with the one you want for the system. After that try to ping another machine on the network.
If that works make the changes permanent.

If it still does not work, type dmesg and check its output. You may find some issues there.

Hope that helps.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #445
Difficulty: Easy
Scientific Linux has been loaded onto systems at the International Space Station.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

Linux Red Hat AS3 Network card is not detecting ...

Dear Expert, I 've installed Redhat linux AS3, My machine having Inbuild network card (Intel(R) 82566DM-2 Gigabit Network Connection). I've downloaded e1000e-2.3.2 from Intel site, but its not working for my machine. I'm unable to configure the Network. ifconfig eth0 xx.xx.xx.xx netmask... (0 Replies)
Discussion started by: Mohammed Faiz
0 Replies

2. UNIX for Dummies Questions & Answers

How can I tell which network card is which?

I have three network cards in my unix box. I need to figure out which card corresponds to an assigned IP address. If there some command in unix I can use to make an ethernet interface blink? Any advice would be appreciated. (6 Replies)
Discussion started by: mojoman
6 Replies

3. UNIX for Dummies Questions & Answers

Multi Network card interface problem

My system info is show below:- #uname -a SunOS qfserver 5.8 Generic_117350-29 sun4u sparc SUNW,Sun-Blade-2500 and I have two network card as shown below:- #ifconfig -a lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1 inet 127.0.0.1 netmask ff000000 bge0:... (1 Reply)
Discussion started by: sarifudin
1 Replies

4. SCO

3c905b network card problem with SCO 5.0.5

Hi, I was wondering if anyone could help me out with this problem. I have SCO 5.0.5 installed on a system that I am using 3c905b (3 Com) network card. This system is always powered on. After no certain time period this NIC doesn't work. I can't ping to this system from any other machine or vice... (2 Replies)
Discussion started by: AtALoss
2 Replies

5. Linux

Linux network configuration problem

I have clients that will be connecting to a server (ServerA) through a switch. ServerA connects to the switch through eth0 and i use another ethernet card - eth1 to connect to the Internet through an ADSL router. The clients can access the internet with no problem, i have set up IP forwarding and... (2 Replies)
Discussion started by: robple11
2 Replies

6. UNIX for Advanced & Expert Users

network card problem

hi, everyone: alpha 600 au true64 Unix 4.0f my network cart is set "Auto-Negotiate".After operate system startup,the network will be disconnected by itself at sometime. I found some prompt in /usr/adm/messages. "tu0 :transmit FIFO underflow:threshold raised to :256 byteŁ¬link up... (1 Reply)
Discussion started by: q30
1 Replies

7. IP Networking

Problem accessing network using Linux

Ok, here at work, we have Windows computers which login into a MS domain server. Some of us also have Linux boxes which get a ip address from the dhcp server. We can see other boxes and see the internet until about 1 week ago. Now, we still get a ip address but can't see anything within our... (3 Replies)
Discussion started by: natter
3 Replies

8. UNIX for Dummies Questions & Answers

Network card problem, wrong IRQ

I've installed mandrake 9 and from the start my network card wouldn't work. I ran the network configuration wizard several times and counldn't get it to work. I checked Linux and in the boot message said the IRQ for my network card was 0 but wheni checked windows XP it listed it as 23. I have a... (1 Reply)
Discussion started by: ripmc
1 Replies

9. UNIX for Advanced & Expert Users

Trying to get my USB network card to work with Linux

Ok, heres the deal... Yesterday i installed Unix on my laptop and surprisingly everything works perfect.....exept my network card i have a linksys USB network card (basically a thing you plug into a USB port that is now your NIC card and i connect it to my router) But i have no idea how i... (1 Reply)
Discussion started by: Freakytah
1 Replies

10. IP Networking

network card

I have a UnixWare 2 server that has an ISA 3Com NIC that has just a BNC connector on it. I want to remove this and install an ISA 3Com NIC that has a BNC/RJ45 connector. What steps do I have to go through to successfully complete this? Thye are almost the exact same cards except for the... (1 Reply)
Discussion started by: cparks
1 Replies

Featured Tech Videos