Resetting WTMP?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Resetting WTMP?
# 1  
Old 02-21-2001

When I type last oracle I get dates from Nov 28, 2000 all the way back to the beginning of time it seems. The 11-28-2000 entry states that Oracle is still logged in, but if you type a who, it shows only 1 entry - the currently logged in user (Me as oracle), but I logged in only minutes ago - and the system date shows correct. Why does it not log current users any more? Please advise as soon as possible.
# 2  
Old 02-22-2001
To reste the data (on Solaris);
cat /dev/null > /var/adm/wtmp
cat /dev/null > /var/adm/wtmpx
cat /dev/null > /var/adm/utmp
cat /dev/null > /var/adm/utmpx

Note that last, who, w etc. will not return the correct data until a reboot so if possible it is adviseable to do this right before a reboot.
# 3  
Old 02-22-2001

Is the only way to get correct data (i.e. dates beyond 11-28-2000) is via a reboot? What would cause this issue to begin with?
# 4  
Old 02-22-2001
You can probably go edit the files listed above and just restart utmpd. I have never tried this though. Whats specific OS are you running?
# 5  
Old 02-22-2001
Alpha box
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. AIX

Wtmp empty everyday

Anyone got experience where wtmp logs get truncated everyday? Though sulog, failedlogin and lastlog seems to be fine. The server uptime is 18 days running on AIX 5.3. Sorry this seems to be a generic questions but never really encountered before. (6 Replies)
Discussion started by: depam
6 Replies

2. Red Hat

wtmp output

Hi, Can anybody explain wtmp output fields? A dir was created at 7:11pm and I wanted to find out who was logged in at that time but as you can see there is no ip address listed when I run utmpdump against the wtmp file..... R, D. (1 Reply)
Discussion started by: Duffs22
1 Replies

3. AIX

Clear wtmp

Hello, Is there a difference between the following commands besides consider the file permissions? /usr/sbin/acct/nulladm /var/adm/wtmp >/var/adm/wtmp cat /dev/null >/var/adm/wtmp Today I tried the second command and it worked... (2 Replies)
Discussion started by: x_adm
2 Replies

4. Shell Programming and Scripting

Resetting date

Hi there, Is there a way i can reset the date on my unix terminal to yesterday's date? date Tue Jul 1 14:18:21 GMT 2008 Please let me know. JAK (7 Replies)
Discussion started by: jakSun8
7 Replies

5. AIX

wtmp file

Hello everyone I have a problem with the file wtmp that is on /var/adm This file was not on this directory (adm). I try creating a new file with the correct rights (644) and owner (adm:adm) but It doesnt work. If I type the last command i get this last ora10g ... (4 Replies)
Discussion started by: lo-lp-kl
4 Replies

6. UNIX for Dummies Questions & Answers

truncate wtmp

I have AIX5.1 I have been trying to learn how to truncate the /var/adm/wtmp file. I have seen several things on google actually but don't quite understand. I also searched your forums but couldn't find it. one says this ">/var/adm/wtmp Is that all I do? I have a seperate question also. I was... (1 Reply)
Discussion started by: rocker40
1 Replies

7. UNIX for Dummies Questions & Answers


Hi, is it ok if i delete wtmp on HPUX 11 under /var/adm It is filling up that filesystem Cheers (2 Replies)
Discussion started by: dsharples
2 Replies

8. UNIX for Dummies Questions & Answers

manage the wtmp file

Here's a usefull perl script to trim the wtmp file, in case it got too big, which happens sometimes, or got curropted (which also happens often). You could learn from here how to parse the wtmp file... but of course for just reading its content always simply use "last" like Neo said.... ... (0 Replies)
Discussion started by: me2unix
0 Replies

9. UNIX for Dummies Questions & Answers

Need Wtmp Reader

I would loke to read the WTMP file. This is a binary file in the /var/logs directory. Is there any utility which will convert this binary file to ASCII format? (1 Reply)
Discussion started by: pgold1
1 Replies
Login or Register to Ask a Question