Visit Our UNIX and Linux User Community


Serius ERROR on HPUX 1020


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Serius ERROR on HPUX 1020
# 1  
Old 01-20-2002
Question Serius ERROR on HPUX 1020

-Here's the funny thing -
I have an old HPUX1020 D270 also known as "grandfather"
Everything was all right until today...
The users began to work as usual.
Suddenly The server "kicked" out the users, and when trying to login back - The server returned with 2 different error mesgs:
one is that the "there is no empty /etc/utmp file". The second is that "cannot access /dev/root"
The wired thing is that The system didn't accept any login, including the root's.
I restarted the server and it solved the problem.
When checking the rc.log This is the freaky massages:
(This is only a part of the log)

Thank you !!
# 2  
Old 01-20-2002
soory - I forgot to put the LogSmilieisplay date


Output from "/sbin/rc1.d/S420set_date start":
----------------------------
"/sbin/rc1.d/S420set_date start" SKIPPED

Copy processor logs to /var/tombstones
Output from "/sbin/rc1.d/S430pdcinfo start":
----------------------------
pdcinfo: The host machine is not supported by this program.
ERROR: pdcinfo returned error status=255
"/sbin/rc1.d/S430pdcinfo start" FAILED

Save system core image if needed
Output from "/sbin/rc1.d/S440savecore start":
----------------------------
EXIT CODE: 2 - savecore found no core dump to save
"/sbin/rc1.d/S440savecore start" SKIPPED

Enable auxiliary swap space
Output from "/sbin/rc1.d/S500swap_start start":
----------------------------
Enabling device paging on /dev/vg00/lvol9.
swap device(s) active
# 3  
Old 01-22-2002
Have you checked the amount of free space on the / partition? The reason it might be working once you reboot it because on startup, many HP-UX systems will clean out tmp and other directories. I am very new to HP-UX administration, although I just got my hands on an old workstation running 10.20, and had a similar problem when I accidentally performed a runaway search that was dumping output to a file in /tmp... I filled up my root partition and bad things started to happen.

Also, did someone change permissions anywhere in the root directory? When I inherited this workstation, I pounded my head against the wall trying to figure out why non-root users couldn't log in... until I finally stopped looking at file permissions and checked the permissions of the / dir...

Also, I am not familiar with tombstones, but if you need them to, a HP CE/SE should be able to diagnose the problem... Also check syslog.log...
# 4  
Old 01-22-2002
Just saw this little trick at the ITRC at HP's website:
Quote:
Quick and easy way to check if your server just rebooted itself or crashed due to a hardware problem;

cd /var/tombstones
grep chassis $(ls | tail -1)

If it says; No HPMC chassis codes logged

Then no hardware problem. If there are some hex numbers there then you need to pass them to HP to check what hardware caused the problem.
Check out: http://forums.itrc.hp.com/cm/FamilyHome/1,,117,00.html for lots of Q&A for HP-UX.
# 5  
Old 01-23-2002
It Happened again today.
This time the system didn't crash - It just created a core file (37 mb ) which captivated 40% of the root.
I called HP. and run this "ps -ef" thing you talked about,
I'll inform you later
Thanks
# 6  
Old 01-23-2002
The Permissions on "/" looks ok.
What's on /dev/root?
is says in the syslog "vx-nospaces on /dev/root"
The root is in 66%
/tmp is in 4%

I'm trying to run nickel but it won't say anything.
I'm probably missing something crucial...
Any ideas?
# 7  
Old 01-23-2002
Hmm... try the command: bdf -i
Can you paste the output back here? I wonder if you're out of i-nodes...
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #931
Difficulty: Medium
64-bit computer system storage allocation for timekeeping will allow them to represent dates more than 300 billion years into the future.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

HPUX Syntax error at line 9 : `<' is not expected

Hi All, i'm getting this error, can somebody check? file name is like this 951957039339019_560119_000523_2w47_3060_0038_6002.log filename=$(basename "$1") extension="${filename##*.}" filename="${filename%.*}" IFS="_" read -r -a array... (2 Replies)
Discussion started by: charli1
2 Replies

2. Slackware

Hp 1020 laser jet Printer doesn't work on slackware 13.1

when i attach HP 1020 leaser jet printer on slackware 13.1 via usb port it detects and display message "Ready to print", in printing window (start->setting->printing) it detects & its properties(Printer->properties) is Description : Hewlett-Packard HP LaserJet 1020 Location : Divya Device... (0 Replies)
Discussion started by: hitlar
0 Replies

3. HP-UX

mk_kernel : "dev_config" error (hpux 11.23)

Any clue why I'm getting the error below? I would greatly appreciate any help. HP ITRC is already engaged since this morning but until now I haven't got any resolution. I'm wondering if anybody out there got an idea on how to fix this. Thanks in advance. This is my system: HPUX11i-OE-Ent... (2 Replies)
Discussion started by: msgameng
2 Replies

4. HP-UX

pwage-hpux-T for Trusted HPUX servers

I'm sharing this in case anybody needs it. Modified from the original solaris pwage script. This modified hpux script will check /etc/password file on hpux trusted systems search /tcb and grep the required u_succhg field. Calculate days to expiry and notify users via email. original solaris... (2 Replies)
Discussion started by: sparcguy
2 Replies

5. Shell Programming and Scripting

Problem with awk awk: program limit exceeded: sprintf buffer size=1020

Hi I have many problems with a script. I have a script that formats a text file but always prints the same error when i try to execute it The code is that: { if (NF==17){ print $0 }else{ fields=NF; all=$0; while... (2 Replies)
Discussion started by: fate
2 Replies

6. Shell Programming and Scripting

hpux vi

Hello. I cant figure out how can i move entire row up , so it pasted on the one above at the end , or to do that for one character. In notepads,word, or some other text editors we would do that with backspace button. Example. Content of my text file is this : I am trying to do that. And... (2 Replies)
Discussion started by: tonijel
2 Replies

7. Shell Programming and Scripting

Need Script to Use CPUs on a HPUX server to simulate Workload Manager on HPUX.

I am running HPUX and using WLM (workload manager). I want to write a script to fork CPUs to basically take CPUs from other servers to show that the communication is working and CPU licensing is working. Basically, I want to build a script that will use up CPU on a server. Any ideas? (2 Replies)
Discussion started by: cpolikowsky
2 Replies

8. Shell Programming and Scripting

.profile file error on HPUX 11.11

Hi, I am working on HPUX 11.11i and 11.10 boxes. My default shell is ksh. I have the following entry in my profile file HOSTNAME=`uname -n` Every time I login to the server, this is the error I get: ${HOME:-.}/.profile: syntax error: `)' unexpected The line number shown... (1 Reply)
Discussion started by: Yomaanmean
1 Replies

9. UNIX for Dummies Questions & Answers

make is giving error while installing cups in hpux

m installing cups-1.2.12 in hp-ux ./configure didnt give any error. but make gives the following error making all in cups... Compiling adminutil.c... In file included from http-private.h:142, from globals.h:35, from adminutil.c:47: /usr/include/net/if.h:240: error: field 'iftp_local' has... (5 Replies)
Discussion started by: rosalina
5 Replies

10. HP-UX

import disk in HP-UX 1020

Hi, is it possible to import a disk into a system, and to mount it without overwriting all data on this disk? thanks (7 Replies)
Discussion started by: Olivier
7 Replies

Featured Tech Videos