Visit Our UNIX and Linux User Community


error in shell script


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers error in shell script
# 1  
Old 05-18-2007
error in shell script

Hi,

I have written a small shell script which logs into each oracle database on the server and displays whether it is in archivelog mode or not.. The script is as under:


#!/bin/bash
dblist=`ps -ef | grep smon | grep -v grep |cut -d'_' -f3`
for ohome in $dblist; do
sqlplus -s /nolog << EOF
connect / as sysdba ;
ORACLE_SID=$ohome; export ORACLE_SID
set heading off
set feedback off
set verify off
output=`select log_mode from v$database;`
exit;
EOF
echo $ohome
echo $output | sort -u
done

When I run it .. i received errors as under:

jalpan.sh: select: not found
Connected.
SP2-0734: unknown command beginning "ORACLE_SID..." - rest of line ignored.
SP2-0042: unknown command "output=" - rest of line ignored.
bnkdbp01

jalpan.sh: select: not found
Connected.
SP2-0734: unknown command beginning "ORACLE_SID..." - rest of line ignored.
SP2-0042: unknown command "output=" - rest of line ignored.
dosdbp01 --> Oracle Database Name

Pls help

Thx in advance
# 2  
Old 05-18-2007
1. is the ORACLE_SID line supposed to be before the sqlplus line?

2. Are the 'set x y' lines as part of the SQL*PLUS script supposed to have a ';' at the end?

3. The 'output', it looks like you are trying to assign in the SQL*PLUS script but have it magically read by the shell script.
# 3  
Old 05-18-2007
Hi,

Reg your point 1 and 2 , you are correct. I did modify it and its working

Reg point 3. i removed ref to output variable and just kept select stmt and it worked

Thanks again for your guidance
 

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Shell script with sql script error

Hi All when I execute from psql prompt, I get the result, when I try to automate using a shell script, the query is not working # `/usr/bin/psql -U postgres -d coba1 -c "select name from users where "Date" > current_date - 30;"` ERROR: column "Date" does not exist LINE 1: select... (2 Replies)
Discussion started by: srilinux09
2 Replies

2. Shell Programming and Scripting

Calling shell script within awk script throws error

I am getting the following error while passing parameter to a shell script called within awk script. Any idea what's causing this issue and how to ix it ? Thanks sh: -c: line 0: syntax error near unexpected token `newline' sh: -c: line 0: `./billdatecalc.sh ... (10 Replies)
Discussion started by: Sudhakar333
10 Replies

3. Shell Programming and Scripting

Error in calling a shell script from another script

HI, We are using two shell scripts, script.sh,env.sh, where env.sh will be called inside script.sh. The variable inside env.sh is used as $var in script.sh.But while running the script its not identifying that variable. Is there any permission needed to call a script inside another script. ... (3 Replies)
Discussion started by: banupriyat
3 Replies

4. Shell Programming and Scripting

Syntax error calling TCL script from shell script

hello everyone i am beginner on shell scripting .and i am working on my project work on ad hoc network i wrote a batch (.sh) to do a looping and execute a tcl script i wrote before in each iteration ..but i got this problem " syntax error near unexpected token `('... (1 Reply)
Discussion started by: marcoss90
1 Replies

5. Shell Programming and Scripting

Error in Shell script

Hello All, I am newbe to scripting and have just taken over following script from previous developer. I am getting following error when running the script. line 70: syntax error near unexpected token `do Could some help me to rectify the error please. Thanks in advance for your... (9 Replies)
Discussion started by: Pahadia
9 Replies

6. Shell Programming and Scripting

How to grep sql error in shell script and exit the script?

I need help in the following script. I want to grep the sql errors insert into the error table and exit the shell script if there is any error, otherwise keep running the scripts. Here is my script #!/bin/csh -f source .orapass set user = $USER set pass = $PASS cd /opt/data/scripts echo... (2 Replies)
Discussion started by: allinshell99
2 Replies

7. Shell Programming and Scripting

Shell script error

Hi, I have the following table in MYSQL: (the structure looks broken in this forum but if you copy/paste it into notepad, it'll look right): +----------------------------+-----------------------+------+-----+---------+----------------+ | Field | Type |... (0 Replies)
Discussion started by: tezarin
0 Replies

8. UNIX for Dummies Questions & Answers

Shell Script Error

Sorry typo found please ignore (0 Replies)
Discussion started by: jazz8146
0 Replies

9. UNIX for Dummies Questions & Answers

awk Shell Script error : "Syntax Error : `Split' unexpected

hi there i write one awk script file in shell programing the code is related to dd/mm/yy to month, day year format but i get an error please can anybody help me out in this problem ?????? i give my code here including error awk ` # date-month -- convert mm/dd/yy to month day,... (2 Replies)
Discussion started by: Herry
2 Replies

Featured Tech Videos