Cannot do this simple thing


 
Thread Tools Search this Thread
# 1  
Cannot do this simple thing

I think its a bash thing and it is really annoying me..

its difficult to explain the problem but I will try..

When I type a command on the shell prompt... then lets say I go back to the 2nd letter and correct a typo.. after that I cannot get the cursor beyond the last alphabet that I had typed..

In the following.. type is in red and position of cursor is: ^

% ./a.out -g file.txt -n 15
^

Then I correct the typo..

% ./a.out -f file.txt -n 15
^

then I want to continue ahead and complete the command

% ./a.out -f file.txt -n 15
^

but my cursor wouldnt go beyond the last character (5 in this case) aaargghh !!! Smilie

So I have to delete 5 using "x", now the cursor comes to 1..and I cannont go beyond that !!!!!

Smilie
# 2  
oops, the cursor position did not come out properly..let me try again..

% ./a.out -g file.txt -n 15
^

Then I correct the typo..

% ./a.out -f file.txt -n 15
^

then I want to continue ahead and complete the command

% ./a.out -f file.txt -n 15
^
# 3  
try shift a that should do it.
# 4  
well, first the cursor is just after the '5'
second its just after the 'f'

third, the cursor is *on* the '5'
# 5  
Thanks Johnf !! that worked.. !! Smilie
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #397
Difficulty: Medium
HP-UX 11i offers a common shared disks for its clustered file system.
True or False?

7 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Difference between two cmmands that did the same thing

Hello everybody, Can you please help me unerstand the difference between: # grep word_we_are_looking_for /directory/file and # more /directory/file |grep word_we_are_looking_for I know that the result is the same. Thank you for your help. Please use next time code tags for your... (5 Replies)
Discussion started by: adilyos
5 Replies

2. Ubuntu

need some help on this jolicloud thing??PLease help !!!!

i am not used to linux ubuntu... i get the same error code while booting from jolicloud.... can you help, please??????? i can't directly installed it because everytime i tried it, installation panel freezes, so i waited and it booted from live cd.... i tried to install jolicloud... (0 Replies)
Discussion started by: cemdede@hotmail
0 Replies

3. UNIX for Dummies Questions & Answers

is there any thing like RPM for sun and hp 10 ?

Hello im trying to find good solution for packaging, I was reading about the RPM for linux is there such thing for sunOs and Hp 10? if not is there any thing simellar ? thanks (1 Reply)
Discussion started by: umen
1 Replies

4. OS X (Apple)

Ok another small thing if anyone knows...

Hi i wanna change the look of my terminal. For example i wanted a black background and like a cyan colored text so it stands out against the black. Is there anyway i can do this?. I am running Mac OSX if that helps any at all (2 Replies)
Discussion started by: Corrail
2 Replies

5. UNIX for Dummies Questions & Answers

Shortcut thing?

Hey, im new to Linux...totally new. I know there is a way to assign a type of variable or something to a directory, so instead of having to type "cd /var/www" etc, I could just assign a variable to the directory, so I could just do "cd $assignedvar" and it would be there...if you get what I... (0 Replies)
Discussion started by: mo0ness
0 Replies

6. UNIX for Dummies Questions & Answers

very simple shell thing..

set a = 5 set b = a echo $b a // will print a I want to get echo ${$b} // something expression like this to get value of 'a' by accessing the value of b. 5 ie. fetching the value of a with the inputs of b ( frm b --thro a ---5) Is it possible to execute something like this? ... (2 Replies)
Discussion started by: sskb
2 Replies

7. UNIX for Dummies Questions & Answers

Dumb thing to do

I'm writing for a friend. He has a SPARC system at home that has Solaris 7 on it. He did not yet create a user on it and has not set the CONSOLE to allow the root user to log in remotely. Now, something happened and the system will not even boot to the Boot PROM. How can he get into the system... (4 Replies)
Discussion started by: danh
4 Replies

Featured Tech Videos