Problem installing gcc


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem installing gcc
# 1  
Old 12-11-2001
Question Problem installing gcc

Hi! I have downloaded a precompiled gcc package but I'm having problems installing it. It is supposed to install in /usr/local and there is plenty of space left there but during the installation I get the following error message No space left on device. Is it some kind of temp folder that is out of space? And if so how can I set the installation to use some other partition as temp folder?

I have printed out the installation output and my partition information here:

# pkgadd -d gcc-2.95.3-sol8-sparc-local

The following packages are available:
1 SMCgcc gcc
(sparc) 2.95.3

Select package(s) you wish to process (or 'all' to process
all packages). (default: all) [?,??,q]: all

Processing package instance <SMCgcc> from </usr/anwi/gcc/gcc-2.95.3-sol8-sparc-l
ocal>

gcc
(sparc) 2.95.3
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/cc1", errno 28
, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/cc1chill", err
no 28, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/cc1obj", errno
28, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/cc1plus", errn
o 28, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/chillrt0.o", e
rrno 28, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/collect2", err
no 28, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/cpp0", errno 2
8, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/f771", errno 2
8, No space left on device
cpio: Cannot write "reloc/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/gmon.o", errno
28, No space left on device
cpio: Cannot write ", errno 28,
cpio:

pkgadd: ERROR: attempt to process datastream failed
- process </usr/bin/cpio -icdumD -C 512> failed, exit code 41
pkgadd: ERROR: unable to unpack datastream

Installation of <SMCgcc> failed (internal error).
No changes were made to the system.
#


This is my partition information:

bash-2.03$ df -b
Filesystem avail
/dev/dsk/c0t0d0s0 33636
/dev/dsk/c0t0d0s7 5021665
/proc 0
fd 0
mnttab 0
/dev/dsk/c0t0d0s3 9919
swap 214120
/dev/dsk/c0t0d0s5 22106
swap 214120
/dev/dsk/c0t0d0s1 137896

bash-2.03$ df
/ (/dev/dsk/c0t0d0s0 ): 67272 blocks 43328 files
/usr (/dev/dsk/c0t0d0s7 ):10043282 blocks 859164 files
/proc (/proc ): 0 blocks 3829 files
/dev/fd (fd ): 0 blocks 0 files
/etc/mnttab (mnttab ): 0 blocks 0 files
/var (/dev/dsk/c0t0d0s3 ): 19838 blocks 15346 files
/var/run (swap ): 428240 blocks 26391 files
/opt (/dev/dsk/c0t0d0s5 ): 44212 blocks 14919 files
/tmp (swap ): 428240 blocks 26391 files
/usr/openwin (/dev/dsk/c0t0d0s1 ): 275792 blocks 184062 files
# 2  
Old 12-11-2001
Lets see what a df -k looks like. I'd be willing to bet it is trying to install somewhere other than /usr/local (or /usr/local is full)

Shimb0
# 3  
Old 12-12-2001
Hi! Thank you for trying to help me!

I have included the df -k information at the bottom of this message and as you can see there is plenty of space at /usr.

I have downloaded the package from www.sunfreeware.com and the text says gcc-2.95.3-sol8-sparc-local.gz compiled GNU C/C++/FORTRAN/Java compiler package installs in /usr/local.. So I thought I was just supposed to write pkgadd -d gcc-2.95.3-sol8-sparc-local.gz to install gcc to /usr/local.

I have just tried to install gcc on another Ultra 5 computer with just one big / partition and the swap partition and the installation went fine! Everything installed nicely under /usr/local/bin. I don't know if it is linked there form somewhere else but at least it worked and that's enough for me! :-)

I'm not that used to work with Solaris (or any kind of Unix at all) but I'm really tired of moving the partitions every time I want to install a new program so I have decided I'm goanna back up all my files and reinstall Solaris with only one big partition (like our other Ultra 5). It might not be the best solution but in the end I think it would be the easiest way for me.

Than you anyway!



# df -k
Filesystem kbytes used avail capacity Mounted on
/dev/dsk/c0t0d0s0 84343 51097 24812 68% /
/dev/dsk/c0t0d0s7 7168133 2352933 4743519 34% /usr
/proc 0 0 0 0% /proc
fd 0 0 0 0% /dev/fd
mnttab 0 0 0 0% /etc/mnttab
/dev/dsk/c0t0d0s3 34335 24496 6406 80% /var
swap 101672 8 101664 1% /var/run
/dev/dsk/c0t0d0s5 24239 2133 19683 10% /opt
swap 102016 352 101664 1% /tmp
/dev/dsk/c0t0d0s1 380815 242919 99815 71% /usr/openwin
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Installatin problem in installing gcc-4.9.0

Hi to all, i'm installing gcc-4.9.0 into my RedHat 6.4 pc. I configure like this :- # mkdir objdir # ./../gcc-4.9.0/configure # make and now having this problem :- checking for x86_64-unknown-linux-gnu-gcc... /software/gcc/objdir/./gcc/xgcc -B/software/gcc/objdir/./gcc/... (0 Replies)
Discussion started by: rahulvishwa
0 Replies

2. Solaris

GCC installing

dear, please just didn't understand the problem that appears when i try to install ./configure here is the message that appears in unix when installing gcc root@ccbtest # ./configure checking build system type... /bin/bash: ./config.guess: No such file or directory configure: error: cannot... (3 Replies)
Discussion started by: semaan
3 Replies

3. Solaris

Help with installing gcc on Solaris 10

I want to install gcc for Solaris 10 to an alternate location besides /usr/local/bin, so I can't use the pre-compiled package from sunfreeware.com. So I assume I need to compile gcc for myself and specify --prefix. How can I accomplish this? Am I pretty much out of luck trying to compile... (3 Replies)
Discussion started by: srhadden
3 Replies

4. Solaris

Installing gcc - recieve error message gcc : cannot execute

AIM- Install Oracle 11g on Solaris using VMWare Steps 1.Logged on as root 2.Created subfolders /usr/local/bin & /usr/local/bin/gcc 3.Downloaded gcc & libiconv & unzipped them on my harddrive & burnt them on CD 4.Copied files from CD to /usr/local/bin/gcc 5.Terminal (root) pkgadd -d... (8 Replies)
Discussion started by: Ackers
8 Replies

5. Solaris

Installing gcc 2.8.1 on Solaris 10

Folks - This may sound like a newbee question - and it is. But a project that I'm managing is under a time crunch and I need a quick answer. IS it possible to install gcc 2.8.1 on a Solaris 10 Sun box? We have some old libraries that need that version of the compiler in order to work... (2 Replies)
Discussion started by: peridot
2 Replies

6. Solaris

Error when installing GCC

GCC 3.4.6 was installed in Solaris 2.8. I ran the commands ./configure and make. When running make install I got the below mentioned errors at the end. Please help me in resolving the same. make: *** Error 1 make: Leaving directory `/gmsp/antony/gcc-3.4.6/sparc-sun-solaris2.8/sparcv9/libf2c'... (1 Reply)
Discussion started by: chrisanto_2000
1 Replies

7. Solaris

error while installing gcc

Hi friends, i down loaded the gcc*.gz file and i am getting the following error when i am trying to install it on solaris 8 ======================================================= Processing package instance <SMCgcc342> from </export/gcc-3.4.2-sol8-sparc-local> gcc (sparc) 3.4.2 FSF... (1 Reply)
Discussion started by: sveera
1 Replies

8. Programming

Installing gcc

Hi all I'm trying to install the latest version of gcc but I keep getting this message on make; gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./../zlib -I./../include -W -Wall -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -g -O2 -c jartool.c jartool.c:234: getopt.h: No... (3 Replies)
Discussion started by: squeakywheel
3 Replies

9. Programming

installing gcc-3.1 on Irix 6.5.15

I am trying to install gcc-3.1 in an SGI Indigo2 running Irix 6.5.15. When I try to configure gcc-3.1 I keep getting the following message: Created "Makefile in gcc/ using "mh-frag" cc ERROR: cannot exec /usr/lib32/cmplrs/fec *** The command 'cc -o conftest -g conftest.c' failed *** You... (0 Replies)
Discussion started by: mdbanas
0 Replies

10. Programming

Help!(Installing GCC.)

(Installing GCC: Configuration) In the document of Installing GCC, there is a sentence I don't understand: " Second, when configuring a native system, either cc or gcc must be in your path or you must set CC in your environment before running configure. Otherwise the configuration scripts... (2 Replies)
Discussion started by: wwz
2 Replies
Login or Register to Ask a Question