Login or Register to Ask a Question and Join Our Community


File Permission Problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers File Permission Problem
# 1  
Old 01-11-2007
Data File Permission Problem

Hi,I am a newbie, in a hp-ux box,i create a file testfile as root,
ls -l testfile
-rw-r--r-- 1 root sys 1 Jan 11 17:51 testfile
then l login the box as user ivan,then I execute
rm testfile
It prompts me testfile : 644 mode ? (y/n) ,if I enter y,then the testfile is deleted.So why could other user delete that file,it seems impossible according to the file permission setting ?
Thanks you all !
# 2  
Old 01-11-2007
You are allowed to do this because your user ivan has write permissions on the directory which this file is in.
# 3  
Old 01-11-2007
no, ivan has no write permission to the directory where testfile is in, actually in my opinion, according to the permission setting, the permission of the file should overwrite the permission of the directory, am i right ?
# 4  
Old 01-11-2007
Type ls -al of the directory where the file is in.
ie:
If the file is in directory /var/test type ls -al /var/test and post the output here.
Tornado
# 5  
Old 01-11-2007
^_^
# ls -al /testdir
total 16
drwxr-xr-x 2 root sys 96 Jan 11 19:14 .
drwxr-xr-x 24 root root 8192 Jan 11 19:14 ..
-rw-r--r-- 1 root sys 0 Jan 11 19:14 testfile

ls -ld /testdir
drwxr-xr-x 2 root sys 96 Jan 11 19:14 /testdir
# 6  
Old 01-11-2007
According to that, Ivan should not be able to remove the file..
Code:
bash-2.05$ ls -al testdir
total 32
drwxr-xr-x   2 root     sys         182 Jan 11 23:03 .
drwxr-xr-x   3 root     root         181 Jan 11 23:02 ..
-rw-r--r--   1 root     sys           0 Jan 11 23:03 testfile
bash-2.05$ rm testfile
rm: testfile: override protection 644 (yes/no)? yes
rm: testfile not removed: Permission denied
bash-2.05$

Tornado
# 7  
Old 01-11-2007
Thanks Tornado, maybe there is something wrong with my unix box, I have tried in another one, it worked in the correct way, thanks !
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Slackware

K3b permission problem

When I set up to backup /home to a DVD I am incurring a problem with K3B ver. 2.0.2 saying I (root) has insufficient privileges to access /home/myuser/hp-check.log file. It also does this to the lost+found files for /home and /opt. I am root and the file/directory has read+write privs for root.... (1 Reply)
Discussion started by: slak0
1 Replies

2. Shell Programming and Scripting

Problem with execute my file permission

Here is my script. 1 echo -n "Enter file name : " 2 read file 3 chmod 777 $file 4 && W="write = yes" || W="Write = no" 5 chmod 777 $file 6 && X="Execute = yes" || X="Execute = No" 7 chmod 777 $file 8 && R="Read = yes" || R="Read = No" ... (0 Replies)
Discussion started by: qral_hdr
0 Replies

3. UNIX for Dummies Questions & Answers

Permission problem

How would i change permissions for a new directory so that i am the only one who has any access to any of the files created in it (2 Replies)
Discussion started by: trob
2 Replies

4. UNIX for Dummies Questions & Answers

file permission problem

Hello I have situation where with my user id (group x) I am able to view a file. However if su to another user (different group) I am not able to view. I get permission denied. The file has complete wide open permissions -rwxrwxrwx and I can also cd from root to the directory in which the file... (3 Replies)
Discussion started by: akumargolf2000
3 Replies

5. Solaris

file permission problem

Hi Expert, Could you tell me what is the meaning of " + " as shown below: drwxr-xrwx+ /opt Thanks. (2 Replies)
Discussion started by: skully
2 Replies

6. Linux

dos2unix permission problem

Hi All, I want to use the command "dos2unix" to format the file line break from win to unix, but after changing the file permission has been change to 600. how can i keep the original permisson after formatting? Many thz (2 Replies)
Discussion started by: eric_wong_ch
2 Replies

7. Solaris

Permission Problem

I ran the sys-unconfig command and now I can't seem to change the permission on that folder evne though I'm the Superuser(Root admin). I need to fix this so the user 'tommy' can login and have his home directory working. How do I fix this??? http://www3.telus.net/superstar/error.jpg (6 Replies)
Discussion started by: kungpow
6 Replies

8. UNIX for Dummies Questions & Answers

unable to delete file for permission problem

Hi, We are facing problem to delete some logfiles. Explaing with example for clear understanding : we have 2 accounts : prdpqrs (application account) & prodxyz (admin account - not root). Both of them are in same group called 'release' While prodxyz is trying to remove a file owned by... (4 Replies)
Discussion started by: sabyasm
4 Replies

9. Forum Support Area for Unregistered Users & Account Problems

Permission problem

I am having problems editing my options and profile etc. Whenever i do, i am getting a message that says I don't have any permissions. Can u tell me a solution. (2 Replies)
Discussion started by: rockyrak
2 Replies

10. UNIX for Dummies Questions & Answers

File permission problem

I have a crontab job that runs a database backup and directs the output to a log. I ran the job, and the output log file was created with no problems, but now if I try and run the same job again, I keep getting a file exists error. The permissions are: -rw-rw-r-- I also tried changing the... (2 Replies)
Discussion started by: jodie
2 Replies
Login or Register to Ask a Question

Featured Tech Videos