Visit Our UNIX and Linux User Community


unable to delete a file


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers unable to delete a file
# 1  
Old 12-01-2006
unable to delete a file

Hi ..

I am trying to deleta a file but i cant do the error i get is

rm: hs_pdref_custom_dict_PG1_out_76_out non-existent

but when i do ls it is listing the in the directory ...
please find the filed below....

-rw-r----- 1 tsta107 users 118011030 Dec 1 04:07 hs_pdref_custom_dict_PG1_out_76
-rw-rw-r-- 1 tsta107 users 118011030 Dec 1 04:12 hs_pdref_custom_dict_PG1_out_75_out
-rw-rw-r-- 1 tsta107 users 23161856 Dec 1 04:14 hs_pdref_custom_dict_PG1_out_76_out

thanks in advance ..

Arun
# 2  
Old 12-01-2006
permissions issue ? have you tried "rm -rf" ?
# 3  
Old 12-01-2006
yeah i did that but still the file is not getting deleted and also the file appears in the listing
# 4  
Old 12-01-2006
Perhaps some "non visible" character is part of its name...
Try, for instance:
Code:
find . -name "*hs_pdref_custom_dict_PG1_out_76_out*" -exec rm -i {} \;

# 5  
Old 12-01-2006
Quote:
Originally Posted by arunkumar_mca
yeah i did that but still the file is not getting deleted and also the file appears in the listing
Some process must be using that file. See the man pages of fuser or lsof. Use that.
# 6  
Old 12-01-2006
Maybe there are nonprintable characters in the filename. Try to find out the inode number (e.g. on aix):
Code:
c000@atschux2> ls -i
 2054 smit.log           2055 smit.script        2056 smit.transaction
c000@atschux2> find . -i 2054 -ls
 2054    1 -rw-r--r--  1 c000      dba            985 Jul 22  2005 ./smit.log
c000@atschux2> find . -i 2054 -exec rm {} \;

# 7  
Old 12-01-2006
Graig,

I tired the command which you gave me.It prompted for Y/N and when i selected Y it ran succesfully.But file still list in the ls command.

Vino,
We dont have fuser permission and there is not manual for lsoft. Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #855
Difficulty: Medium
JSX (JavaScript XML) is an extension to the JavaScript language syntax.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Tried many options but unable to delete blank lines from text file

Hi, I tried the following options but was unable to delete blank lines from file Input file = temp.hash.txt temp.hash.txt content 90 0 89.56 0 0 57575.4544 56.89 (9 Replies)
Discussion started by: uuuunnnn
9 Replies

2. AIX

Unable to delete files

heapdump716960.1416296627.txt heapdump716960.1416299494.txt heapdump716960.1416302375.txt trying to delete the above files root@atec:/oratec/prodcomn/temp>rm heap*.*.txt ksh: /usr/bin/rm: 0403-027 The parameter list is too long. root@atec:/oratec/prodcomn/temp>rm heap*.txt... (2 Replies)
Discussion started by: filosophizer
2 Replies

3. HP-UX

Unable to delete iscsi target

Hi Please can someone give me a hint on this, when I list the targets, I see two o them: #iscsiutil -p Operational Target Information ------------------------------ Target # 1 ----------- Target Name : iqn.1992-08.com.netapp:sn.142241859 Target Alias ... (2 Replies)
Discussion started by: fretagi
2 Replies

4. Solaris

Unable to delete directory even with 777 perm

Hi, I have an 'empty' directory 'tmp' of which I am the owner and 777 permission. But when I try to delete the directory using rmdir or rm command, it gives error. Command prompt snapshot: => uname SunOS ... (4 Replies)
Discussion started by: platinum81
4 Replies

5. Shell Programming and Scripting

Unable to overwrite but can delete file

I'm debugging a ksh script written by someone else that does the following: It runs a command and redirects stdout to a file called dberror that already exists using ">". This command fails with the following error: The file access permissions do not allow the specified action. dberror:... (1 Reply)
Discussion started by: savage66
1 Replies

6. Shell Programming and Scripting

Rsync help - unable to delete the Source file

Hi All, I am facing problem deleting Source while using the rsync command. rsync --include=*`date --date="-1 day" \+\%Y\%m\%d`* --include=*`date +\%Y\%m\%d`* --exclude=* --delete-after -auvb -e ssh USER@SERVER:SOURCE DESTINATION However the sync happens but not the deletion of the source... (1 Reply)
Discussion started by: amitkhiare
1 Replies

7. UNIX for Advanced & Expert Users

Unable to delete an open file

I am working on a unix server. I killed all the processes with my id on the machine. After that I tried to delete a file, I got an error:- file not removed.Text File busy. Deletion of directory prompted:- Directory not empty. Can anyone help me regarding this...??? Thanks, Vikas (11 Replies)
Discussion started by: vikasrout
11 Replies

8. Windows & DOS: Issues & Discussions

Unable to delete a file through SAMBA

We have AIX box with a share. We have a Windows 2000 server with a mapped drive to this share. We were able to create and delete files inside the mapped drive. I removed the map. Changed it to a test share. Removed that map. Added it back to teh original share. However, now we can... (3 Replies)
Discussion started by: mcubitt
3 Replies

9. UNIX for Dummies Questions & Answers

Unable to delete files

I have more than 1 million files (No directories). rm -rf * did not work. How do i delete all these files at a stretch in a single command? (9 Replies)
Discussion started by: sydney2008
9 Replies

10. UNIX for Dummies Questions & Answers

unable to delete file for permission problem

Hi, We are facing problem to delete some logfiles. Explaing with example for clear understanding : we have 2 accounts : prdpqrs (application account) & prodxyz (admin account - not root). Both of them are in same group called 'release' While prodxyz is trying to remove a file owned by... (4 Replies)
Discussion started by: sabyasm
4 Replies

Featured Tech Videos