Visit Our UNIX and Linux User Community


run fsck on swap slice?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers run fsck on swap slice?
# 1  
Old 11-22-2001
CPU & Memory run fsck on swap slice?

Hi..
i am using sun solaris...and this is the filesystem information...

you can see th slice(swap) c0t0d0s1 is giving some absord information......and during rebooting it is asking to run fsck mnually..when i run fsck manually it is giving error incorrect starting and end header...smthing like that....
How to solve this problem.....how to run fsck on this slice..
pleae help.

thanks
praful

# df -k
Filesystem kbytes used avail capacity Mounted on
/dev/dsk/c0t0d0s0 1015542 82020 872590 9% /
/dev/dsk/c0t0d0s4 1487790 649247 779032 46% /usr
/proc 0 0 0 0% /proc
fd 0 0 0 0% /dev/fd
mnttab 0 0 0 0% /etc/mnttab
/dev/dsk/c0t0d0s3 1487790 25670 1402609 2% /var
swap 729624 16 729608 1% /var/run
swap 733904 4296 729608 1% /tmp
/dev/dsk/c0t0d0s5 1190430 146106 984803 13% /opt
/dev/dsk/c0t0d0s1 673742 18446744059363710531 14346454191 3008736508754394%
/swap
/dev/dsk/c0t0d0s6 7054325 1301609 5682173 19% /oracle8i/u01
/dev/dsk/c0t0d0s7 6046389 1110078 4875848 19% /oracle8i/u02 Smilie Smilie
# 2  
Old 11-23-2001
CPU & Memory working fine

Hi....

I unmount that partition....create a newfile system on it and added this slice as swap disk...
that is swap -a /dev/dsk/c0t0d0s1
now it is working fine.......

thanks n regds

prafulSmilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #810
Difficulty: Medium
The CSS3 RGB Decimal Code for Turquoise is 64,224,218.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Disk corruption? Cant run fsck....

NOTICE: /: unexpected free inode 45262, run fsck(1M) fsck: cannot open vfstab Looks like /etc/vfstab (and a few other files has gone) Any ideas? Boot from cd, mount disk and recreate vfstab so that I can run fsck? (1 Reply)
Discussion started by: psychocandy
1 Replies

2. Solaris

Possible to increase swap size for existing UFS-based drive slice?

I like to increase swap size for my current server running solaris 10. Seems like the system is not using it's full 16G of physical memory. #swap -l swapfile dev swaplo blocks free /dev/dsk/c0t0d0s1 32,1 16 1058288 1058288 # swap -s total: 4125120k bytes... (17 Replies)
Discussion started by: JT-KGY
17 Replies

3. Solaris

unable to repair the / filesystem. Run fsck manually (fsck -F ufs /dev/rdsk/c1t0d0s0)

What can I fix this issue? I have ran below commands but everything is same.:confused: WARNING: Last shutdown is later than time on time-of-day chip: check date. The / file system (/dev/rdsk/c1t0d0s0) is being checked WARNING - unable to repair the / filesystem. Run fsck manually (fsck -F... (4 Replies)
Discussion started by: getrue
4 Replies

4. Solaris

Not able to run fsck on root file system

I am trying to root disk mirroring on SunFire V210 Server. There are two disks on this server c1t0d0 and c1t1d0 . I completed all the steps and I updated the vfstab file too. After I have updated the vfstab file I run df -h command but could not see the changes i made in vfstab. Suddenly the server... (1 Reply)
Discussion started by: newbi8321
1 Replies

5. Solaris

clear swap slice

is there a command that would zero swap slice? I found these instructions: but hoping there is some swap-specific command (3 Replies)
Discussion started by: orange47
3 Replies

6. HP-UX

fsck doesn't work - not even run?

Hi, please consider, I'm pretty new to HP-UX, thanks. Our server (rp7420 with HP-UX 11.31) has crashed due to disk write error (not boot partition). So I replaced damaged device with the new one of the same size and performed dd copy 1:1 to restore data - vxfs partition "/dev/vg01/lvol1"... (4 Replies)
Discussion started by: Morhoo
4 Replies

7. UNIX for Dummies Questions & Answers

Having a run fsck manually problem...

so i am pretty dumb when it comes to unix. but i am in the navy and the system i work on is unix based. and we have come across this problem. COULD NOT FIX FILE SYSTEM WITH fsck -P, RUN fsck INTERACTIVELY! LOGGING IN AS root FOR MANUAL fsk, ENTER ^D WHEN FILE SYSTEM FIXED (in bcheckrc)# ... (4 Replies)
Discussion started by: afouts
4 Replies

8. Solaris

Run fsck from standard login

Hello. I have created a FS /u00/ and created a non-root login under this FS. Also, disabled direct root login. Now is it possible or worth moving this login over to the root partition or allowing mount/umount + fsck from a standard account. As I am not able to run fsck for this FS. How to... (5 Replies)
Discussion started by: panchpan
5 Replies

9. Solaris

fsck run

Hi, Can anybody tell me that is it the command "fsck" can be run by the root account only? Thanks. (2 Replies)
Discussion started by: efang
2 Replies

10. UNIX for Dummies Questions & Answers

Add SWAP to free slice

I'm interested in adding more swap space to my current workstation (Solaris 10). I currently have 2 hard drives installed, however the system was only created with 512MB for swap that resides on drive 1. This drive is already sliced up and all slices are being used. The second drive has two... (3 Replies)
Discussion started by: here2learn
3 Replies

Featured Tech Videos