Visit Our UNIX and Linux User Community


How to change blocksize for in tar command


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers How to change blocksize for in tar command
# 1  
Old 10-11-2006
How to change blocksize for in tar command

How can I change the blocksize in tar command?

tar cvf test.tar backup.sh
a backup.sh 1K

If we need to set the blocksize to 20, how to do that?

Please advise.
Thank you.
# 2  
Old 10-11-2006
man tar

to create archive

tar cvfb <filenm.tar> 20 <files to archive >

to check block size

tar tvf <filenm.tar>
OR
tar tvf <filenm.tar> 30

anybode please correct me if wrong

samsam
# 3  
Old 10-11-2006
Hi,
Thanks for your quick response.
I managed to do the tar now. By the way, the blocksize show 4,

# tar cvfb test.tar 20 backup.sh
a backup.sh 1K

# tar tvf test.tar
tar: blocksize = 4
-rwxr-xr-x 0/1 76 Jul 20 16:21 2005 backup.sh
# tar tvf test.tar 30
tar: blocksize = 4

Please advise.
Thank you.
# 4  
Old 10-11-2006
The blocksize shows 4, but we need set it to 20.
How can we do that?
# 5  
Old 10-12-2006
It might depend on which tar you're using.

Linux/tar:
Code:
tar -c -b 20 -f test.tar -v backup.sh

OpenBSD/tar:
Code:
tar -c -b 20 -f test.tar -v backup.sh

By the way, the default (per the two man pages) is 20 blocks. POSIX max is 63 and max under OpenBSD is 126. The man page on linux doesn't show the maximums. I brought up info tar but it's pages and pages of stuff. Feel free to run that if you have a few minutes to spare Smilie

Carl
# 6  
Old 10-12-2006
Bug

In Tru64,
> tar cvfb test.tar 20 abc
a abc 0 Blocks
> tar tvf test.tar
blocksize = 20
-rw-r--r-- 0/15 0 Oct 12 11:19:14 2006 abc

In Solaris,

# ls -al abc
-rw-r--r-- 1 root other 0 Oct 12 11:20 abc
# tar cvfb test.tar 20 abc
a abc 0K
# tar tvf test.tar
tar: blocksize = 3
-rw-r--r-- 0/1 0 Oct 12 11:20 2006 abc

How can we get the blocksize in solaris to set as tru64 blockszie?
# 7  
Old 10-12-2006
My sun box (solaris 8) I have here says (via man) that 20 is the default. I ran the same command you did but the test option doesn't show the blocking factor. I tried it with a blocking factor of 30 but it still didn't show it.

Carl
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #575
Difficulty: Medium
If a program has poor memory management and fails to deallocate memory when it is no longer needed, the memory will not leak.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

tar command to explore multiple layers of tar and tar.gz files

Hi all, I have a tar file and inside that tar file is a folder with additional tar.gz files. What I want to do is look inside the first tar file and then find the second tar file I'm looking for, look inside that tar.gz file to find a certain directory. I'm encountering issues by trying to... (1 Reply)
Discussion started by: bashnewbee
1 Replies

2. Shell Programming and Scripting

tar command dont tar to original directory

HI, if I have a tarfile called pmapdata.tar that contains tar -tvf pmapdata.tar -rw-r--r-- 0/0 21 Oct 15 11:00 2009 /var/tmp/pmapdata/pmap4628.txt -rw-r--r-- 0/0 21 Oct 14 20:00 2009 /var/tmp/pmapdata/pmap23752.txt -rw-r--r-- 0/0 1625 Oct 13 20:00 2009... (1 Reply)
Discussion started by: borderblaster
1 Replies

3. UNIX for Dummies Questions & Answers

tar -cvf test.tar `find . -mtime -1 -type f` only tar 1 file

Hi all, 4 files are returned when i issue 'find . -mtime -1 -type f -ls'. ./ora_475244.aud ./ora_671958.aud ./ora_934052.aud ./ora_934050.aud However, when I issued the below command: tar -cvf test.tar `find . -mtime -1 -type f`, the tar file only contains the 1st file -... (2 Replies)
Discussion started by: ahSher
2 Replies

4. Solaris

Tar blockSize problem

Hi, i have got a tar file some 200MB big and i have ftp'ed the tar file over from one server to another but it does not seem to extract. its giving the following message: tar xvf saptar tar: blocksize = 2 Its the first time i used tar so I not got any ideas why its giving this message?... (2 Replies)
Discussion started by: scriptingmani
2 Replies

5. UNIX for Dummies Questions & Answers

tar: blocksize = 0 - Error message?

Hi All, While viewing tar file using "tar tf file.tar" command, I have received "tar: blocksize = 0" message and while extracting a particular file from the same tar file (file.tar) I have received the same message and nothing is extracted. Above commands ran in a shell script so, I... (3 Replies)
Discussion started by: Tlogine
3 Replies

6. UNIX for Dummies Questions & Answers

tar: blocksize

Hi, When doing tar -xvf to untar, some tar versions display the blocksize: “tar: blocksize = 6” my goal is to avoid this message. One way of doing it is to specify the blocksize: tar -xvfb <tar_file> 6 Is there a setting in tar or a tar version to avoid this type of message without... (0 Replies)
Discussion started by: melanie_pfefer
0 Replies

7. UNIX for Advanced & Expert Users

tar: tape blocksize error

Hi, I have tar: tape blocksize error when launching # gunzip < TierDB.tar.gz |tar -xvf /data/ora/DREC tar: tape blocksize error Can you please help me ? It is urgent. Many thanks. (1 Reply)
Discussion started by: big123456
1 Replies

8. UNIX for Dummies Questions & Answers

Blocksize problem restoring file from tape

I was recently given the responsibility of the unix box at our work. Without much training, I now have to go back and restore a file from tape. I'm having some trouble with it. I'm getting an error with the blocksize. The part of the script that does the tar looks like this: tar cvfX... (11 Replies)
Discussion started by: citrowske
11 Replies

9. UNIX for Advanced & Expert Users

Tar: tape blocksize error

When trying to extract a tar file in HP-UX using tar -xvf command it exits with the following error :"Tar: tape blocksize error". Tar file is created using the following command with MKS toolkit(Unix Simulation Kit for Windows env) under Windows 2000 Professional: "$tar -cvf test.tar test.txt... (1 Reply)
Discussion started by: ramkumar
1 Replies

Featured Tech Videos