dns/pppoe Problems

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers dns/pppoe Problems
# 1  
Old 10-20-2001
Question dns/pppoe Problems

I would appreciate any help anyone could give.
I am having DNS problems...
Here are the facts:
linux: 2.2.16
Distrib: SUSE 7.0
pppd: rp-pppoe
ISP: Verizon Avenue
IP: Dynamic
DNS: ???
Default Gateway: ????

I have tried putting the above IP into /etc/resolv.conf with no luck, I have also tried leaving the file blank.

I CAN connect to my ISP.
I CAN ping external IP address
I CANNOT ping www.suse.com www.hp.com etc..

an nslookup returns the error:
Can't find server name for address No response from server.

I think that maybe the dns IP is incorrect.
Any thoughts?

# 2  
Old 10-20-2001
Would you print out your resolv.conf? I suspect that there is a problem there.
# 3  
Old 10-20-2001
Data dns/pppoe problems

I have checked and double-check resolve.conf...
When I use "adsl-setup"
I choose "server" for server chooses......

This puts the following in resolv.conf, that was previously empty:


And that's it......

with these in resolve.conf, I can connect, otherwise I cannot.....
but the dns still doesn't resolve domain names for me......

Once connected, resolv.conf is now a link to /etc/ppp/resolv.conf, which is now empy....???

I can then ping outside IP's but not domain names.........

Also resolve.conf is owned by root, but the group is "dialout" ???

Are there other files, or variable I should check???????

Another thing,
I can ping once connected, but I CANNOT ping

# 4  
Old 10-21-2001
Lightbulb I've Got it !!!

I figured it out!!!!

Just for future reference,
when using RP-PPPOE (Roaring Penguin's pppoe package),
choosing server will put the nameservers IP's into
/etc/resolv.conf however, when you use
start-adsl that file is moved, and a link is created to
/etc/ppp/resolv.conf , which in my case was empty

I copied /etc/resolv.conf to /etc/ppp/resolv.conf before starting
adsl. Now it WORKS!! I am surfing with a linux machine!!!


Last edited by Recon; 10-22-2001 at 04:01 AM..
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. IP Networking

authentication of VM's via PPPoE

I have two VM's running on Ubuntu box.Their name and IP addresses are give below. nas home_user I establish a ppp connection between the two machines #nas (server) sudo pppd noauth local lock defaultroute... (0 Replies)
Discussion started by: karthik.sharma
0 Replies

2. Ubuntu

PPPOE + Ubuntu = Frustrating

Hii everyone, I will be explaining what kind of problem I am having with Ubuntu and PPPOE. I have dual booted my PC with Win 7 and Ubuntu 10.10 Previously, whenever I use to start my ubuntu, internet automatically used to start up.. .no problems. I had created a DSL connection through... (0 Replies)
Discussion started by: zsycho
0 Replies

3. Slackware

pppoe-start not working

Hello. I'm new here and i'm new to slack (concept) as well. I made a connection for pppoe with pppoe-setup, bringed up eth0 with ifconfig but when i try pppoe-connect i get "Cannot determine ethernet address for proxy ARP" and with pppoe-start i get "child pppd process terminated". How can i make... (0 Replies)
Discussion started by: editheraven
0 Replies

4. Red Hat

PPPoE Connection on RHEL5

Hi, I am having broadband connection, I need to connect broadband internet through eth0. Please give me some use full information for configuring this. (0 Replies)
Discussion started by: pkachary
0 Replies

5. UNIX for Advanced & Expert Users

problems figuring out dns

Im on an OS X 10.4 Mac server running bind 9.3, I just replaced the entire network with cisco hardware, all machines including servers now have private ip addresses that t he firewall resolves. I need to have a dns that works for both internal and external connections. any help would be great! (1 Reply)
Discussion started by: nbredthauer
1 Replies

6. Solaris

OS Problems -no DNS & SSH not working

I just installed Solaris 6/10 without any problems but I didn't connect the network cable when I installed it. Here are my problems: -I can access webpages using IP addrsses but not with domain names -ssh is installed but it is not running ('ps -e | grep sshd' didn't show it) I have been... (4 Replies)
Discussion started by: kungpow
4 Replies

7. UNIX for Dummies Questions & Answers

DNS problems.

Here's the setup. We have a consortium of three different\separate domains\organizations A.org, B.org, and C.org that are sharing a domain D.org. The server they share\use is housed at domain A.org. Domain A.org also maintains the primary nameserver for both internal and external DNS. The... (5 Replies)
Discussion started by: Westy564
5 Replies

8. SCO


Greetings... I'm looking for a pppoe client for SCO SYS_V can u guys gimme some help ? a website address or even the program name would be just fine. Thanx (1 Reply)
Discussion started by: nEuRoMaNcEr
1 Replies
Login or Register to Ask a Question