still cant get the solaris cdrom!!

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers still cant get the solaris cdrom!!
# 1  
Old 10-16-2001
Error still cant get the solaris cdrom!!

ok here is what i do and get:
# mount /dev/sd6a /cdrom
mount /dev/sd6a write-protected

ok so what do i do its a external cdrom and its on scsi number 6. its a SparcSTATION 2. we're trying to put red hat sparc 6.2 on it but it wont boot. i am about to take the hard drives out and install it a different way but then i wont learn anything so please help me before i go insane and shot the unix machine.

# 2  
Old 10-16-2001
Is it possible that you have to mount it
as read only? I believe read/write is the


# mount -r /dev/sd6a /cdrom
# 3  
Old 10-17-2001
The cdrom shouldn't let you mount it any other way than read-only. I may be missing it here, but I don't see the problem...

If you're trying to install Redhat on your Sparc, first off, make sure you have the Sparc release. Next, read the installation manual - you can't just mount a cdrom and copy files over...
# 4  
Old 10-17-2001
wixifer writes...
ok here is what i do and get:
# mount /dev/sd6a /cdrom
mount /dev/sd6a write-protected
Note that mount defaults to read/write.
My suggestion is to add the "-r" (read-only)
option to the mount command.
# 5  
Old 10-17-2001
still cant get solaris 2 cdrom mount 2

ok i tried this and got this
# mount -r /dev/sd6a /cdrom
/dev/sd6a write-protected or something else but not mounted
# mount /dev/sd6a /cdrom
/dev/sd6a write-protected or something else but not mounted
# mount -F ufs /dev/sd6a /cdrom
/dev/sd6a write-protected or something else but not mounted
# mount -F ufs -r /dev/sd6a /cdrom
/dev/sd6a write-protected or something else but not mounted

ok just read the first one i wrote on 10-16-01 if u want to know more info.
# 6  
Old 10-19-2001

I've got some questions for you, and I think I understand your frustration...
I remember somewhere a while back reading that Suns will only boot from a 2048 block reading CDROM, and the norm is a 1024 block read, so your run of the mill scsi cdrom won't boot a Sun, if that is part of your aim ( or reverse the block sizes, one way or the other...).
I understand you want to install RedHat on the Sparc, so why bother with the CD? From my experience with RH on Sparc (not much), I needed to make a boot diskette, and since that was an image, I could do that on a PC or by dd-ing off my other boxes. If your Sparc is without a floppy, let me say the a sparc floppy is also a bit different from your average floppy.
Now, if you wan to keep solaris and mount that CD, you need to know a coupla things, your filesystem type, and your device. Most of the mount versions out there will see that the device is read-only and warn you and then allow the mount but ask you to use "mount -o ro /dev/cdrom" in the future. Make sure you are mounting the correct partition of the CD, this is part of the device special. I have had the odd CD that wanted s4 mounted or something equally strange.
I also notice that you are using the Linux drive letter specifications, Solaris is different, your devices are under /dev/dsk/c0t6d0s0, as a matter of fact, that is prolly your cd right there, have you explored /dev/dsk for the "cooked" devices on the system? you'll want to look....

Okay, now that all of that is out of the way, if you are installing RH, boot from the floppy, and it will find the CD, especially if you don't have a Sun CDROM, and don't think it's Sun just because the case says so, sometimes it ain't so.
If you are keeping Solaris, mount the drive with:
"mount -o ro /dev/dsk/c0t6d0s0 /cdrom", that should work better.

# 7  
Old 10-19-2001
just so you know solaris should auto mount cd's and floppys.

run the command volcheck if that does not work makesure automountd is started.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Solaris 10 missing /cdrom/cdrom0/

Good day everyone, I am trying to install some new senmail patch on my Solaris 10 system. I know the cdrom for my CP3260 blade servers in my rack worked for the last patches installed. However, when I went to copy from the .tar file from the cdrom to the /tmp. I received an error cannot... (2 Replies)
Discussion started by: cookiecrumbs
2 Replies

2. Solaris

dvd/cdrom missing after solaris 10 jumpstart

Hi everybody Having a strange problem on a x4270m2 Sun server. Jumpstarting it from dvd drive. After install the dvddrive does not exist. Be aware jumpstart is custommade bash-3.00# mount -F hsfs -o ro /dev/dsk/c1t4d0p0 /cdrom mount: No such device mount: cannot mount... (7 Replies)
Discussion started by: stockhes
7 Replies

3. Solaris

Solaris 9 not recognizing CDROM drive

Hello, I've read many posts that offer tips on how to mount a CDROM but I haven't seen any on how to get the system to recognize the CDROM drive. I was transferring files from CDROM to the hard drive successfully. I entered the third CDROM and the system refused to automount it. I tried... (2 Replies)
Discussion started by: TrueSon
2 Replies

4. Solaris

I/O error when mounting cdrom in Solaris 10

hi unix friends, has anyone faced this problem before ? i inserted my cd into my X1450 machine, it says I/O error. mount -F hsfs -o ro /dev/dsk/clt0d0s0 /cdrom mount: I/O error mount: cannot mount /dev/dsk/c1t0d0s0 what should i do ? (4 Replies)
Discussion started by: Exposure
4 Replies

5. Solaris

Solaris 10 on CDROM?

Hello, First i'm Dutch, and my English is not very well. Sorry. :D I have got a Sun Microsystems Ultra 3D (with SPARC processor). The file must be burned to a DVD. And my computer can onley read a cd. How to get Solaris 10 on a few cds? Please help me. Thanks a lot.. Greets. (21 Replies)
Discussion started by: TomW
21 Replies

6. Solaris

SOLARIS 8 cdrom not being read

Hello, I'm a new SA fairly familar with Solaris. I'm using the COEInstaller tool and am unable to read a cd. The cd is fine. The machine continues to see the last cdrom I've used which was an image. I've tried restarted the server, restarted COEInstaller but the machine still see's the last... (3 Replies)
Discussion started by: computerguy_2
3 Replies

7. Solaris

Solaris 10, CDROM issue!!!!

I have Sun Solaris 10 (x86 based). I installed Solaris through CDROMs by booting the system through CDs only. But now when I try to use the same CDROM, it ejects out CD after few seconds, the CDROM blinks as long as the CD is in. But it throws it out. I tried killing and restarting "VOLD". Also bye... (3 Replies)
Discussion started by: stushar2000
3 Replies

8. Solaris

mounting cdrom on Solaris 9

Here's some cmd output: bash-2.05# ls /dev/dsk/* /dev/dsk/c0t0d0s0 /dev/dsk/c0t0d0s4 /dev/dsk/c0t1d0s0 /dev/dsk/c0t1d0s4 /dev/dsk/c0t0d0s1 /dev/dsk/c0t0d0s5 /dev/dsk/c0t1d0s1 /dev/dsk/c0t1d0s5 /dev/dsk/c0t0d0s2 /dev/dsk/c0t0d0s6 /dev/dsk/c0t1d0s2 /dev/dsk/c0t1d0s6 /dev/dsk/c0t0d0s3 ... (4 Replies)
Discussion started by: AJA
4 Replies

9. UNIX for Dummies Questions & Answers

burn cdrom with solaris

Hallo, who can help me to configure a scsi cd writer to my sun server enterprice 1000. 1. Hardware configuration 2. Burn program etc.. Please send me links or dokuments were i can get more infos about this theme. regards joerg (1 Reply)
Discussion started by: joerg
1 Replies

10. UNIX for Dummies Questions & Answers

how do i mount a scsi extrnal cdrom on solaris 2?

ok i have had it i need help i am in 11th grade and i cant figure how to mount the dumb cdrom on the sparcstation 2. i have tried everything i know and it still doesnt see it. by the way this is for school so please help me. Jon aka wixifer (1 Reply)
Discussion started by: wixifer
1 Replies
Login or Register to Ask a Question