Unable to grep

Thread Tools Search this Thread
# 1  
Unable to grep

I have a file with 2 lines of code
Rome is in Romeo
Romeo is in Rome

How do I grep, so that only last line would be the outcome.
sample output
Romeo is in Rome

I have tried with all possible greps but its resulting in both the lines in output.

Please help.
# 2  
When you say you have tried all possible greps, I find that hard to believe. Please show us what you have tried.

Is this a homework assignment?
This User Gave Thanks to Don Cragun For This Post:
# 3  
Thanks Cragun for the response.
No, its not a homework, It just came to mind and i was on it.
May be its a silly one and currently its not striking me.
Here are the ones i have tried but its not working.

D1: grep 'Romeo * Rom ' togrep
D1: grep 'Romeo * Rom' togrep
D1: grep "Romeo * Rom" togrep
D1: grep "Romeo * Rom " togrep

D1: egrep 'Romeo | Rom' togrep
Rom is in Romeo
Romeo is in Rome

D1: grep Romeo togrep | grep Rom
Rom is in Romeo
Romeo is in Rome

# 4  
 grep Romeo.*Rome gotamp.txt

This User Gave Thanks to Aia For This Post:
# 5  
Many thanks Aia.

now i understood, i was missing the period . before *
# 6  
For these two lines of input, any of the following will select only the 2nd line:
grep '^Rome' togrep
grep 'e$' togrep
grep 'o i' togrep

If there is other input that needs to be rejected, or criteria other than just "grep, so that only last line would be the outcome" from the two line input file:
Rome is in Romeo
Romeo is in Rome

you need to provide much clearer requirements for what you are trying to do.
This User Gave Thanks to Don Cragun For This Post:
# 7  
Apologies for not being clear while mentioning my requirement.
yes actually there were number of other inputs as well those were to be rejected.
Anyways thanks for the help !!
Will try to be more clear and precise next time onwards.

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Unable to do grep in a script

Hi, I am trying to grep a filename from a script after taking the file name and other variables as keyboard input .When I run the grep command with the same filename on the prompt, it runs fine, but it is either not giving me the correct output or not running at all from the script using the... (13 Replies)
Discussion started by: dsid
13 Replies

2. Shell Programming and Scripting

Unable to grep the process

I have user1 run a script called logginexpert.sh while has this line of code sleep 888I then login to another putty session with another user2 and try to grep for the logginexpert.sh process using ps -ef | grep exSunOS mymac 5.11 11.2 sun4u sparc SUNW,SPARC-Enterprise But, i dont get any... (20 Replies)
Discussion started by: mohtashims
20 Replies

3. Shell Programming and Scripting

Inconsistent `ps -eaf -o args | grep -i sfs_pcard_load_file.ksh | grep -v grep | wc -l`

i have this line of code that looks for the same file if it is currently running and returns the count. `ps -eaf -o args | grep -i sfs_pcard_load_file.ksh | grep -v grep | wc -l` basically it is assigned to a variable ISRUNNING=`ps -eaf -o args | grep -i sfs_pcard_load_file.ksh |... (6 Replies)
Discussion started by: wtolentino
6 Replies

4. UNIX for Dummies Questions & Answers

unable to grep the reqd field

hi all, i have a data sm thg like this 28504 0 abc 148782859 42 101M nhmmmm ilopo abc 2345432 i want to get only the field which is just aftr abc i,e., 148782859, 2345432 i have used grep /abc\t/ filename to get that but its not working can any 1 help me out (5 Replies)
Discussion started by: anurupa777
5 Replies

5. Shell Programming and Scripting

unable to match grep pattern

Hi All, I am trying to select all files in a directory which are not with .gz extension . for which I am using below script , but its rejecting both .gz and .z extension files,as in each letter is considered separately. PFB ls -lrt | awk '{print $9}'| egrep "^IRAMS.*$" please suggest... (1 Reply)
Discussion started by: Jcpratap
1 Replies

6. Shell Programming and Scripting

unable to grep the running processes.

Hi All, We have a shell script(ODS_Load)which loads the data from perticular flat file to oracle table invoking sqlplus based on the parameter. When we execute the script(ODS_Load) independently, script is working fine and able to load the tables successfully. We invoke(ODS_Load) with... (1 Reply)
Discussion started by: Nagaraja Akkiva
1 Replies

7. Shell Programming and Scripting

Unable to grep control/non printable characters

Unable to grep: Able to grep: (11 Replies)
Discussion started by: proactiveaditya
11 Replies

8. Shell Programming and Scripting

Log file is not getting created & unable to grep error from it

Hi All, Below is my code,what I am trying to do is redirecting output of ftp to a log file & then greping the errors but here I am unable to grep "Permission denied" error only & also the corresponding log file is also not getting created. #!/bin/sh . cfg USER='abc' PASSWD='abc123' ... (4 Replies)
Discussion started by: ss_ss
4 Replies

9. Shell Programming and Scripting

grep or awk problem, unable to extract numbers

Hi, I've trouble getting some numbers from a html-file. The thing is that I have several html-logs that contains lines like this: nerdnerd, how_old_r_u:45782<br>APPLY: <hour_second> Verification succeded This is some of what I've extracted from a html file but all I really want is the number... (7 Replies)
Discussion started by: baghera
7 Replies

10. Shell Programming and Scripting

unable to grep the following pattern

I have the following line in file1 elif ; then now if i try to grep this using following command grep -e "elif ; then" file1 it is showing nothing... how to grep such patterns (2 Replies)
Discussion started by: suri
2 Replies

Featured Tech Videos