Visit Our UNIX and Linux User Community


Subdomain is not working, debian, apache


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Subdomain is not working, debian, apache
# 1  
Old 10-07-2015
Subdomain is not working, debian, apache

Hi,
I use debian jessie, apache. I am not allowed to post links here at this forum, I am new user.
I made subdomain porodin.predicsasa.com and it is working, vhost file is porodin.conf in /etc/apache2/sites-available
then I copied vhost file and made it hosting.conf, did a2ensite hosting and it is OK:
Code:
root@vmi50113:~# a2ensite hosting
Site hosting already enabled

but it is not working when I type in firefox:
hostingDOTpredicsasaDOTcom

both files are identical except DocumentRoot folder:
Code:
porodin screnshot: s23.postimg.org/d7p4cdf4q/Untitled.jpg
hosting screenshot: s28.postimg.org/720ocqhx8/Untitled2.jpg

file permissions are the same in html folder:
Code:
drwxrwxr-x  2 www-data root  4096 Oct  4 14:17 hosting
drwxrwxr-x  3 www-data root  4096 Oct  4 12:05 porodin

despite being identical, one subdomain is working, another one is not working.
any help?

Last edited by Corona688; 10-07-2015 at 02:29 PM..
# 2  
Old 10-07-2015
Did you restart apache after changing the config file?

/etc/init.d/apache2 restart
# 3  
Old 10-07-2015
yes, I did restart apache many times during work on other things, this problem is the same several days, it is not from today. I rebooted VPS several times also but the problem is still there.
# 4  
Old 10-07-2015
Try disabling and enabling the site.

Try intentionally putting a syntax error in the file, just to see if it's actually being included at all, a2ensite often causes much madness.

If that doesn't work, we may need to see the contents.
# 5  
Old 10-08-2015
Hi,
thank you for answers Smilie
I found out what mistake I made:
I forgot to make subdomain, A record ("hosting" and IP address) at my domain control panel (namecheap), now I made it and it is working.
so, problem is solved, if anybody in the future has similar problem, in this case, it was DNS problem...
This User Gave Thanks to alanford For This Post:
# 6  
Old 10-08-2015
Glad the problem was solved, thanks for letting us know. It's also possible to set a "catch all" for URL's so "anything.TLDN.com" can work without being preconfigured in DNS.
 

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Ubuntu

Apache not working

I have installed apache2 on ubuntu 16.00 and checked the logs and no errors apt list --installed | grep apache2 WARNING: apt does not have a stable CLI interface. Use with caution in scripts. apache2/xenial-updates,xenial-security,now 2.4.18-2ubuntu3.5 amd64 ... (0 Replies)
Discussion started by: DOkuwa
0 Replies

2. Linux

Apache wildcard ssl on subdomain serves same page for non ssl virtualhosts

Issue observed: I have configured ng.my-site.com using widlcard ssl cert. When I hit https://www.my-site.com it loads ng.my-site.com website! please advise if I missed any concept / configs... Thank you! httpd.conf <VirtualHost *:80> ServerName www.my-site.com ServerAdmin... (0 Replies)
Discussion started by: ashokvpp
0 Replies

3. Red Hat

Apache chown on its files not working

Hello, My apache user generate one file : # ls -lsa /tmp/reference_file.csv 76 -rwxrwxrwx 1 apache apache 69921 Aug 16 14:14 tmp/reference_file.csv the user and the group belong to apache, but when i am trying to change it : su -l apache -s /bin/bash -bash-3.00$ whoami apache... (7 Replies)
Discussion started by: cterra
7 Replies

4. Linux

Chrome browser no longer working on my debian lenny 5

Hi All, My chrome browser was working correctly on my Debian Lenny 5 PC..Today i downloaded the version from google and tried to install the deb from command line as follows: dpkg -i <latest-chrome-package> The installation failed but now my existing old chrome browser is not starting. ... (2 Replies)
Discussion started by: coolatt
2 Replies

5. Linux

Apache/2.2.25 VirtualHost not working

I am having problems in implementing the virtual hosts here in my server. I have this one cloud dev server: Amazon Linux AMI release 2013.03 (based on RHEL like CentOS) with Apache 2.2.25 installed and I'm trying to create 2 virtual hosts: test-kalc.tk and test2-kalc.tk. If I go to... (2 Replies)
Discussion started by: jpdoria
2 Replies

6. Web Development

Apache to Tomcat forwarding not working properly

Hi, I am facing some problem with Apache to Tomcat forwarding. I have Tomcat (6.0.18) behind Apache (2.2). I want to use ‘https' for receiving request from the client. This request, when forwarded by Apache to Tomcat, will use ‘http'. My application's name is ‘abc', which is deployed in... (1 Reply)
Discussion started by: Technext
1 Replies

7. Debian

Iomega ix2-200 Custom Debian - Autostart script in init.d not Working

!!Hello Everyone!! I Recently purchased a Iomega iX2-200 NAS that runs a custom debian installed by Iomega (Linux Debian 5.0.2 ( 2.6.22.18 armv5tejl)) . I have SSH access. I installed Transmission since the factory installed torrents manager that Iomega uses is terrible. Transmission-daemon... (1 Reply)
Discussion started by: stejimenez
1 Replies

8. Shell Programming and Scripting

how to grep a subdomain

When I try to grep a subdomain having three dots("."), I am getting another fully qualified domain also that looks same as the sub domain but with hyphen("-") in the place of dot(".") I just need the first result. Please help me... grep abcd.efg.xyz.info /etc/named.conf zone... (15 Replies)
Discussion started by: an00p
15 Replies

9. IP Networking

MX record for a subdomain

Hi all, I have problem regarding public subdomain delegation i have created an A record for subzone in BIND on a machine running Solaris10 Sparc to point to another machine running win2k3 as follows sub.domain.tld and www.sub.domain.tld now i want to add an MX record for mail routing for the... (1 Reply)
Discussion started by: h@foorsa.biz
1 Replies

10. Shell Programming and Scripting

find subdomain in url

I want to find out subdomains in the url using shell script. e.g narendra.eukhost.com abc.domainname.co.uk I want to extract narendra & abc from the above urls. Please any one can suggest idea or script ? (2 Replies)
Discussion started by: nrbhole
2 Replies

Featured Tech Videos