Visit The New, Modern Unix Linux Community


This awk should work, shouldn't it?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers This awk should work, shouldn't it?
# 22  
Quote:
Originally Posted by sea
My question is more like if there is any specific reason, or did you just start from bottom?
What perhaps happened is: the output of curl is "counting upwards" like scp, yum and a lot of other tools. They do this by not sending a line break at the end of the line but a simple "carriage return" without a line feed, so they are overwriting one and the same line over and over again. For a log file this is just one long line and the updated numbers are different fields. If you do a longer download you will probably find the different fields over and over again,as they are updated during the download every seond or something such.

Try using "tr" to revert the carriage returns to real nextline characters and you have lines which should be fairly easy to parse.

I hope this helps.

bakunin
This User Gave Thanks to bakunin For This Post:
# 23  
Ravinder: Ok, just wanted to be sure.
RudiC: Literal (copy-paste), as i get a 'blank screen' when pressing CTRL+M to get that character.

---------- Post updated at 15:18 ---------- Previous update was at 15:10 ----------

@bakunin: Like: printf "\rReplace\rAgain\rAnother\rAnd so\rforth"?
But that doesnt output as curl does Smilie

Yikes, got it finaly, thanks for the hints!
Code:
sed s,'^M','\n',g out.tmp | awk 'END{print $27}'

But then again, its still the 27, not the 2nd as shown/visible.. :doh:

---------- Post updated at 15:19 ---------- Previous update was at 15:18 ----------

This looks better:
Code:
sed s,'\r','\n',g out.tmp | awk 'END{NR=3}END{print $2}'

# 24  
Nooo - it needs to be the control char (as you can see in the hexdump)! Try the <Ctrl-V><Ctrl-M> combination.

---------- Post updated at 15:21 ---------- Previous update was at 15:19 ----------

Or try -vRS=$'\r' (bashism!)
# 25  
Sorry Rudi, my hexdump'ish is not fluent.
Ok i guess that way no 'sed' is required Smilie

Anyway, it is working now.
Thanks alot, to all of you!

-->
Code:
MAXVAL=$($AWK -vRS=$'\r' 'END{NR=3}END{print $2}' "$TUI_FILE_TEMP")

 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #1007
Difficulty: Medium
ix = ln(cos x+isin x)
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Why does this if match although it shouldn't?

Hi everyboy, I am a little confused and can't understand why I get a positive match in the following case. Shell Script section echo $SHELL echo "Server type = ${SERV_TYPE}" if ]]; then echo "foor" echo -e $(_date) "${cinfo}INFO: ${crst}Checking SAP memory on ${HOST}"This is the... (1 Reply)
Discussion started by: h1kelds
1 Replies

2. UNIX for Dummies Questions & Answers

Users of own group shouldn't be able to delete

Oracle Linux 6.5 oracle user's primary group is oinstall and its secondary group is dba,asmdba,asmoper. For the below created directory, I want the users belonging to dba,asmdba,asmoper to be able create, read and execute files but not delete them. How can I achieve that. If I use 775 as... (5 Replies)
Discussion started by: kraljic
5 Replies

3. Shell Programming and Scripting

Script outputing out numbers when it shouldn't

i suspect the issue is with the IFS part. I have a script that reads a file. the problem here is that, when i run the script, it outputs a bunch of numbers. i know what these numbers are, but i dont understand why they're being sent to the screen. as you can see below, everything should be... (5 Replies)
Discussion started by: SkySmart
5 Replies

4. Solaris

Particular user account shouldn't be locked after entering wrong passwd specfic no. times

Hi all In my system we have implemented user lockout feature after 3 failure attempt if he tries to login directly or if he run the any command through sudo and enter wrong password thrice. Now I have requirement in which particular user account shouldn't be locked when he run the command... (1 Reply)
Discussion started by: sb200
1 Replies

5. Shell Programming and Scripting

Delimited data contains line feeds where they shouldn't be

I have some data, each record (line) ends with a line feed (\n). Each field is pipe (|) delimited. 1|short desc|long text|2001-01-01 01:01 2|short desc| long text |2002-02-02 02:02 3|short desc| long text | 2003-03-03 03:03 4|short desc | long text | 2004-04-04 04:04 ... (10 Replies)
Discussion started by: ericdp63
10 Replies

6. Shell Programming and Scripting

Parse file using awk and work in awk output

hi guys, i want to parse a file using public function, the file contain raw data in the below format i want to get the output like this to load it to Oracle DB MARWA1,BSS:26,1,3,0,0,0,0,0.00,22,22,22.00 MARWA2,BSS:26,1,3,0,0,0,0,0.00,22,22,22.00 this the file raw format: Number of... (6 Replies)
Discussion started by: dagigg
6 Replies

7. Shell Programming and Scripting

awk: assign variable with -v didn't work in awk filter

I want to filter 2nd column = 2 using awk $ cat t 1 2 2 4 $ VAR=2 #variable worked in print $ cat t | awk -v ID=$VAR ' { print ID}' 2 2 # but variable didn't work in awk filter $ cat t | awk -v ID=$VAR '$2~/ID/ { print $0}' (2 Replies)
Discussion started by: honglus
2 Replies

8. Shell Programming and Scripting

why awk does not work here?

I am trying to find any line with the 9th column's number greater than 200, but why the following awk command does not work? awk '$9 > 200' /tmp/test 2007-09-05 10:13:05.714 640.847 any 1.2.3.4 719 2445 487260 32 6082 199 2007-09-05 10:13:02.686 641.827... (2 Replies)
Discussion started by: fedora
2 Replies

9. UNIX for Dummies Questions & Answers

why is this so hard when it shouldn't be?

All I ask is one thing: 1. Where can i dl unix and the driver for my modem? right now i have win xp HP notebook, and bellsouth is my provider with a westell modem. (2 Replies)
Discussion started by: velious
2 Replies

Featured Tech Videos