Visit The New, Modern Unix Linux Community


Regarding ps command


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Regarding ps command
# 1  
Regarding ps command

Recently we have migrated our server from HP UX to LINUX, unfortunately one of our admin script is not working in new LINUX machine

ps -eflxA -o pcpu,pid,ppid,user,state,vsz,etime,args | grep dsjob


Code:
dsadm@dstagedev:/scripts/adminscripts:==>ps -eflxA -o pcpu,pid,ppid,user,state,vsz,etime,args | grep dsjob
ERROR: Must set personality to get -x option.
********* simple selection *********  ********* selection by list *********
-A all processes                      -C by command name
-N negate selection                   -G by real group ID (supports names)
-a all w/ tty except session leaders  -U by real user ID (supports names)
-d all except session leaders         -g by session OR by effective group name
-e all processes                      -p by process ID
                                      -q by process ID (unsorted & quick)
T  all processes on this terminal     -s processes in the sessions given
a  all w/ tty, including other users  -t by tty
g  OBSOLETE -- DO NOT USE             -u by effective user ID (supports names)
r  only running processes             U  processes for specified users
x  processes w/o controlling ttys     t  by tty
*********** output format **********  *********** long options ***********
-o,o user-defined  -f full            --Group --User --pid --cols --ppid
-j,j job control   s  signal          --group --user --sid --rows --info
-O,O preloaded -o  v  virtual memory  --cumulative --format --deselect
-l,l long          u  user-oriented   --sort --tty --forest --version
-F   extra full    X  registers       --heading --no-heading --context
                                      --quick-pid
                    ********* misc options *********
-V,V  show version      L  list format codes  f  ASCII art forest
-m,m,-L,-T,H  threads   S  children in sum    -y change -l format
-M,Z  security data     c  true command name  -c scheduling class
-w,w  wide output       n  numeric WCHAN,UID  -H process hierarchy

Please help me to resolve this issue.
Moderator's Comments:
Mod Comment code tags please

Last edited by jim mcnamara; 09-08-2015 at 06:29 AM..
# 2  
I think this may be what you see -
From man7.org ps(1) - Linux manual page

Code:
 Note that "ps -aux" is distinct from "ps aux".  The POSIX and UNIX
       standards require that "ps -aux" print all processes owned by a user
       named "x", as well as printing all processes that would be selected
       by the -a option.  If the user named "x" does not exist, this ps may
       interpret the command as "ps aux" instead and print a warning.  This
       behavior is intended to aid in transitioning old scripts and habits.
       It is fragile, subject to change, and thus should not be relied upon.

This User Gave Thanks to jim mcnamara For This Post:
# 3  
I tried below option.

Code:
==>ps -eo pid,ppid,user,state,vsz,etime,args | grep DSD.RUN | grep -v grep
13300 13290 dscmr    S 186288    04:26:44 phantom DSD.RUN Seq_To_Check_Script. 0/50/0/0/0/0/0/

I am getting expected output, also i would like to add %CPU.

Please help on this
# 4  
Quote:
Originally Posted by akshu.agni
Code:
==>ps -eo pid,ppid,user,state,vsz,etime,args | grep DSD.RUN | grep -v grep

instead of

Code:
... | grep program | grep -v grep

better use

Code:
... | grep [p]rogram

which saves one "grep".

for the "%CPU" have a look at the man-page of the ps-command. The "-o"-option is of the form "-o field1,field2,field3,...", so you just have to find out the suitable field name (different from system to system, you have to look for yourself) and put it there at some place where it suits you.

I hope this helps.

bakunin
This User Gave Thanks to bakunin For This Post:
# 5  
Hi All,

I used below code working according to my requirement, thanks for guiding me.

Code:
ps axo pcpu,pid,ppid,user,state,vsz,etime,args | grep DSD.RUN | grep -v grep

Quote:
0.0 1152 1141 dsvsd S 186360 51:44 phantom DSD.RUN Seq_To_Check_Script. 0/50/0/0/0/0/0/
# 6  
Quote:
Originally Posted by akshu.agni
Hi All,

I used below code working according to my requirement, thanks for guiding me.

Code:
ps axo pcpu,pid,ppid,user,state,vsz,etime,args | grep DSD.RUN | grep -v grep

As i told you in the last post, this:

Code:
ps axo pcpu,pid,ppid,user,state,vsz,etime,args | grep [D]SD.RUN

Would do the same with one program call less.

I hope this helps.

bakunin
This User Gave Thanks to bakunin For This Post:
# 7  
Even better with the [ ] in quotes!
And in case the dot is a real dot, this one should be the one in [ ]
Code:
ps axo pcpu,pid,ppid,user,state,vsz,etime,args | grep "DSD[.]RUN"

Code:
ps -eo pcpu,pid,ppid,user,state,vsz,etime,args | grep "DSD[.]RUN"

This User Gave Thanks to MadeInGermany For This Post:
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #340
Difficulty: Easy
Apache2 is a web server developed by Apple Computer.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Another one line command where I'd like to determine if Ubuntu or Red Hat when running command

Hello Forum, I'm making very good progress on my report thanks to the very helpful people on this forum. I've been able to successfully create my report for my Red Hat servers. But I do have a few ubuntu servers in the mix and I'd like to capture some data from them when an ssh connection is... (8 Replies)
Discussion started by: greavette
8 Replies

2. AIX

I'm facing problem with rpm command, when running the command and appears this error:

exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors: 0509-022 Cannot load module /opt/freeware/lib/libintl.a(libintl.so.1). 0509-150 Dependent module /opt/freeware/lib/libiconv.a(shr4.o) could not be loaded. 0509-152 Member... (4 Replies)
Discussion started by: Ohmkar
4 Replies

3. Shell Programming and Scripting

Multiple command execution inside awk command during xml parsing

below is the output xml string from some other command and i will be parsing it using awk cat /tmp/alerts.xml <Alert id="10102" name="APP-DS-ds_ha-140018-componentFailure-S" alertDefinitionId="13982" resourceId="11427" ctime="1359453507621" fixed="false" reason="If Event/Log Level(ANY) and... (2 Replies)
Discussion started by: vivek d r
2 Replies

4. Shell Programming and Scripting

SH script, variable built command fails, but works at command line

I am working with a sh script on a solaris 9 zone (sol 10 host) that grabs information to build the configuration command line. the variables Build64, SSLopt, CONFIGopt, and CC are populated in the script. the script includes CC=`which gcc` CONFIGopt=' --prefix=/ --exec-prefix=/usr... (8 Replies)
Discussion started by: oly_r
8 Replies

5. UNIX for Dummies Questions & Answers

passing command output from one command to the next command in cshell

HI Guys, I hope you are well. I am trying to write a script that gets executed every time i open a shell (cshell). I have two questions about that 1) I need to enter these commands $ echo $DISPLAY $ setenv $DISPLAY output_of_echo_$display_command How can i write a... (2 Replies)
Discussion started by: kaaliakahn
2 Replies

6. UNIX for Advanced & Expert Users

unix command : how to insert text at the cursor location via command line?

Hi, Well my title isn't very clear I think. So to understand my goal: I have a script "test1" #!/bin/bash xvkbd -text blabla with xbindkeys, I bind F5 key in order it runs my test1 script So when I press F5, test1 runs. I'm under Emacs/Vi and I press F5 in order to have "blabla" be... (0 Replies)
Discussion started by: xib.be
0 Replies

7. Shell Programming and Scripting

Need help! command working ok when executed in command line, but fails when run inside a script!

Hi everyone, when executing this command in unix: echo "WM7 Fatal Alerts:", $(cat query1.txt) > a.csvIt works fine, but running this command in a shell script gives an error saying that there's a syntax error. here is content of my script: tdbsrvr$ vi hc.sh "hc.sh" 22 lines, 509... (4 Replies)
Discussion started by: 4dirk1
4 Replies

8. AIX

AIX:Command to get netaddress/subnet address command in IPv4/IP6

AIX:Command to get netaddress/subnet address command in IPv4/IP6 Can anybody help us with a command to retrieve netaddress/subnet address command in IPv4/IP6 on aix machine. net/subnet address is in the format 172.16.212.0(signifies all 255 machines in an IPv4 network) (2 Replies)
Discussion started by: rookie8278
2 Replies

9. Shell Programming and Scripting

assign a command line argument and a unix command to awk variables

Hi , I have a piece of code ...wherein I need to assign the following ... 1) A command line argument to a variable e.g origCount=ARGV 2) A unix command to a variable e.g result=`wc -l testFile.txt` in my awk shell script When I do this : print "origCount" origCount --> I get the... (0 Replies)
Discussion started by: sweta_doshi
0 Replies

10. SuSE

inconsistent ls command display at the command prompt & running as a cron job

Sir, I using the following commands in a file (part of a bigger script): #!/bin/bash cd /opt/oracle/bin ls -lt | tail -1 | awk '{print $6}' >> /tmp/ramb.out If I run this from the command prompt the result is: 2007-05-16 if I run it as a cron job then... (5 Replies)
Discussion started by: rajranibl
5 Replies

Featured Tech Videos