Tree command does not print properly

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Tree command does not print properly
# 1  
Old 04-09-2015
Tree command does not print properly


when I run tree command in linux box getting below image, not the line

3 directories, 2 files

installed tree-1.5.3-2.el6.x86_64 package
# 2  
Old 04-09-2015
LC_ALL=C tree

This User Gave Thanks to radoulov For This Post:
# 3  
Old 04-09-2015
Thanks, it worked.
# 4  
Old 05-25-2015
I know this very old, but I have a question. still when I run tree command I am getting same junk what I posted in my first post.

But when I run below command, tree structure getting
LC_ALL=C tree

what is permanent solution to print tree structure with "tree" command.

Last edited by Scrutinizer; 05-25-2015 at 12:36 PM.. Reason: doubt -> question
# 5  
Old 05-25-2015
Maybe your character set is set to UTF-8 when you don't actually have a UTF-8 terminal. LC_ALL=C prevents it from trying to use fancy unicode line-printing characters.
# 6  
Old 05-25-2015
What is the output of your locale command?
# 7  
Old 05-25-2015
Originally Posted by stew
But when I run below command, tree structure getting
LC_ALL=C tree

what is permanent solution to print tree structure with "tree" command.
The set of language-specific characters in your environment is (maybe erronously) set so that the line-drawing characters are replaced by some other characters (which you called "junk"). Which set of characters is taking these places (german umlauts, french accents, ....) is controlled by the "LC_ALL" variable. To set this variable to "C" means to use a set of characters without any diacriticals at all, which is enough for english language but probably no other.

When you enter a certain setting for a variable and then a command it means that the value for this variable is in effect only for this one command. This means:

# LC_ALL=C tree
# tree

The first of the two commands will have set LC_ALL to "C" and therefore work, the second one will produce junk again because "LC_ALL" is set to something else.

Solution: set the variable somewhere where it has a lasting effect. The best place is your shells startup file: "~/.kshrc" if you use ksh (Korn shell), "~/.bashrc" if you use bash (Bourne Again Shell).

Put in the respective file the following line:

LC_ALL=C ; export LC_ALL

and start a new shell.

I hope this helps.

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

awk print not working properly

Hello friends, There is one requirment where I need to login into database environment and pull all schema names into a text file ... as of now below are the schemas available... $> describe keyspaces; system_schema system_auth system abc system_distributed system_traces Now from... (4 Replies)
Discussion started by: onenessboy
4 Replies

2. Shell Programming and Scripting

Date command is not working properly

Hi, in my script, i take the last month by a=$(date --date '1 month ago' +%Y%m) i expect that it give me in this month "March" as result 201402, but linux gave me 201403. IMPe@ABC123:> ~/date --date '1 month ago' +%Y%m 201403 i'm reasonably confused. Any idea? Thanks in advance, ... (2 Replies)
Discussion started by: IMPe
2 Replies

3. UNIX for Dummies Questions & Answers

Help on ps tree listing command - Linux/Solaris

Hi all, Can any guru please help on how I can tweak the following ps command so that it only shows the lines that I wanted. $ command ps -HAcl -F S -A f F S UID PID PPID CLS PRI ADDR SZ WCHAN RSS PSR STIME TTY TIME CMD 4 S root 1 0 TS 24 - 2592 ? ... (3 Replies)
Discussion started by: newbie_01
3 Replies

4. Shell Programming and Scripting

[Solved] Tree as alias command

Hi, I have this command: ls -R | grep ":$" | sed -e 's/:$//' -e 's/*\//--/g' -e 's/^/ /' -e 's/-/|/' Works nicely to show the current file structure as a tree. I'd like to have it as an alias in '' but doesn't work just like that and I can't fix it with backslashes: alias tree='?' ... (4 Replies)
Discussion started by: borobudur
4 Replies

5. Shell Programming and Scripting

Likely charset issue with tree command?

Hi All I'm using a tree command in a script that for me outputs:- | - - DIRECTORYNAME However a different user is getting the following output:- aaa (actually with an umlat above them) DIRECTORYNAME I'm not sure where this could be coming from, any ideas anyone? (0 Replies)
Discussion started by: Bashingaway
0 Replies

6. UNIX for Dummies Questions & Answers

Tree command

How can i install tree command in ubundu without root ? I have found some shell script which does the same job as tree but i would like to get all the options in tree command thanks (2 Replies)
Discussion started by: gvj
2 Replies

7. Programming

c++ code to print a tree using stl map

hi all, i need c++ code to print a binary or non binary tree using stl map.... please help me to find the same.......... (1 Reply)
Discussion started by: vidyaj
1 Replies

8. Solaris

What command can display files in a tree?

Is there a command that displays a certain path of files in a tree just like the dos command 'tree'? (17 Replies)
Discussion started by: Bradj47
17 Replies

9. UNIX for Dummies Questions & Answers

tree command

In DOS, to get the complete directory structure, we use 'TREE' command.. can anyone tell me what is the equivalent command in Unix I am using SunOS ABC 5.8 Generic_117350-18 sun4u sparc SUNW,Sun-Fire-V240 thanks.. (1 Reply)
Discussion started by: wip_vasikaran
1 Replies

10. UNIX for Dummies Questions & Answers

How to output the results of the AT command - properly!

Hi, I am new to UNIX and I am more used to simple commands like those in VMS. One of them is the ability to get the output from a job using the /out=<file> command in VMS. I want to submit a job (a set of unix commands) using the AT command but to get the output in a file like that used in... (4 Replies)
Discussion started by: SpanishPassion
4 Replies
Login or Register to Ask a Question

Featured Tech Videos