Strange Keyboard and Mouse Issue

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Strange Keyboard and Mouse Issue
# 1  
Old 01-07-2015
Strange Keyboard and Mouse Issue

Hello All,

PC: CuBox-i (*i.MX6) Mini-PC
OS: openSUSE 13.1 (Bottle) (armv7hl)
Kernel: 3.14.14-cubox-i

# uname -a
Linux CuBox-HQ 3.14.14-cubox-i #1 SMP Sat Sep 13 03:48:24 UTC 2014 armv7l armv7l armv7l GNU/Linux

So I've been having this random issue happen on this PC where a few strange things start happening with the Mouse and Keyboard.

1st Issue:
When the issue is occuring, the mouse pointer will randomly click things on the screen. However, the mouse does NOT
move around on it's own, it's more or less just clicking stuff. So for example lets say I have a terminal open and I start to
move the mouse across the terminal window, the mouse will suddenly highlight a few lines that I just moved past as if I
held down the left mouse button to highlight them. Or, if I'm moving my mouse pointer over a window that is not in
"focus" (*i.e. not the top window on screen) it will click that window making it the new top window on the screen.

2nd Issue:
This one is similar to the one above in that occasionally when I first touch the mouse to start moving the pointer, it will suddenly
right-click wherever the mouse was when I first began to move it.

3rd Issue:
This problem has to do with the keyboard... While I'm typing not every key I press gets put onto the screen. For example, while I'm
typing NOT every key I press is being shown on the screen as I press the key. So let's say I'm typing the "The Quick brown fox jumped
over the lazy dog."
phrase, I'll be more likely to get something like this: "he ickbrown fop jmped over the lay do"
As you can see lots of letters and spaces are missing.

4th Issue:
This one is also similar to the previous one (*3rd Issue), but instead of missing/skipping keys, as I'm pressing keys on the keyboard
it will suddenly start repeating whatever character I just hit. For example, let's say I'm trying to use the up and down arrows in a
terminal to cycle through the command history, it will suddenly begin scrolling through the commands extremely fast, as if I was
holding down the down-arrow key, and will continue doing this until I hit another key. Also, another example would be if I was writing
the same phrase from the previous example, I would get something like this:
"Te qucccck bron fffffffffffffox jud oer the lzyyy dg......................"

*FYI, all the example text strings above where copy/pasted from that PC, so that is actually what was printed...

So basically when all these issues I described above start happening, they all happen at the same time, seemingly randomly. Usually I
can just reboot the PC and the issue goes away. But I just now tried a reboot and it was still happening after it came back up...

I also thought that this only started happening when the CPU was under a heavy load, but today when it happened the ONLY thing I had
open at that moment was one terminal window. Just an FYI, this issue would continue no matter what program is up on the screen, it
does not only happen with terminals.

Does anybody have any idea what could be causing this problem, it's REALLY frustrating and basically unusable when it starts happening.
Any thoughts or suggestions would be greatly appreciated.

Thanks in Advance,
# 2  
Old 01-07-2015
The keyboard and mice aren't wireless, are they? I suppose you've already tried using a different keyboard and mouse.

Can you run dmesg when this starts? I/O errors and the like might appear at the end when things act up. It's not saved between reboots unless syslog has been configured to send it into messages or the like.

lsmod might also be useful, to see what USB drivers you have loaded.

I notice this is a small embedded PC powered by a little 5 volt power supply. I wonder if this would make it more sensitive to power line noise or not.
This User Gave Thanks to Corona688 For This Post:
# 3  
Old 01-07-2015
Hey Corona, thanks for the reply.

Yes, you are correct about the Mini-PC it does use a small 5-volt power supply. That could be a possibility I suppose...

Also, I'm pretty sure my dmesg output also gets saved to the messages log file like you had said. So I'll attach my /var/log/messages file.
I'm pretty sure the data from dmesg shows in /var/log/messages as "kernel: [#####.#####] ......" messages.

One thing about this file that you'll notice... Since the only way to really power-off the CuBox completely is to unplug the power from it after
issuing a shutdown, the current date and time are not kept up on during the boot up, and the actual time doesn't show in the log until the Network
is up and NTP has started.

So in the attachment you'll notice the start date during the bootup is 2014-07-08 at 00:00:00... Then once NTP starts the time gets changed
to the actual time.

And of course, I just got back from my lunch break and before I left I rebooted the PC in hopes of stopping the issue and of course when I got
back all was fine. So I'll have to wait till it starts happening again to get those things you were asking about.

Also, the keyboard and mouse are just regular wired USB devices, so I'm not using wireless ones...

But here is the output from lsmod:
# lsmod
Module                  Size  Used by
bnep                   18791  2 
bluetooth             235913  5 bnep
rfkill                 24250  2 bluetooth
6lowpan_iphc           17172  1 bluetooth
ir_lirc_codec          13150  0 
lirc_dev               20316  1 ir_lirc_codec
ir_jvc_decoder         12715  0 
ir_mce_kbd_decoder     13047  0 
ir_nec_decoder         12715  0 
ir_sanyo_decoder       12721  0 
ir_sony_decoder        12718  0 
ir_rc6_decoder         12715  0 
ir_rc5_decoder         12715  0 
joydev                 17772  0 
pl2303                 14006  0 
cdc_acm                24126  2 
gpio_ir_recv           13139  0 
scsi_dh_alua           18125  0 
scsi_dh_emc            14188  0 
scsi_dh_rdac           14496  0 
scsi_dh_hp_sw          13378  0

Thanks again Corona for the reply, much appreciated!

# 4  
Old 01-07-2015
Check that little power supply. Is it hot?

Also, you wouldn't happen to be using a KVM switch, would you?
This User Gave Thanks to achenle For This Post:
# 5  
Old 01-07-2015
Hey Achenle, thanks for the reply.

Well currently it is not hot, but the issue is not happening at the moment so I can't tell ya for sure if it was at the time it was
happening. But when it starts again I'll be sure to check for that. And since it does not have a fan that possibility is definitely there...

If by KVM switch you mean a USB hub, as a matter of fact I am. Its a small 4 port USB hub (*made by "IOGEAR") that gets power
from the USB port itself (*i.e. no separate power supply for the hub). I only really need to use the hub while I'm testing the thing.
Because I need to have a Keyboard, Mouse, Dial-Up USB Modem and a Serial-to-USB adapter connected. But, once I'm done
testing, it will only have the USB modem and the USB Adapter connected to it, and it only has 2 USB ports so I won't need the
hub after that...

But, you think the HUB could be causing the problem?

Thanks again for the reply, much appreciated!

# 6  
Old 01-07-2015
You might try the KB on the not hub port, to see if the hub is a problem. Power needs on the lite hub can make problems. I try to keep rf transmitters off, for instance, and they seem to kill it.
This User Gave Thanks to DGPickett For This Post:
# 7  
Old 01-07-2015
Hey DG, thanks for the reply!

Ok, I will give that a shot when it starts happening again. With my luck, it won't happen again for a week...

Sorry, could you say your last sentence again about the RF Transmitters. What exactly do you mean, what would use/have
radio-freq transmitters?

But anyway, I was just thinking... In the previous post about checking to see how hot the power supply was. That sounds like a
likely culprit. But I was just thinking now, when I first booted up the PC this morning, which is when the issue first started
immediatly upon logging in, there is no way the power supply could have been hot within the 30 seconds it took to boot-up. I'm
not saying that is not the issue, but it's something to think about...

Thanks for the reply, much appreciated!

Thanks Again,
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Run command if no mouse or keyboard input

I would like a script that would run pm-suspend if there has been no keyboard or mouse input for a specified time. ------ Post updated at 11:17 AM ------ Never mind. I found a setting in power management that does what I need. (0 Replies)
Discussion started by: drew77
0 Replies

2. What is on Your Mind?

Keyboard vs mouse

Which Input device do you use the most ? for me... keyboard ofcourse !! (56 Replies)
Discussion started by: vpraveen84
56 Replies

3. AIX

Keyboard Mouse Display not working with Pseries

Hello, Just got a refurbished Pseries when I boot the machine , everything is okay, that is no attention light and panel shows 01 B N but there is nothing on the display ( monitor / console ) which is plugged into the video card port of pseries. The display is empty.... The keyboard... (3 Replies)
Discussion started by: filosophizer
3 Replies

4. SCO

X Server -> keyboard and mouse are freezing

hi I've configured X Server using Video Configuration Manager on SCO 5.0.6, but the keyboard and mouse are freezing after 5 minutes on the graphical login mask. ---------- Post updated at 01:59 PM ---------- Previous update was at 02:43 AM ---------- BTW I finished the configuration,... (2 Replies)
Discussion started by: ccc
2 Replies

5. UNIX for Advanced & Expert Users

Check keyboard and mouse activity

I need help from someone that is good at making scripts. I'm trying to make a script file that checks for keyboard and mouse activity during 1 am to 8 am and logs you off if it detects activity. I can't find anything useful in google. ---------- Post updated 06-30-10 at 12:33 AM ----------... (1 Reply)
Discussion started by: cokedude
1 Replies

6. Solaris

Solaris don't boot without mouse and keyboard

Hi guys, I've installed Solaris 10 (SunOS 5.10) in a x86 box. I will put this box as a home server to store my files/backups/whatterver shared stuff replacing my old NetBSD machine. But, after installed and correctly configured, when I tried to boot this box without keybord and mouse (USB both),... (4 Replies)
Discussion started by: Timmerman
4 Replies

7. What is on Your Mind?

mouse/keyboard wrist lesions.

Anyone ever had any problem related to wrist lesions caused by keyboard or mouse? Tendinitis? Tenosynovitis? How long it lasted? How did it go away? (3 Replies)
Discussion started by: redoubtable
3 Replies

8. Programming

How to get capture input events from keyboard and mouse

Hi, Is there any way to capture/record the input events from keyboard, as well as from mouse using C. Thanks in advance (4 Replies)
Discussion started by: yhacks
4 Replies

9. HP-UX

HP-UX 11.11: X doesn't recognize mouse and keyboard

hi folks, i've got a blank hp visualize C3000 workstation and installed HP-UX 11.11. When I want to start X, I get the following error message: # X Fatal server error: Couldn't open X pointer device! Is one attached? I've connected an mouse and a keyboard with an usb/ps2 connector.... (5 Replies)
Discussion started by: grisu
5 Replies
Login or Register to Ask a Question

Featured Tech Videos