Ssh stopped working AIX

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Ssh stopped working AIX
# 1  
Old 07-10-2014
Ssh stopped working AIX

I Was able to ssh into the AIX box. now i cannot When I run the command to start it it comes back that is was started, but still does not work. Here is a shot i what i see

# server:/> lslpp -l | grep ssh
  openssh.base.client  COMMITTED  Open Secure Shell Commands
  openssh.base.server  COMMITTED  Open Secure Shell Server
  openssh.license  COMMITTED  Open Secure Shell License  COMMITTED  Open Secure Shell
  openssh.msg.EN_US  COMMITTED  Open Secure Shell Messages -
  openssh.msg.en_US  COMMITTED  Open Secure Shell Messages -
  openssh.base.client  COMMITTED  Open Secure Shell Commands
  openssh.base.server  COMMITTED  Open Secure Shell Server
# server:/> startsrc -s sshd
0513-059 The sshd Subsystem has been started. Subsystem PID is 6778932.
# server:/> lssrc -s sshd
Subsystem         Group            PID          Status
 sshd             ssh                           inoperative
# server:/> startsrc -g ssh
0513-059 The sshd Subsystem has been started. Subsystem PID is 6778946.
# server:/> lssrc -s ssh
0513-085 The ssh Subsystem is not on file.
# server:/> lssrc -g ssh
Subsystem         Group            PID          Status
 sshd             ssh                           inoperative

---------- Post updated 07-10-14 at 03:09 PM ---------- Previous update was 07-09-14 at 09:59 PM ----------

I tried a stop and start again. the ssh localhost here is what i got.

# server:/> stopsrc -s sshd
0513-004 The Subsystem or Group, sshd, is currently inoperative.
# server:/> startsrc -s sshd
0513-059 The sshd Subsystem has been started. Subsystem PID is 6266918.
# server:/> ssh localhost
Could not load program ssh:
        Dependent module /usr/lib/libcrypto.a( could not be l
        Member is not found in archive

# 2  
Old 07-10-2014
Did you recently upgrade your system? Upgrade your version of openssh.
# 3  
Old 07-10-2014
Specifically your openssl packages? That libcrypto is part of openssl:

ldd $(which ssh)
/usr/bin/ssh needs:

lslpp -w /usr/lib/libcrypto.a
  File                                        Fileset               Type
  /usr/lib/libcrypto.a                        openssl.base          File

Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Solaris

Mailx stopped working

after a new patch set on the 14th. I noticed that mailx stopped working, as far a I can tell that is the only thing that changed. solaris 10 OS it seems everything is the same, sendmail seems to be running root@server # ps -ef | grep -i sendmail smmsp 687 1 0 10:42:25 ? ... (0 Replies)
Discussion started by: goya
0 Replies

2. AIX

Printer stopped working

I have a serial printer connected to a 16 port ran. All of a sudden my printer stopped working and not sure how to get it back. Can anyone help pint me in the write direction? lsdev -Cc printer gives me the following. lp0 Defined 0A-08-11-00 Other serial printer lp1 Defined 0A-08-11-03... (3 Replies)
Discussion started by: Gmanx
3 Replies

3. Shell Programming and Scripting

Perl script stopped working

Hi, I have the following segment of a script which is supposed to prompt a user for password and then capture the password entered by the user. The function is called in by another script and used to work without issue, the problem is that recently the script is not waiting for the user to... (3 Replies)
Discussion started by: belalr
3 Replies

4. Hardware

Middle Mouse Button stopped working

I have no idea what happened, but my middle mouse button stopped working since yesterday. I checked the settings for the mouse, everything seems fine. Reconnected mouse , restarted PC, nothing works. What kind of issue this could be, anyone experienced something like this before? If you have... (4 Replies)
Discussion started by: zdorian
4 Replies

5. IP Networking

Wireless stopped working- Fedora 12

I installed F12 around the time it was released and it picked up my wireless card and worked like a charm.....Suddenly last week everything stopped working and I receive what appears to be a driver error when wlan0 tries to load. Error for wireless request "Set Mode" (8B06) : SET failed on... (1 Reply)
Discussion started by: woodson2
1 Replies

6. UNIX for Advanced & Expert Users

suPHP stopped working after dist-upgrade

Hi all, My server was Debian Etch (4) and had a working suPHP module (version 0.6.2-1). After I dist-upgraded it to Lenny (Debian 5), suPHP (version 0.6.2-3) stopped working. I read in the mailing list that I should change the settings of /etc/suphp/suphp.conf to this form: ;Handler... (1 Reply)
Discussion started by: mjdousti
1 Replies

7. Shell Programming and Scripting

cronjobs stopped working

Hello people, I had these cronjobs scheduled in some Unix boxes which were running fine until yesterday.But then the password was changed for that user id and then the jobs stopped working. As far as i know cron jobs run from super user. I am completely lost over here now. Thanks. (2 Replies)
Discussion started by: King Nothing
2 Replies

8. Linux

Cronjobs stopped working

Hi All, I am user of a Linux machine and I have approximatly 15 cronjobs scheduled in my crontab. Yesterday my administrator made LDAP active on my userid and all the things are doing fine after that. But all cronjobs for my user id stored in my crontab have stopped working after that. Could... (1 Reply)
Discussion started by: bisla.yogender
1 Replies

9. Shell Programming and Scripting

#!/bin/bash has stopped working

Hi I'm writing a script and I've put #!/bin/bash as the first line so that I can just type my scripts name 'whodate' at PS1 instead of ./whodate. This has suddenly stopped working for me. It used to be the case that I could start a script with #!/bin/bash and it would work, but for this script... (2 Replies)
Discussion started by: zorrokan
2 Replies
Login or Register to Ask a Question

Featured Tech Videos