Visit Our UNIX and Linux User Community

Trying to copy old hard drive to new hard drive.

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Trying to copy old hard drive to new hard drive.
# 1  
Old 01-27-2006
Trying to copy old hard drive to new hard drive.

Smilie ........I have a new hard drive and I need to copy ALL info from the old to the new. I would like to use the dd command. I know the command is as follows......

dd if=/dev/rdsk/c1t1d0s0 of=/dev/rdsk/????????

Where I have the question marks is the problem.
How do I find out what the id is?

Thanks in advance.
# 2  
Old 01-27-2006

This looks like a solaris box. If its is, its is most likly c1t2d0s0. It will depend on how to formatted the disk. If you are on a sun box. Use format command to look at how it is name. Using format will not change anything IF Smilie you just use it to look at the disks. Please do man on format command before using it. I think if you use df -k it should also give you disk naming.

# 3  
Old 01-29-2006
df -k would only show you the device if it was currently mounted. Yes, the format command is probably the way to go. Did you remember to do a boot -r (or touch /reconfigure then init 6) after you added the new disk? If not, run devfsadm. Then the appropriate device entries will be created and you should be able to see the disk when you run format. You can use dd, or even ufsdump|ufsrestore to transfer your data. You're best to umount the source disk before you copy - if anything is writing to the filesystem whilst you're copying it's contents you could end up with corrupt data.

# 4  
Old 01-30-2006
Ok......I did a format and the new drive showed being c1t2d0.
So I did a dd if=/dev/rdsk/c1t1d0s0 of =/dev/rdsk/c1t2d0s0 and the following error showed up........
dd: /dev/rdsk/c1t2d0s0 open: Invalid argument

I did some research and the consensus is that slice 2 would span the entire disk, so I tried dd if=/dev/rdsk/c1t1d0s2 of=/dev/rdsk/c1t2d0s2 and the same error came up.

Any suggestions Smilie
# 5  
Old 01-30-2006
Progress...........I had to label the drive......i typed format and it asked me if i wanted it labelled.......then i did dd dd if=/dev/rdsk/c1t1d0s2 of =/dev/rdsk/c1t2d0s2 and it's been running for about an hour and a half. Maybe I should have specified the blocksize?!?!

Previous Thread | Next Thread
Test Your Knowledge in Computers #717
Difficulty: Medium
A universal Turing machine can calculate any recursive function, decide any recursive language, and accept any recursively enumerable language.
True or False?

9 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

External hard drive

I have connected an external hard drive. I can't find it. Both ls /media, fdisk -l and ls /dev show nothing. TIA (3 Replies)
Discussion started by: Meow613
3 Replies

2. Solaris

How to make an exact image copy of a SCSI hard drive in Solaris 8 OS?

To Solaris 8 Experts, Please let me know what's the best method / procedure as well as the Solaris 8 commands for accomplishing the following tasks on a production Sun Enterprise 250 Server running Sun Solaris 8 Operating System: 1. Make an exact image/copy of the SCSI Hard Drive in the... (3 Replies)
Discussion started by: ssabet
3 Replies

3. Shell Programming and Scripting

I want to copy all files of a said type on my external hard drive

My code is this, what I'm trying to accomplish is to make a list of all pdf documents in my computer and then copy all of those documents to my external hard drive in a directory mkdir /Volumes/Hardrive-1/allpdf echo "File Locations" > /Volumes/Hardrive-1/allpdf/FileLocations.txt mdfind pdf... (2 Replies)
Discussion started by: darpness
2 Replies

4. UNIX for Dummies Questions & Answers

Copy everything from remote Linux to external hard drive in windows

Hi, I`m trying to copy an entire directory(with numerous files, folders and subfolders etc, a content size of 500gigs) from a linux machine running Red Hat Enterprise Linux 6 to an external hard drive on my windows. I downloaded and installed psftp on my windows and I can login using psftp... (9 Replies)
Discussion started by: newbie83
9 Replies

5. Solaris

Hard Drive Copy results in differences on boot

I have an old Pentium 4 PC running Solaris 9. The system has two 40gig IDE hard drives. I removed the drives and, using a hard disk duplicating device, "cloned" both drives. I installed the new drives in the PC. The system boots but I get a message that X-Term will not run on the console. If I... (4 Replies)
Discussion started by: ddogarmyman
4 Replies

6. Filesystems, Disks and Memory

The best partitioning schem for a 250GB Sata hard drive & a 75GB SCSI hard drive

Hi I have 2 75GB SCSI hard drives and 2 250GB SATA hard drives which are using RAID Level 1 respectively. I wana have both FTP and Apache installed on them as services. I'm wondering what's the best partitioning schem? I wana use FC3 as my OS, so, I thought I can use the 75GB hard drive as the /... (0 Replies)
Discussion started by: sirbijan
0 Replies

7. UNIX for Dummies Questions & Answers

How do copy certain files and directories from one hard drive to another?

I have two drives (scsi) mounted on one server and I need to copy certain files and directories from one drive to the other. Any suggestions :confused: (4 Replies)
Discussion started by: shorty
4 Replies

8. UNIX for Dummies Questions & Answers

currupted my hard drive

Hello, earlier tonight I was installing BETA version of Mandrake Linux 9.0 and I realised I needed to partition my drive. I tried making the partition within mandrake but ther wasnt an option within the mandrake setup. So i go into my WindowsXP and do the disk management option but there want a... (5 Replies)
Discussion started by: xcaliber
5 Replies

9. UNIX for Advanced & Expert Users

reading the hard drive

I have suns machine that holds two hard drives. I only used one. I tryed to make a lan network with my windows xp. When I tryed to restart the machine it wanted to a password. when before I just typed root to log in. So i edited the etc dir. big mistake. So now the machine will not read the hard... (2 Replies)
Discussion started by: victbla
2 Replies

Featured Tech Videos