Visit Our UNIX and Linux User Community


Cronjob not working


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Cronjob not working
# 1  
Old 04-17-2014
Cronjob not working

Hi,

I am trying to run a script through crontab but it doesn't run. The script sends an email of the logfile created.When I reun through command line it works perfectly but doesn't send any email through cron. There are othe jobs in cron wich runs perfectly.
Please let me know if I am doing anything incorrect


Code:
45 16 * * * /oracle/home/scripts/get_log.sh

Moderator's Comments:
Mod Comment Please use CODE tags when displaying code, not size and font tags.

Last edited by Don Cragun; 04-17-2014 at 05:09 PM.. Reason: Fix tags.
# 2  
Old 04-17-2014
There are many, many responses to this issue in the archives. Search for "cronjob not working".
This User Gave Thanks to Don Cragun For This Post:
# 3  
Old 04-17-2014
You may find it useful to run a very simple one-off cron which will show you the cron environment.

e.g.

set >/tmp/mylog.log

Then compare the output from the command "set" when running from an interactive Shell in your Oracle account with what you get above.

The cron environment is not the same as a user login environment. You will need to set a significant number of Environment Variables to get a cron to run which will invoke Oracle and run correctly.
This is no big deal if you compare the environment when running interactively from an Oracle account with the environment when running from cron.

Don't forget that cron has no VDU. Anything which might need a VDU must be redirected to a file or else cron will pick it up and send it to you in an email (to be avoided).
These 2 Users Gave Thanks to methyl For This Post:
# 4  
Old 06-12-2014
Are you creating the crontab under the same user account as you have test the shell script manually?
  1. Always use the full path to the command in crontab
  2. You also always want to include the same environment variables as you use when you execute your shell script manually.
setcron.com
 

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

PHP cronjob not working but manual working

Hi, Can anyone help me on my PHP cron not working, but when i do the manual it work. # manual run working /usr/local/bin/php /root/dev/test.php # crontab not working 55 8 * * * /usr/local/bin/php /root/dev/test.php Thank in advances Regards, FSPalero Please use CODE tags as... (2 Replies)
Discussion started by: fspalero
2 Replies

2. Shell Programming and Scripting

Cronjob is NOT working

Hi; Here is the output from crontab -l: 2,7,12,17,22,27,32,37,42,47,52,57 * * * * /var/tmp/gcsw/jmap_samples/jmap_script.sh > /var/tmp/gcsw/jmap_samples/histo_`date '+%Y%m%d%H%M'`.txtWhen I manually run the line: /var/tmp/gcsw/jmap_samples/jmap_script.sh >... (2 Replies)
Discussion started by: gc_sw
2 Replies

3. Shell Programming and Scripting

Cronjob not working as intended

I have a shell script that I have scheduled using cron using a command: 0 10 * * * /directory/Script.sh > /directory/log/output.log The script is scheduled to run at 10 AM everyday. The script executes but produces output files only with headers, no content is there. The script produces... (11 Replies)
Discussion started by: Palak Sharma
11 Replies

4. Shell Programming and Scripting

while loop not working in cronjob

Hi , While loop is not working when running script as cronjob. #!/usr/bin/bash xyz sleep 30 var=0 while do xyz commands done This script is working if I run it manually. (7 Replies)
Discussion started by: ankush_mehra
7 Replies

5. Shell Programming and Scripting

Cronjob not working from user's crontab

Hi All, I am trying to execute a python script from a user's crontab. /home/user1/UDE/scripts/UdeManager.py I am at /home/user1. If I run the command "/home/user1UDE/scripts/UdeManager.py" from the users home directory its working fine. But when I try to run from user's cron tab its... (3 Replies)
Discussion started by: Tuxidow
3 Replies

6. UNIX for Advanced & Expert Users

cronjob not working intermittently

Hi there I have a cronjob running on a sol 10 U6 server which runs every 15 minutes. The cronjob is a perl script. But I have noticed that after every few weeks the job stops running all of a sudden. There are other cronjobs running on the system from the same user and from other users which... (3 Replies)
Discussion started by: sinfuldips
3 Replies

7. Solaris

cronjob not working

Hi All , I have a cron jobs that is not working while put inside cron. But on executing from manually, it works fine, Pl anyone find if there is anything wrong in the script. 30 22 * * 1-5 cd /home/ab90737/introscope/util/bin; ./batchgenerateReport.pl ../config/reps.config >... (1 Reply)
Discussion started by: jegaraman
1 Replies

8. Solaris

cronjob not working

I am trying to schedule a job via cronjob. Not sure what the problem is. below is my script and the error. 45 10 * * * /u01/app/oracle/jpark/sched_exp_mis.sh Error received. Your "cron" job on tama /u01/app/oracle/jpark/sched_exp_mis.sh produced the following output: ... (19 Replies)
Discussion started by: mrx1350
19 Replies

9. UNIX for Advanced & Expert Users

cronjob not working

I created a file in /u01/oradata directory as cronjb.ksh which contains following script 30 12 * * * /export/home/oracle/u01/oradata/rman.ksh '/export/home/oracle' is my root directory. I then moved cronjb.ksh file to my '/export/home/oracle' directory. i typed crontab cronjb.ksh. However my... (8 Replies)
Discussion started by: manna
8 Replies

10. UNIX for Dummies Questions & Answers

sftp not working as cronjob

hi, I have a script that will automatically login into a server and get a file. it is working fine if i run it on a command line. however, when i tried to run it as a cron job, it is not working. what should i do? set timeout -1 spawn /usr/bin/sftp user1@server1 match_max 100000 expect... (3 Replies)
Discussion started by: tungaw2004
3 Replies

Featured Tech Videos