Running program from local install?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Running program from local install?
# 1  
Old 01-27-2014
Running program from local install?

Dear forum,

This is my first post here, nice to meet you all.

My question might be a beginner one, also it might have been answered before (I searched but found nothing).

I am a new Unix user. I am using a terminal to connect to Ubuntu 12.04.2 LTS (GNU/Linux 3.2.0-48-generic x86_64); please forgive me if I made any mistakes here, I'm only just starting to use something other than Windows.

I need to use a specific program which is installed twice in the terminal server: both in the main and in a local installation.

I need to run it from the local installation. Can you please help me as to how I will be able to do that?

Thank you in advance.

Best regards
# 2  
Old 01-27-2014
Do you know in what path is the local installation stored?
# 3  
Old 01-27-2014
Yes, I do.

My problem is the following: this program (gromacs) has various executable tools. Also, it has loads of files (forcefield files etc).

So what puzzles me is whether I will have to create an alias or something like that for each and every gromacs tool; another thing, since it also includes files that are not executables, how will I also specify that I want it to use these files whenever performing an action?

Or is there a "global" command that I write somewhere and then the whole program runs from the local install?

Thank you in advance.
# 4  
Old 01-27-2014
You should try running the program like this:

It should automatically load correct files based on the installation directory.
# 5  
Old 01-27-2014
Thank you Smilie

Another question: Is there a permanent solution to that? For example a way to set it as a default and not having to type the whole path everytime I want to use a gromacs tool? Is there a way to do specify that I want gromacs to run only locally and not from the main installation?

Thank you in advance
# 6  
Old 01-27-2014
You can add the path to that installation to your user's .profile file. You can try doing it like this:
vi ~/.profile

Put following lines there:
export PATH

Save. Log out. Log in again. Run:
which gromacs

It should show "/full/path/to/local/gromacs".
# 7  
Old 01-27-2014
Thank you - unfortunately it doesn't work. I will have to either figure out why, or run each executable separately specifying the path.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Running local script remotely with arguments

Dear Experts, I have found this script on internet that can be used to execute local script remotely #!/bin/bash # # usage: localscript remoteuser remotehost arg1 arg2 ... realscript=$1 user=$2 host=$3 shift 3 # escape the arguments declare -a args ... (4 Replies)
Discussion started by: mukulverma2408
4 Replies

2. Red Hat

Questions about running local YUM server

Im building a local yum server to update a handful of RHEL6 and RHEL7 servers, I'll be sharing out these updates via a local http webserver but I have a few questions. 1) it seem I am only able to download RHEL6 patches from a RHEL6 box and 7 patches from a 7 box which would mean I would have to... (1 Reply)
Discussion started by: dendenyc
1 Replies

3. Shell Programming and Scripting

Running Local Script from SSH with SUDO

Hello, I know for SSH'ing and running a local script is... ssh -t user@servername < /path/to/ and with SSH'ing and SUDO'ing is... ssh -t user@servername "sudo -u username ls -l /home/username" My inquiry is how can I combine both, by SSH'ing and SUDO'ing but running... (4 Replies)
Discussion started by: WPGPoseidon
4 Replies

4. Debian

How to install package from local hard drive?

Hello, I want to install a .deb package which I already have on the hard drive. I have tried to edit /etc/apt/sources.list to point to the file but apt-get says it can't find it. The package is not in the Debian repository. Debian 6.0 (3 Replies)
Discussion started by: snorkack59
3 Replies

5. Shell Programming and Scripting

Running local script remotely with arguments in ksh

When i use ssh command to execute local script on remote server , I am unable to do it. Please let me know how this can be done in ksh req=abc dte=ghd ssh username@hostname "$req $dte" < (2 Replies)
Discussion started by: lalitpct
2 Replies

6. Solaris

install jre in local zone

How can I install a new version of jre on a local zone? Since /usr is not writable in a local zone)? pls advise solaris10 sparc ---------- Post updated at 03:51 PM ---------- Previous update was at 02:34 PM ---------- jdk6 i mean (6 Replies)
Discussion started by: lhareigh890
6 Replies

7. Solaris

Adding a filesystem to a running local zone

Is there a way to mount a filesystem from the global zone to the local zone without rebooting the local zone? I'm using a lofs filesystem.. any help is appreciated! thanks.. (4 Replies)
Discussion started by: BG_JrAdmin
4 Replies

8. Shell Programming and Scripting

running command remotely to populate local variable

If I run this # ssh remote-server 'du -sk /usr/platform/`uname -i`/' 174 /usr/platform/SUNW,Sun-Fire-V245 I get my output just fine, However, if i try to do the same but populate a local variable within my script called for example 'result' #!/bin/ksh result=`ssh remote-server... (3 Replies)
Discussion started by: hcclnoodles
3 Replies

9. Gentoo

Install over local network

hello all, anyone can point to some good basic tutorial/howto (independent, not specific to any distro) about how to install linux over LAN from one PC with working linux distro to another PC without cdrom and floppy-just over LAN? Thanks in advance ! (2 Replies)
Discussion started by: vampirex
2 Replies

10. AIX

Install MySQL connector without local SQL database

Hello UNIX gurus, I need to install the mysql odbc connector with unixODBC on my AIX 5.3 machine. I have a mySQL database running on another server (Ubuntu 7.04). The SQL database works fine. The problem I am having is when trying to run ./configure for mysql-connector-odbc it seems to be looking... (1 Reply)
Discussion started by: raidzero
1 Replies
Login or Register to Ask a Question