Visit The New, Modern Unix Linux Community


Cygwin Errors: Yaml Configuration issues


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Cygwin Errors: Yaml Configuration issues
# 1  
Question Cygwin Errors: Yaml Configuration issues

Hi everyone!

Hope all of you will be fine. I am new to this forum.

Well, I am trying to configure yaml-0.1.4 in cygwin [ DLL version: 1.7.27] on Windows 7.
I have written the following command:

Code:
*******/tmp/yaml-0.1.4
$ ./configure --prefix=/usr && make && make install

and the following error appeared.
Code:
./configure: line 32: syntax error near unexpected token `newline'
'/configure: line 32: `  ;;

I used the online "dos2unix" converter to convert the "configure" file present in yaml-0.1.4 subdirectory:

and again executed the previous command but faced the following error:

Code:
$ ./configure --prefix=/usr && make && make install
make: *** No targets specified and no makefile found.  Stop.

I cannot figure out what is going wrong? Please help me to resolve this issue.

Thanks in advance.Smilie

Regards,
Robert
# 2  
I doubt you "fixed" ./configure by running dos2unix on it, especially when squeezing it through an online converter... If anything you would have broken it further.

If you want libyaml for windows, it comes with Visual Studio 6, Visual Studio 2003, and Visual Studio 2008 projects.
# 3  
Hi Corona688,

Thanks for your response.

However, I noticed that "Visual Studio 6, Visual Studio 2003, and Visual Studio 2008 projects" already exist in the folder "win32" [which is under yaml-0.1.4 directory]. So according to my observation, the reason could be some formatting issues in "configure" file which is originally in "dos" format but I want to use it with cygwin (which you know provides unix/linux like environment in windows). That's why i used an online "dos2unix" converter but as you mentioned earlier "the problem was fixed but configure file has something further broken inside it" and has failed to create "Makefile" file which would further have been used in "make" and "make install" commands.

Having said all that, I need your kind help to successfully build the "yaml" using "./configure" command, i.e. let me know from your experience about some efficient way to manipulate "configure" file so that I can get rid of the above mentioned issues. I really really need help.

Suggestions and recommendations from other respected members are also welcome.
Thanking you all in anticipation.

Regards,
Robert
# 4  
Quote:
Originally Posted by imdalucky1
However, I noticed that "Visual Studio 6, Visual Studio 2003, and Visual Studio 2008 projects" already exist in the folder "win32" [which is under yaml-0.1.4 directory].
You would use these instead of ./configure and make.

Quote:
So according to my observation, the reason could be some formatting issues in "configure" file which is originally in "dos" format but I want to use it with cygwin (which you know provides unix/linux like environment in windows).
./configure was never in "dos" format. The .tar.gz is for all architectures and "converting" it will ruin it even more.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #617
Difficulty: Medium
If you place two string literals side by side, they are automatically concatenated by Python.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

[TIP] Processing YAML files with yq

After the success of the jq - tool for parsing and manipulating JSON-Data someone wrote a tool called yq, which aims to be the same for YAML, what jq is for JSON. Seems to work fine. I'll definitely give it a chance in future. Example YAML-File: --- !ruby/object:Puppet::Node::Facts ... (1 Reply)
Discussion started by: stomp
1 Replies

2. What is on Your Mind?

Google Search Console - Mobile Usability - No Errors or Issues - New Milestone

For the first time in the history of the site Google Search Console (GSC) has unix.com showing "no mobile viewability errors". This is no small achievement considering the hundreds of thousand of lines of legacy code we run at a site which has been around much longer than Facebook or LinkedIn: ... (0 Replies)
Discussion started by: Neo
0 Replies

3. Linux

Apache httpd configuration - Issues with APR

Hi I have tried setting up of Apache http server - httpd-2.4.25. During configuration, I understand it needs APR to be setup. Hence I have downloaded APR & APR-Util. Performed, tar xvfC apr-1.5.2.tar /root/httpd-2.4.25/srclib/apr What is happening is there is another directory... (1 Reply)
Discussion started by: videsh77
1 Replies

4. Shell Programming and Scripting

YAML file update

removing post since it got fix (1 Reply)
Discussion started by: kishore150
1 Replies

5. UNIX for Dummies Questions & Answers

Cygwin errors

I'm not sure if this is the right place to post this or should I even be posting this here but here is my problem. I've recently installed Cygwin on my windows laptop so that I can run shell scripts. However I'm getting lots of errors with most lines of code in my scripts although the syntax is... (9 Replies)
Discussion started by: millsy5
9 Replies

6. Linux

squid + AD configuration issues

Hi, I am new in squid. We need to make our squid users to be authenticated by Windows AD. The squid proxy is installed on SuSE linux. Here are AD related settings: auth_param basic program /usr/sbin/squid_ldap_auth -P -R -v 3 \ -b "dc=mydomain,dc=com" \ -D cn=squid.bind,ou=service... (1 Reply)
Discussion started by: aixlover
1 Replies

7. Solaris

Errors in postfix configuration on solaris 10

Hi Geeks, I am trying to configure 'postfix' for sending mail only instead of 'sendmail'. I am getting following error when I try to send mail using mailx command. #echo "test" | mailx -s "test mail" <username> -- command executed from server --/var/log/syslog output : Jul 8 12:55:44... (0 Replies)
Discussion started by: abhkadam
0 Replies

8. Solaris

issues with Veritas volume manager configuration

hi all i am a newbie to solaris and i am doing some R&D in veritas volume manager. This is my first day with veritas. I downloaded and installed Veritas storage foundation 5.1 package in my sun solaris 5.10 sparc machine. When i try to create disk group in vxvm, it giving one error message. I am... (6 Replies)
Discussion started by: kingston
6 Replies

9. UNIX for Dummies Questions & Answers

Cygwin/X11 issues on Windows 7

Hi All, I recently upgraded to windows 7 and am therefore reinstalling cygwin/x11 after a long time. On XP I would start xterm from the startxwin.bat file. I am experiencing trouble starting with the startxwin executable which is the new recommended startup method as well as afew other... (2 Replies)
Discussion started by: ScKaSx
2 Replies

10. Linux

postfix configuration issues...specifically masquerading (lack of )

postfix configuration issues...specifically masquerading (lack of ) Mail sent to our intranet arrives correctly (me@domain.com). Mail sent to our intranet arrives correctly (me@domain.com). Anything going outside does not, so my tests get rejected (me@hostname.com) :( any assistance... (5 Replies)
Discussion started by: mr_manny
5 Replies

Featured Tech Videos