Today (Saturday) We will make some minor tuning adjustments to MySQL.

You may experience 2 up to 10 seconds "glitch time" when we restart MySQL. We expect to make these adjustments around 1AM Eastern Daylight Saving Time (EDT) US.


Cygwin Errors: Yaml Configuration issues


 
Thread Tools Search this Thread
# 1  
Question Cygwin Errors: Yaml Configuration issues

Hi everyone!

Hope all of you will be fine. I am new to this forum.

Well, I am trying to configure yaml-0.1.4 in cygwin [ DLL version: 1.7.27] on Windows 7.
I have written the following command:

Code:
*******/tmp/yaml-0.1.4
$ ./configure --prefix=/usr && make && make install

and the following error appeared.
Code:
./configure: line 32: syntax error near unexpected token `newline'
'/configure: line 32: `  ;;

I used the online "dos2unix" converter to convert the "configure" file present in yaml-0.1.4 subdirectory:

and again executed the previous command but faced the following error:

Code:
$ ./configure --prefix=/usr && make && make install
make: *** No targets specified and no makefile found.  Stop.

I cannot figure out what is going wrong? Please help me to resolve this issue.

Thanks in advance.Smilie

Regards,
Robert
# 2  
I doubt you "fixed" ./configure by running dos2unix on it, especially when squeezing it through an online converter... If anything you would have broken it further.

If you want libyaml for windows, it comes with Visual Studio 6, Visual Studio 2003, and Visual Studio 2008 projects.
# 3  
Hi Corona688,

Thanks for your response.

However, I noticed that "Visual Studio 6, Visual Studio 2003, and Visual Studio 2008 projects" already exist in the folder "win32" [which is under yaml-0.1.4 directory]. So according to my observation, the reason could be some formatting issues in "configure" file which is originally in "dos" format but I want to use it with cygwin (which you know provides unix/linux like environment in windows). That's why i used an online "dos2unix" converter but as you mentioned earlier "the problem was fixed but configure file has something further broken inside it" and has failed to create "Makefile" file which would further have been used in "make" and "make install" commands.

Having said all that, I need your kind help to successfully build the "yaml" using "./configure" command, i.e. let me know from your experience about some efficient way to manipulate "configure" file so that I can get rid of the above mentioned issues. I really really need help.

Suggestions and recommendations from other respected members are also welcome.
Thanking you all in anticipation.

Regards,
Robert
# 4  
Quote:
Originally Posted by imdalucky1
However, I noticed that "Visual Studio 6, Visual Studio 2003, and Visual Studio 2008 projects" already exist in the folder "win32" [which is under yaml-0.1.4 directory].
You would use these instead of ./configure and make.

Quote:
So according to my observation, the reason could be some formatting issues in "configure" file which is originally in "dos" format but I want to use it with cygwin (which you know provides unix/linux like environment in windows).
./configure was never in "dos" format. The .tar.gz is for all architectures and "converting" it will ruin it even more.
 

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Apache httpd configuration - Issues with APR
videsh77
Hi I have tried setting up of Apache http server - httpd-2.4.25. During configuration, I understand it needs APR to be setup. Hence I have downloaded APR & APR-Util. Performed, tar xvfC apr-1.5.2.tar /root/httpd-2.4.25/srclib/apr What is happening is there is another directory...... Linux
1
Linux
Cygwin errors
millsy5
I'm not sure if this is the right place to post this or should I even be posting this here but here is my problem. I've recently installed Cygwin on my windows laptop so that I can run shell scripts. However I'm getting lots of errors with most lines of code in my scripts although the syntax is...... UNIX for Dummies Questions & Answers
9
UNIX for Dummies Questions & Answers
squid + AD configuration issues
aixlover
Hi, I am new in squid. We need to make our squid users to be authenticated by Windows AD. The squid proxy is installed on SuSE linux. Here are AD related settings: auth_param basic program /usr/sbin/squid_ldap_auth -P -R -v 3 \ -b "dc=mydomain,dc=com" \ -D cn=squid.bind,ou=service...... Linux
1
Linux
Errors in postfix configuration on solaris 10
abhkadam
Hi Geeks, I am trying to configure 'postfix' for sending mail only instead of 'sendmail'. I am getting following error when I try to send mail using mailx command. #echo "test" | mailx -s "test mail" <username> -- command executed from server --/var/log/syslog output : Jul 8 12:55:44...... Solaris
0
Solaris
Cygwin/X11 issues on Windows 7
ScKaSx
Hi All, I recently upgraded to windows 7 and am therefore reinstalling cygwin/x11 after a long time. On XP I would start xterm from the startxwin.bat file. I am experiencing trouble starting with the startxwin executable which is the new recommended startup method as well as afew other...... UNIX for Dummies Questions & Answers
2
UNIX for Dummies Questions & Answers

Featured Tech Videos