Mount UEFI partition

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Mount UEFI partition
# 1  
Old 12-06-2013
Mount UEFI partition

I want to gain read/write access to a Windows 8 partition from a linux live cd. Prior to Windows 8, I used ntfs-3g to mount the partition from the command line.

The "Fdisk -l" command does not seem to be able to read efi partitions. There must be some new strategy for linux users. This is my first time dealing with Windows 8. I really need to be able to do this from the terminal.
# 2  
Old 12-06-2013

Your version of fdisk is probably limited to MBR. UEFI Windows disks are partitioned using GPT. There is a variant of fdisk that understands GPT: gptfdisk, available on sourceforge.
gparted will also work.
# 3  
Old 12-07-2013
Thanks Kimon - I checked it out, and I do have it. I just wasn't aware of it. Do you happen to know if I will be able to mount a UEFI partition?
# 4  
Old 12-07-2013
Yes. The EFI system partition is FAT32, mount should not have any problem with that.
# 5  
Old 12-07-2013
And what about the partition that holds Windows 8. When I try with ntfs-3g, I cannot mount it.
# 6  
Old 12-08-2013
Originally Posted by jamarsh
I want to gain read/write access to a Windows 8 partition from a linux live cd.
Which live cd? What's the distro and version?

Originally Posted by jamarsh
And what about the partition that holds Windows 8. When I try with ntfs-3g, I cannot mount it.
What command did you try? What was the error message? Show us the partition table from a gpt (the uefi partition table format) aware tool.

You really need to start dealing in specifics if you would like to resolve the issue in a timely fashion. Otherwise, you're just wasting everyone's time (yours included).

Finally, make sure that the live cd's kernel (whatever it is) is compiled with efi support. Otherwise, the mount(2) system call won't be able to find the partition.

# 7  
Old 12-08-2013
Alas, the Windows 8 computer has been taken back by the owner due to time constraints, so I will have to pick up this thread on my next encounter with Win 8. I never was able to achieve a dual boot, but the owner seems satisfied enough with Ubuntu - he loathed Windows 8.

The live cd was System Rescue CD (gentoo). I used the ntfs-3g command to try to mount the partition. In the mean time, I will investigate the system rescue cd kernel to see if it is compiled with efi support.

Thanks for your reply.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. OS X (Apple)

Can I mount partition at given dir path

Hi, In Linux, I had modified fstab file which used to mount ~/Music, ~/Pictures, etc with disk partitions containing corresponding content or binding directory located at other partition. But I am wondering can I do same in El-Capitan as well? No linking! /media/L-Store/Desktop/Documents ... (0 Replies)
Discussion started by: ezee
0 Replies

2. AIX

Can't mount a partition

Hello, today i get some aix errors (can't lock files and strange things) then i umount FS to do a fsck but i get these errors root@omega / > fsck -p /dev/fslv06 The current volume is: /dev/fslv06 Unable to read primary superblock. Unable to read either superblock. I readed on this page... (9 Replies)
Discussion started by: thorin666
9 Replies

3. UNIX for Dummies Questions & Answers

mount extended partition

Hello, Im new here, and may be my question is stupid, but... Today I run PGP Desktop decript on my 2nd partition ( D:\ ) and when decript finish, I restart my PC.Now when I try to open D:\ its give me: D:\ is not accessable and I lose my files :( So I load Linux live CD ( knoppix ) and try to... (1 Reply)
Discussion started by: mrowcp
1 Replies

4. HP-UX

Could I mount a swap/dump partition on /tmp?

Hey Guys. Let show our disk-mapping structure on HP-UX B11.11 with df : # df /home (/dev/vg00/lvol5 ): 18979652 blocks 1224395 i /opt (/dev/vg00/lvol4 ): 120276192 blocks 1894100 i /var (/dev/vg00/lvol6 ): 19380328 blocks ... (3 Replies)
Discussion started by: aggadtech08
3 Replies

5. Solaris

can not mount the selected partition

Dear Brothers First i installed suse linux with the following partition. my hd0 size is 75gb hdc1 swap 1 gb hdc2 native linux 39gb For the rest of the 35 gb i did not create any partition. so i planned to install solaris 10x86 on that free space. When i installed the solaris i... (1 Reply)
Discussion started by: sayed_021
1 Replies

6. UNIX for Dummies Questions & Answers

I've created a partition with GNU Parted, how do I mount the partition?

I've created a partition with GNU Parted, how do I mount the partition? The manual information at is good, but I am sure about how I mount the partition afterwards. Thanks, --Todd (1 Reply)
Discussion started by: jtp51
1 Replies

7. SCO

/ partition is mounted but not present in mount

Hello , I 've got a problem with the root partition on my SCO 5.0.5 . When I check the disk with df or mount , I can 't see the root filesystem . # mount /stand on /dev/boot read only on Tue Sep 05 16:13:51 2006 /home on /dev/home read/write on Tue Sep 05 16:14:41 2006 But , if I try... (3 Replies)
Discussion started by: npn35
3 Replies

8. Solaris

how to mount other partition?

dear all, that is my problem : c0d0p1 is nt, c0d0p2 is solaris and other on extended partition is pcfs, so how can i mount it somewhere? because i dont know which one connect from raw to block dev. /dev/rdsk/c0d0p? any help would be great... :) (6 Replies)
Discussion started by: stdout
6 Replies

9. Solaris

can't mount a partition

Hello, I have a problem on my sun station, that run solaris7. To free temporarly a little space on /, I moved a few empty folders (mnt, net, awk, tftpboot) to the /home partition. Unfortunately the system froze just after this...maybe I should not have move this files, I don't know, I am a... (3 Replies)
Discussion started by: nabulus
3 Replies

10. UNIX for Dummies Questions & Answers

How to mount fat16 partition

Hello, I am trying to mount a FAT16 and FAT32 partition on an already installed Redhat system. I have tried to edit the fstab and mtab, and to put in the data I got from fdisk, but it just says cannot find it. The information given by fdisk on /dev/hda is: Device Boot Start ... (4 Replies)
Discussion started by: ghoti
4 Replies
Login or Register to Ask a Question

Featured Tech Videos