Can't CD to lib ??? why

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Can't CD to lib ??? why
# 1  
Old 12-03-2013
Can't CD to lib ??? why


I have root access and user name called prod. but it doesn't matter which user I log in as. But I can't CD to the directory. Can you advise.

dr-xr-xr-x   1 root     root           1 Sep 12 15:40 lib
[prod@newd1 ilx]$id
uid=4902(prod) gid=50(develop)

[prod@newd1 ilx]$cd lib
-bash: cd: lib: Permission denied

newd1> id
uid=0(root) gid=0(root)
newd1> cd lib
-bash: cd: lib: Permission denied

# 2  
Old 12-03-2013
What kind of file system ? where are you? ->
 cd .. ; ls -al

This User Gave Thanks to vbe For This Post:
# 3  
Old 12-03-2013
That is really strange! Can you try changing directory by inode instead?

Get inode:
ls -il
918527 drwxr-xr-x 2 yoda yoda 96 Dec  3 07:28 lib

Change dir by inode:
cd $( find -inum 918527 )

This User Gave Thanks to Yoda For This Post:
# 4  
Old 12-03-2013
Can you show us the output from:-
ls -ld lib

.... and to check if there is an ACL in play, can you show us that too. It's most likely to be:-
getacl lib

Do you have any security functions switched on, such as SELinux or 'Unicenter' from Computer Associates?

Is there anything in the system logs? You will have to read /etc/syslog.conf or /etc/rsyslog.conf to find out where they are written.

Thanks, in advance,
# 5  
Old 12-03-2013
Thanks for your help. Still not working.

newd1> ls -il lib
lib: Permission denied
total 1

newd1> id
uid=0(root) gid=0(root) 
newd1> uname -a
SunOS newd1 5.10 Generic_142909-17 sun4u sparc SUNW,Netra-T12

newd1> ls -ld lib
dr-xr-xr-x   1 root     root           1 Sep 12 15:40 lib

newd1> getacl lib
-bash: getacl: command not found

newd1> which getacl
no getacl in /opt/csw/bin /opt/csw/gcc3/bin /usr/local/bin /usr/bin /bin /usr/sbin /sbin /usr/local/java/bin /usr/sfw/bin /usr/openwin/bin /usr/dt/bin /usr/ccs/bin /opt/studio11/bin /opt/SUNWspro6/bin /usr/sbin /usr/bin .

I didn't see any errors undder /var/adm/messages. I don't have rsyslog.conf. I do have /etc/syslog.conf. Looks normal, to me, I didn't see anything new.
# 6  
Old 12-03-2013
Well, that's confusing. How about:-
ls -ld `pwd`

I'm not sure where on Solaris (assuming that's what you are using because you are on a Sparc) the getacl command is.

As for system messages, the /etc/syslog.conf is the config file, so you would need to look at where messages are being written to as defined there. Can you show us the output of:-
grep -v "^#" /etc/syslog.conf

.... and then we can direct you which log files to look in.

This User Gave Thanks to rbatte1 For This Post:
# 7  
Old 12-04-2013
Robin, Thank you for your advise. I think I know what's going on here. This directory is on local and part of on the NFS drive. Very confusing.

when they mount the file system, it came as Read only, so that's why I ran into all those issues. But error message never came as it was read only file system.

                       1.1T   884G   264G    78%    /ilx/src
                       813G   691G   122G    85%    /usr/local

This User Gave Thanks to samnyc For This Post:
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

Lib files

Hi All, I am trying to install IIS Suite application on AIX box. It gave an error as below Ensure the following libraries do not exist: /usr/lib/libicuio.a, /usr/lib/libicuuc.a, /usr/lib/libicui18n.a. These libraries may cause uvsh to not work properly. I manually removed these files by... (1 Reply)
Discussion started by: tostay2003
1 Replies

2. AIX

LIB Version

Hi...please help with command to find the library version on AIX server ---------- Post updated at 12:50 PM ---------- Previous update was at 12:31 PM ---------- AIX version is 6.1.Please (4 Replies)
Discussion started by: Sanal
4 Replies

3. Red Hat

Lib missing

Hai dear, I am installing some application on linux RedHat 9 It gives me following discrepancies (GLIBC_2.3.4) needed (GLIBC_2.4) needed needed rtld(GNU_HASH) needed i tried to search a lot on internet to find relative rpm for these libs... (3 Replies)
Discussion started by: Danish Shakil
3 Replies

4. Red Hat

ls: /lib/ no version information available (required by /lib/

Hello, I'm experimenting a problem on my rh server. Red Hat Enterprise Linux AS release 3 (Taroon Update 8) 2.4.21-47.ELsmp #1 SMP i686 i686 i386 GNU/Linux It started with a segmentation fault on #id root To resolve it, I've installed coreutils-4.5.3-28.4.i386.rpm But, I... (6 Replies)
Discussion started by: gogol_bordello
6 Replies

5. Programming

Question on using gd lib with c++

Hello, I'm trying to use gd with c++ in linux. Previously, I had already succeed using the gd lib in windows through gdwin32. Now I would like to run the program in linux but i'm not sure how to do it. I'm currently try running it in cygwin, but I couldn't compiled it. Any suggestion? (3 Replies)
Discussion started by: shahrulb
3 Replies

6. Programming

2D Graphics Lib

Hi, I am on Fedora9 and need to do some simple 2D graphics (for game development). I am looking for an ideal 2D library/package to be used with GCC. I have come accross GRX, libmxi and some OpenGL (The 3D), but none of which seems to be ok. I could not find any tutorial or support material... (1 Reply)
Discussion started by: nasersh
1 Replies

7. UNIX for Advanced & Expert Users

how install lib...

i download a boost library from net on/by window machine...i am using telnet connection.then how can i untar/compile/install boost library to /usr/local/lib...on my unix machine. (1 Reply)
Discussion started by: prangin
1 Replies

8. Programming

To use lib or lib32?

A good day to you, dear experts, I am a newbie, I noticed in binutils or gcc there are lib and lib32 and lib64, to take binutils as an example, My system is sgi IRIX6.5, which is suggested to use "n32" flag during the compiling and linking, is that mean that I need to use lib32? Q1. which one... (2 Replies)
Discussion started by: lakeat
2 Replies

9. Linux

ct-lib on Lynix

Hi Friends ! Where can I get free ct-lib for Lynix ?? My problem is something like this-- Sybase server is running on a Solaris machine. Now I trying to access the Sybase from a Lynix machine for which i need ct-lib. I tried by downloading some free ct-libs for Lynix on the net, but they... (2 Replies)
Discussion started by: mrgubbala
2 Replies

10. Programming

LIB question

a program on linux uses three libs: libutil.a libtermcap.a libpthread.a. If I want to transplant this program to Solaris, where can I get the three libs? Thanks. (2 Replies)
Discussion started by: hewlet
2 Replies
Login or Register to Ask a Question