I think I broke it....

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers I think I broke it....
# 1  
Old 09-30-2001
I think I broke it....

I was trying to install gcc on my solaris 2.6 box... and I kept encountering an error that was probably due to the lack of allocated space to the /var/spool/pkg...

For some reason... I'm still trying to figure this out... I make symbolic links to every instace of /spool I could find... I then accidently deleted /spool under /var/spool... which happened to be a symbolic link to ../var/spool or something...

Anyways... I started making alot of links... now whenever I try to get something going... like dtpad or dterm... I get the following error:

Error: Can't open display: :0.0

All help will be greatly appreciated.
# 2  
Old 09-30-2001
Maybe an answer to this might help my problem...

What directories can are you allowed to make a link to... and which directories should you not make a link to?

/ is small... so i'm trying to move everything to the larger /usr ... that's why I make links to everything...

Greg Lehey recommends this be done for FreeBSD installs with certain directories... but can you apply the same to a Solaris system?
# 3  
Old 10-01-2001


first of all, try to find out what exactly you erased. If it's /var/spool, then you've basically deleted those folders where programs send output, and temp info, like printer, sendmail, at, etc... Look up at the same system what folder tree it has to be, and restore it. I couldnt think of something else. Sorry.

Good luckSmilie
# 4  
Old 10-01-2001
thanks for the reply... but whatever I did... it totally screwed things up...

I might have deleted /var/spool or some other spool in another directory... when i tried to make a symbolic link...

anyways... when I rebooted... the bloody system was stuck on an hourglass...

I had no choice but to run a reinstall... but this time i'm going to give RedHat 6.2 a try.

Thanks for your suggestion... next time I'm gonna take things slowly... Smilie
Login or Register to Ask a Question

Previous Thread | Next Thread

7 More Discussions You Might Find Interesting

1. Solaris

LDAP broke after patching

Greetings...My first post here... I am facing issue on a x86 Solaris server, running on VMWare. We have to install latest patch cluster. I took a snapshot (on VMWare side), so we have backup copy. Downloaded and installed latest patch cluster. Post patching, I am not able to login on server with... (3 Replies)
Discussion started by: ron323232
3 Replies

2. Solaris

Ssh connection broke after patching

Hi, I have a user - e3t3user on two Solaris-10 servers. We did patching source server and after that e3t3user is not able to ssh from one server to another. Passwordless ssh connection is setup between both servers (with ssh keys share). I am not able to figure out, where it is failing. Here is... (1 Reply)
Discussion started by: solaris_1977
1 Replies

3. AIX

X Forwarding broke

X Forwarding has quit working on only 2 of our AIX Servers. ssh -X -vvv host That shows it requesting the X11 forward auth spoofing. No errors. echo $DISPLAY shows the display variable However when I execute xclock.... nothing... Kinda like it just hangs and for some reasons it does... (1 Reply)
Discussion started by: Gibby13
1 Replies

4. Shell Programming and Scripting

Have a find/replace perl script thats broke

Hello Folks, #!/usr/bin/perl use File::Find; open F,shift or die $!; my %ip=map/(\S+)\s+(\S+)/,<F>; close F; find sub{ if( -f ){ local @ARGV=($_); local $^I=""; while( <> ){ !/#/ && s/(\w+)\.fs\.rich\.us/$ip{$1}/g; print; } }... (8 Replies)
Discussion started by: richsark
8 Replies

5. AIX

disks broke?

hay I'm new in the AIX-environment. Right now i'm testing some stuff out. But i can't test the LVM-part which is (to me) very important. I have 2 disks in my testmachine but it seems only 1 is working wel. I'll show you the output below of the disks... hdisk0 = in good condition hdisk2 =... (8 Replies)
Discussion started by: kvanelshocht
8 Replies

6. UNIX for Advanced & Expert Users

i broke CDE

i honestly dont know what i did... considering i did many things... but now when i run a tightvnc session, i don't get the CDE desktop anymore, i get something that looks like an empty screen with a single terminal window... to make things worse, i can't do anything with that terminal window. it... (2 Replies)
Discussion started by: xyyz
2 Replies

7. UNIX for Dummies Questions & Answers

Changed the hostname/IP and broke it (AIX)

A buddy of mine bought an older RS/6000 CAD workstation runing AIX to learn on, and had me put it on his LAN at home. I used smit to change the hostname/IP. After a reboot I try to login, and get a message saying that DTMessage cannot start, and gives a changed hostname as one of the possible... (3 Replies)
Discussion started by: 98_1LE
3 Replies
Login or Register to Ask a Question