Problem with multiplications

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem with multiplications
# 1  
Old 11-06-2013
Problem with multiplications

	echo -en "Enter hourly wage: "
	read hourlyWage
	echo -en "Enter hours worked this week: "
	read hoursWorked
	if [ $hoursWorked -gt 40 ]
		otHours=`expr $hoursWorked - 40`
		echo "$otHours"
		salary=`expr $hourlyWage \* 40`
		echo "$salary"
		otsalary=`expr $otHours \* $hourlyWage \* 1.5`##having error
		echo "$otsalary"
		echo "Hi"

For my otsalary caculation , i tried to multiply 2 variable and a 1.5 times, but the result was expr: non-integer argument
. Is there anything that im doing it wrong?

The echoing was to check whether the subtraction and multiplication is done correctly. But only subtraction works and multiplication failed.
Please help me out . Im new to shell.

Thank you

Last edited by eggisbad; 11-06-2013 at 02:13 PM..
# 2  
Old 11-06-2013
Your variable names are different:
read hourlyWage
salary=`expr $hourlywage \* 40`

This User Gave Thanks to Yoda For This Post:
# 3  
Old 11-06-2013
Originally Posted by Yoda
Your variable names are different:
read hourlyWage
salary=`expr $hourlywage \* 40`

omg thank you what a stupid syntax error of mine, overlooked it Smilie
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. IP Networking

Router problem or ISP problem ?

Hi everyone, I am experiencing discontinuity of Internet service, this started 1 month ago. Everything worked very well for 1 year of intensive use, but now, I have problems reaching my gateway. The gateway is not my router but a node belonging to my ISP and I share the same public IP with... (3 Replies)
Discussion started by: remic
3 Replies

2. UNIX for Dummies Questions & Answers

sed Or Grep Problem OR Terminal Problem?

I don't know if you guys get this problem sometimes at Terminal but I had been having this problem since yesterday :( Maybe I overdid the Terminal. Even the codes that used to work doesn't work anymore. Here is what 's happening: * I wanted to remove lines containing digits so I used this... (25 Replies)
Discussion started by: Nexeu
25 Replies

3. Linux

Command line multiplications

Hi I am trying to do take the current mins in the current hour and multply by 60 minutes to make them into seconds and substract this way I am planning to do a Sleep on the process for the next closed zero hours but this expression is not working expr 3600 - (expr `date +%M` \* 60... (3 Replies)
Discussion started by: vinodkpunna19
3 Replies

4. IP Networking

Problem with forwarding emails (SPF problem)

Hi, This is rather a question from a "user" than from a sys admin, but I think this forum is apropriate for the question. I have an adress with automatic email forwarding and for some senders (two hietherto), emails are bouncing. This has really created a lot of problems those two time so I... (0 Replies)
Discussion started by: carwe
0 Replies

5. AIX

AIX OS problem? network problem?

Dear ALL. I installed AIX OS on customer sites. but Only one site is too slow when I connected telnet, ftp.. Ping is too fast. but telnet and FTP is not connected.. of course i check the configuration file on aix but it's normal. Do any Idea?? thanks in advance. - Jun - (3 Replies)
Discussion started by: Jeon Jun Seok
3 Replies

6. UNIX for Dummies Questions & Answers

DHCP problem and eth1 problem

At work I am trying to get this one Linux machine (let's call it ctesgm07) to behave like another Linux machine that we have (let's call it test007). test007 returns the following version info: cat /etc/debian_version: lenny/sid uname -a: Linux test007 2.6.27-7-generic #1 SMP Tue Nov 4... (0 Replies)
Discussion started by: sllinux
0 Replies

7. AIX

user login problem & Files listing problem.

1) when user login to the server the session got colosed. How will resolve? 2) While firing the command ls -l we are not able to see the any files in the director. but over all view the file system using the command df -g it is showing 91% used. what will be the problem? Thanks in advance. (1 Reply)
Discussion started by: pernasivam
1 Replies

8. Shell Programming and Scripting

ssh script problem problem

Hi Please help me with the following problem with my script. The following block of code is not repeating in the while loop and exiting after searching for first message. input_file ========== host001-01 host001-02 2008-07-23 13:02:04,651 ConnectionFactory - Setting session state... (2 Replies)
Discussion started by: pcjandyala
2 Replies

9. Shell Programming and Scripting

problem with dd command or maybe AFS problem

Hi, folks. Sorry for bothering, but maybe someone could help me please. The problem is the following: there is some script that copies files from local file system to AFS. The copying is performed with dd command. The script copies data into some AFS volumes. The problem appeared with one... (0 Replies)
Discussion started by: Anta
0 Replies

10. UNIX for Advanced & Expert Users

SSH Problem auth problem

Hi, Just recently we seem to be getting the following error message relating to SSH when we run the UNIX script in background mode: warning: You have no controlling tty. Cannot read confirmation.^M warning: Authentication failed.^M Disconnected; key exchange or algorithm negotiation... (1 Reply)
Discussion started by: budrito
1 Replies
Login or Register to Ask a Question

Featured Tech Videos