Replacing root / boot files


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Replacing root / boot files
# 1  
Question

Hi everybody,

I am running SCO-V openserver platform running on P-100.

How can I replace root / boot files ? I want to do this because, if my system is not getting booted or my root is corrupted, I want to just replace this with the back up taken or boot/root floppy. Usually I am restoring the full back up ( The installation CD is not available with me)

Thanks

# 2  
You replace corrupted boot/root files just like you replace any other files. If you can't boot the system because the files are corrupted, you must boot from a boot disk (hard drive, floppy, CD) and then replace the files after mounting the corrupted filesystem(s).
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #354
Difficulty: Medium
gawk is the only awk implementation that makes serious progress implementing internationalization and localization and TCP/IP networking.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Sun Fire 480 - devfsadm -C not working after replacing one of the boot disks

Our SunFire 480 - one of the boot disks failed. It is mirrored with VxVm. I followed the exact steps that is detailed in the veritas and sun guides (I can not post the URL since I don't have 5 posts yet.) After removing the failed disk, I ran devfsadm -C -c disk and it still shows the device... (7 Replies)
Discussion started by: jtamminen
7 Replies

2. Solaris

Need help replacing a mirrored boot disk

I have a v480 with a mirrored boot disk c1t0 and c1t1. The drives themselves don't show a failure but the mirror's need maintenance. This is my plan for replacing the drive. I would love feedback to point out what I"m missing or where my steps are incorrect. Two things I believe I'm... (3 Replies)
Discussion started by: pcoffey
3 Replies

3. Solaris

Boot Solaris 10 from detached root mirrors

I recently ran some patching on a Solaris 10 server and as per normal procedure I detached the LVM root disk mirrors first to preserve the pre-patching copy of the OS. During the patching, I ran into some issues which I managed to resolve and completed the patching. However, I was looking around... (5 Replies)
Discussion started by: Grippo
5 Replies

4. Red Hat

Is there any method by which fedora 13 can be boot directly from root??

Is there any method by which fedora 13 can be boot directly from root?? (4 Replies)
Discussion started by: sony star
4 Replies

5. UNIX for Dummies Questions & Answers

Messed up my boot environment or root profile

Ok, a couple weeks ago I was fixing a cron report about perl not happy with 'locale' info (LANG and LC not set). As a result, I was experimenting with setting the correct 'locale' in several areas (like /etc/sysconfig/i18n and who knows where). Somehow after a reboot, as soon as the OS starts... (3 Replies)
Discussion started by: Garball
3 Replies

6. Shell Programming and Scripting

exec script as user on boot not root

Is there a way to change a process owned by root to be owned by another user. I am interested in finding out if there is a way to put a script in /etc/rc2.d that will start up automatically on reboot that will not be owned by root This is for security reasons.. The Service that runs on my server... (7 Replies)
Discussion started by: chipmunken
7 Replies

7. Solaris

replacing root disk SunFire 280R

Hi, We had a disk go bad in this SunFire 280R, running Solaris 8 - Generic_117350-46. We replaced the disk and partitioned it. We metadetached all the metadevices but for some reason the new disk is showing up in the metadb as Concat/Stripe and it won't let us re-sync the mirror. We are not... (2 Replies)
Discussion started by: mgb
2 Replies

8. Solaris

Unable to boot after an error in mirroring root

Hey Guys, I am using a Sun sparc server and had 6 disks. The root was loaded on c0t10d0s0 disk. I made an image or mirrored the root to another disk c0t9d0s0. But during the process instead of attaching submirrors to main mirror (d0 <--- d01 and d11) i attached d0 <--- d01 and... (1 Reply)
Discussion started by: rjcool
1 Replies

9. UNIX for Dummies Questions & Answers

Root directory full, system does not boot

Hi, I have an SGI workstation running on Irix 6.5. A few days ago the system started giving messages that the root directory is full. Even before I could find out how to clean up the root directory, the system crashed and does not boot anymore. Can anyone help me on how I can get the system to... (1 Reply)
Discussion started by: gnanavvk
1 Replies

10. UNIX for Advanced & Expert Users

Replacing Boot Disk in Solaris

Hi, I have the situaiton in which primary boot disk has bad sectors in Solaris 9. The other hard disk is mirrored using Solstice DiskSuite 4.2. I can reboot system with the other disk. My question is, when I replaced the boot disk with a new one, how can I create meta db and finally make it... (2 Replies)
Discussion started by: s_aamir
2 Replies

Featured Tech Videos