UNIX System V Mount Floppy Drive


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers UNIX System V Mount Floppy Drive
# 8  
Thanks for the reply.

I tried that command
Code:
dd if=/dev/fd0 of=/dev/null

with fd0 and fd1. Both times I got the message
Code:
cannot open /dev/fd0: no such device or address

If I tried using /dev/fd, it said it something like
0+1 Sent
0+1 Received
, but there was no light flashing on the drive.

The light never did flash on the drive at all, but I am 100% confident that the floppy drive works.
Any Thoughts?Smilie
# 9  
Looks like there may be hardware problem, daisy cable issue, master/slave issue. Also to check in the BIOS how it has been configured.It should not be disabled. Then in the kernel devices, does it detect any device while boot up, that may give some clue. Try booting of the floppy drive , the drive should sense if you change the boot sequence to FDD. These are few steps may be helpful diagnosing the Floppy Drive problem.
# 10  
I don't think it is a hardware problem. The BIOS settings all look good, and I can boot the computer with a DOS Diskette and read and write to and from the disk.

Quote:
Originally Posted by rveri
Then in the kernel devices, does it detect any device while boot up,
How exactly would I check this? (Sorry, I'm fairly new to Unix)

---------- Post updated at 04:00 PM ---------- Previous update was at 08:47 AM ----------

Thanks for all the help, guys.

I finally determined the the floppy disk is
Code:
/dev/dsk/f0

But If I try
Code:
mount -F ufs /dev/dsk/f0

The floppy makes noises, so it is accessing the right drive. but i get the message
Code:
f0 is not an ufs file system

When I try to format the disk with ufs file system
Code:
format  /dev/dsk/f0
format  /dev/dsdk/f03h

I get the message
Code:
Device must be a character device

Thanks for the help. How can i format the Disk?

Last edited by BrentBANKS; 07-14-2013 at 10:26 PM.. Reason: Update
# 11  
Is there a boot record /usr/adm/messages? In some this is a cumlative history of devices found during boot and you could do a tail of the file to see if it is recognizing the floppy during boot. Or maybe a tail -50 to see all of the last boot. Use more to see the entire file.

On some, if the floppy was disabled during OS load it might require a md floppy to create the /dev/fd0 and link it into the kernel.

Also the possibility that the drive is empty or the diskette is not a unix filesystem. You are trying to mount a file system and if it is not the right kind it will give you the error.

You may have fdformat available to see if it tries to format a blank diskette.

Last edited by edfair; 07-14-2013 at 09:57 PM..
# 12  
BrentBANKS,
so far looks good,
You dont have any filesystem in the floppy disk yet, so it complains about filesystem , You should be able to mount it after formatting the disk with correct format.
>>Device must be a character device.
- To Use : format -F ufs /dev/rdsk/f0 , instead of /dev/dsk .
This User Gave Thanks to rveri For This Post:
# 13  
Unfortunately, I have a different version of format. ( there was a typo in my last post under format, I will fix it)

Code:
format [-f first] [-l last] [-i interleave] [-v] [-V] [-E] NOTES: -E implies -V

I formatted with
Code:
format /dev/rdsk/f0

It seemed to format just fine, but i still cant mount it.

I do have a make file system tool, mkfs.
Code:
mkfs -F ufs /dev/rdsk/f0
mkfs -F ufs /dev/rdsk/f03h

If i run either of those commands, i just end up with this prompt
Code:
ufs usage: mkfs [-F FSType] [-V] [-m] [-o options] special size [nsect ntrak bsize fragsize cgsize free rps nbpi opt apc gap]

I've read about tools like floppy, fdformat, rmformat, but UNIX Sys V is old enough that it doesn't have any of those. I think mkfs is the way to go. (I read about newfs, but i dont have it either).
Thanks for your help.

---------- Post updated at 08:01 PM ---------- Previous update was at 07:26 PM ----------

I take that back. I can mount it using the -F fdfs option.
Code:
mount -F fdfs /dev/dsk/f0 /mnt

It shows the drive the drive is mounted. This is the contents of the /mnt directory.
Code:
0 10 12 14 16 18 2 21 23 4 6 8
1 11 13 15 17 19 20 22 3 5 7 9

Is this correct, will i be able to copy files to and from, or should i try and format the drive as UFS?
# 14  
You haven't said which version of Unix you are using. There is SCO, Interactive, ATand T.
If the diskette has a tar file on it, it does not have a file system, and cannot be mounted, it can however be read using tar.
You may need to specify the exact diskette type and size.
#tar xvf /dev/fd0
#tar xvf /dev/rfd0135ds18 for a 3.5 inch high density floppy on drive A.
If you are using SCO there is a file called /etc/default/tar which has a list of the various media types. so you can substitute a number for the media type"
#tar xv6 (where 6 relates to the paired values in the above file.)
You may have a command called 'dtype'
#dtype /dev/fd0
Will display the diskette formatting.
The possible results are dos, unix 1k file system, tar, cpio
If dos
#mount -f dos /dev/fd0 /mnt
If 1k
#mount /dev/fd0 /mnt
Although you seem to have tried this one and had it not work.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #68
Difficulty: Easy
Awk is abbreviated from the names of the developers - Aho, Weinberger, and Kernighan.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

How to Mount a Unix share drive on Windows

We are trying to mount a Unix share drive on a Windows 2003 server to avoid transfering files accross the network using sftp. I can see shared drives on the Solaris server using the "share" command. How can I mount the drives on my Windows server so that I can read them directly. Do I need... (2 Replies)
Discussion started by: rbdenham
2 Replies

2. SCO

mounting USB floppy drive /Flash drive in OSR 6.0

Can anybody help me out to mount USB flash /floppy drive in sco openserver 6.0 . (5 Replies)
Discussion started by: sureshdrajan
5 Replies

3. UNIX for Dummies Questions & Answers

Mount a windows drive on unix

Hi, I would like to be able to mount windows xp to a unix system, so that I can pull data from windows machine for backup and store it on the unix server. Does anyone know how I can go about mounting the windows drive in unix. Thanks, Eric (4 Replies)
Discussion started by: ejbrever
4 Replies

4. AIX

mount floppy, to be sure

Hi there, I never touch a AIX because i'm used to work on FreeBSD. I'll have to copy some file from a floppy to an AIX. Just to be sure is the mount command the same ? I mean a simple mount /dev/fd0 /floppy should work ? Thanks :) (1 Reply)
Discussion started by: Yogz
1 Replies

5. UNIX for Dummies Questions & Answers

Floppy will not mount on SUSE

I have installed SUSE 10 on a laptop that has a swappable CDROM/Floppy drive. When I was installing the OS my CDROM was connected. Later I tried to swap it with the Floppy and mount it but no success. Here is what I get: dell:/dev # mount -t msdos /dev/fd0 /mnt /dev/fd0: Invalid argument ... (0 Replies)
Discussion started by: reedcat
0 Replies

6. UNIX for Dummies Questions & Answers

Mount a network computer/drive in unix?

:D hey all, how do you scan/mount a network drive or computer/directory? thanks (2 Replies)
Discussion started by: emplate
2 Replies

7. UNIX for Advanced & Expert Users

mount a floppy in UNIX BSDi 3

Anybody know how to mount a floppy in BSDi3 UNIX? Have tried all the standard commands with no luck. This includes: mount /dev/fd0 /mnt/floppy mount /mnt/floppy (3 Replies)
Discussion started by: jpalmer320
3 Replies

8. HP-UX

scsi floppy drive addressing

Does anyone know of a site that documents the various addressing schemes used with SCSI floppy disk drives? (5 Replies)
Discussion started by: Drew_Harrison
5 Replies

9. BSD

Floppy drive problem.

My FreeBSD install at ad0s1, and Windows 2000 at ad2s1. Everytime I start my FreeBSD, it shows me this message: fdc0: cmd 3 failed at out byte 1 of 3 pmtimer 0 on isa0 fdc0: cannot reserve I/O port range (6 ports) My Floppy drive info: 0x03F2 - 0x03F3 0x03F4 - 0x03F5 0x03F7 - 0x03F7... (6 Replies)
Discussion started by: _cs
6 Replies

10. UNIX for Dummies Questions & Answers

how to mount a hotswap scsi drive on a solaris 2.6 netra box using the mount command?

Hi... question is this: How do I mount an LVD hotswap scsi drive in bay #2 on a netra using the mount command? volmgt doesn't seem to mount it and/or I don't know how to view the drives data if it's formatted which it may not be. This drive is not new out of the box so I'm not sure. ... (4 Replies)
Discussion started by: soulshaker
4 Replies