Solaris 9: make: Fatal error:Command failed for target

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Solaris 9: make: Fatal error:Command failed for target
# 1  
Old 10-27-2005
Solaris 9: make: Fatal error:Command failed for target

Hi everyone

first of all you should know that I've been working with solaris for a few days only. Smilie

I need to install some programs and I have had the following troubles:

1. When I used /.configure it showed the following message:
"no acceptable C compiler found in $PATH"
I included /usr/css/bin/ in the path and it worked but I think is using ucbcc instead of cc

2.Then again with ./configure it showed:
"error: C compiler cannot create executables"
I followed some advices I found in the internet and now ./configure is ok

3. I tried with 'make" which is the next step in the installation process but it said: "make: not found"

4.I tried with "/usr/ccs/bin/./make" and is trying to compile but the following message appears (when trying to install gnu m4-1.4.3):
"make: fatal error: command failed for target 'libm4.a'

this kind of error appears with all programs I try to install

my path is:
/usr/sbin: /usr/bin: /usr/dt/bin/: /usr/openwin/bin: /bin: /usr/ucb: /usr/css/bin

I don't know what's wrong. Do I need to configure another path, am I missing something?? help please

thank you very much
# 2  
Old 10-28-2005
Two important things i have found when compiling packages in Solaris are the PATH & LD_LIBRARY_PATH


I have also found that the cc compiler with Solaris hasn't always compiled what i wanted to.. So what i would suggest you do is download gcc from say You can install this with a pkgadd and you might even find that the package your are trying to compile is already on there!

If not once you have gcc installed then i would suggest your re-run the ./configure and see how you get on!
# 3  
Old 10-28-2005
I tried with the PATH and the LD_LIBRARY_PATH and it worked!!!! Smilie

thank you very much plimpix

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. What is on Your Mind?

PHP Fatal Errors During SSL Cert Management - PHP Fatal error: xc_fcntl_mutex failed

Today, I noticed some errors in our SSL cert renewal log files, mostly related to domains where the IP address had changed. Concerned about this, rebuilt out SSL cert, which normally goes well without a hiccup. However, for today, for some reason which I cannot explain, there was a PHP error... (0 Replies)
Discussion started by: Neo
0 Replies

2. Solaris

Command failed for target 'check-recursive' error

Sorry if this is the wrong place for this. I haven't done UNIX Admin in a long time and am trying to update the utilities on a Solaris server so that I can get Apache 2.4.25 installed. I am finding a lot of utilities that are just too far out of date and some versions are no longer supported. So... (0 Replies)
Discussion started by: PJ_Namias
0 Replies

3. Programming

Issue with make, no rule to make target etc.

I have been trying to split up my src directory to clear out files that are not re-compiled very often. Now I have the following setup in my trunk, trunk/bld trunk/src/ trunk/src/src_server trunk/makefile.linux In the make file, I have compile rules SOURCELOC = src # compile src c++... (4 Replies)
Discussion started by: LMHmedchem
4 Replies

4. Solaris

Cygwin X Server error: xdmcp fatal error session failed session 23 failed for display

Hi, i got the following error when i tried to access the cygwin x server from a windows XP PC. "xdmcp fatal error session failed session 23 failed for display" Alternatively, when i tried to access the same Cygwin X Server from another windows XP PC which is on a different LAN... (3 Replies)
Discussion started by: HarishKumarM
3 Replies

5. Shell Programming and Scripting

make Fatal error: Command failed for target 'exp_inter.o'

I am trying to install Expect 5.43 on my Solaris 10 x86 PC. When I run the make file I get - Command failed for target 'exp_inter.o'. I tried to find the file (find / -name exp_inter.o -print 2>/dev/null) but could not. Where can I get this file from? (2 Replies)
Discussion started by: pazzy
2 Replies

6. Solaris

PHP 5.3 compile on Solaris 10 : make distclean :: fatal error

I'm trying to install PHP 5.3 on Solaris 10 . I'm using etc/apache2 and installed mysql 5.1.39. When I tried to compile PHP 5.3, with the following configure text, ./configure --with-mysql=/usr/local/mysql \ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-zlib-dir=/usr/local \... (21 Replies)
Discussion started by: ppa108
21 Replies

7. Solaris

Gani Network Driver Won't Install - make: Fatal error: Don't know how to make targ...

I attached a README file that I will refer to. I successfully completed everything in the README file until step 4. # pwd /gani/gani-2.4.4 # ls COPYING Makefile.macros gem.c Makefile Makefile.sparc_gcc gem.h Makefile.amd64_gcc ... (1 Reply)
Discussion started by: Bradj47
1 Replies

8. Solaris

Error- expr: fatal: open failed:No such file or directory

Hi Friends I have a compiler(Sun Forte,I believe) running in my Solaris 9 box. since y'day my development team is finding this error when they compile: expr: fatal: open failed: No such file or directory I ran a search for this file and found it in one of my file... (2 Replies)
Discussion started by: Hari_Ganesh
2 Replies

9. UNIX for Dummies Questions & Answers

make command failed for target 'obj/gp_unix.o'

hi, i am trying to run make command in solaris 9. its giving the error: make:Fatal error:Command failed for target 'obj/gp_unix.o' i came to know X11 should be inastalled for gp_unix.o.But it is already installed.still the same error. ./configure worked fine. can anybody please suggest... (3 Replies)
Discussion started by: rosalina
3 Replies

10. Solaris

Fatal error: Command failed for target `build_crypto'

Dear brothers. i tried so many times to install openssl-0.9.8g in x86 machine. i have done ./config without any error notification. when i execute the make command i am having the same error fatal error: Command failed for target `build_crypto'. i installed c compiler the verson of... (1 Reply)
Discussion started by: sayed_021
1 Replies
Login or Register to Ask a Question

Featured Tech Videos