Visit Our UNIX and Linux User Community

Problem in C shell (csh) prompt setting containing the '$' char

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem in C shell (csh) prompt setting containing the '$' char
# 1  
Old 02-20-2013
[Solved] Problem in C shell (csh) prompt setting containing the '$' char


I am trying to customize the command prompt of the C shell as follows:
set prompt="[%/ ] "

The above one works fine but when I try to add a '$' (dollar) symbol into the string as
set prompt="[%/ $] "

I am getting the error as: Illegal variable name

However, this one
set prompt = "-- %T %n %~ -- \n$ "


So could anyone suggest me what I am doing wrong in the string which gives me error and how to correct it to get the desired prompt?
# 2  
Old 02-20-2013
compare :
set prompt="[%/ $] "
# and
set prompt = "-- %T %n %~ -- \n$ "

a Dollar sign followed by ANYTHING is unserstood by the shell as a variable...
Im sure you put:
set prompt="[%/ $ ] "

gives no errors....
This User Gave Thanks to vbe For This Post:
# 3  
Old 02-21-2013
You are exactly correct vbe !! Thanks for shedding some light Smilie

I tweaked the above code to
set prompt='[%/ $] '

by replacing the double quotes with single quotes and now it works like a charm Smilie

Previous Thread | Next Thread
Test Your Knowledge in Computers #126
Difficulty: Easy
Linux distro is an OS created from a collection of software built upon the Linux kernel.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Pass C shell array to another C shell script(csh) and shell(sh)

Dear Friends, Please help me on this my script name is send.csh In this i have written the statement like this set args = ( city state country price ) I want to pass this array to another c shell called receiver.csh. and i want to use it in this c shell or how to pass to... (2 Replies)
Discussion started by: SA_Palani
2 Replies

2. UNIX for Dummies Questions & Answers

Need to revert default prompt in Linux after setting PS1 command

I have given as: PS1="Karthick>" in linux. Now the prompt changed as: Karthick> Now I need to get back the default prompt . How to achieve this? Thanks in advance (13 Replies)
Discussion started by: karthick nath
13 Replies

3. Shell Programming and Scripting

Changing the prompt in CSH

Need assistance in changing prompt . Trying to change prompt in csh,tcsh shell . Below are the commands i tried in .cshrc and sourcing this files. set prompt = "$user@`uname -n` : ${cwd}> " #above commands works for username and hostname but cwd doesnt change directories set... (16 Replies)
Discussion started by: ajayram_arya
16 Replies

4. Shell Programming and Scripting

tcsh/csh: set prompt in production to color red

Hi folks This is our prompt at the moment oracle@pinkipinki:/opt/oracle> grep 'set prompt' .cshrc set prompt = "$user@`uname -n`:$cwd> " We wish to have in production the same prompt, but red. Howto do that? I tried a lot a internet manuals, but it doesn't work. (1 Reply)
Discussion started by: slashdotweenie
1 Replies

5. Red Hat

Help with csh env setting in Fedora 8

Hi there, How can I change bash to csh when starting a terminal, and set some aliases for csh? I can't find such files like .cshrc in my home directory. Thanks a lot (1 Reply)
Discussion started by: dustinwang2003
1 Replies

6. Shell Programming and Scripting

Help setting PS1 prompt to include current time

Hi, I'm using the ksh shell and I'd like to set my PS1 prompt on an AIX system to include, amongst ther things, the current time. This was my best effort: export PS1=$(date -u +%R)'${ME}:${PWD}# ' but this only sets the time to the value when PS1 is defined and the time value doesn't... (4 Replies)
Discussion started by: m223464
4 Replies

7. Shell Programming and Scripting

problem in setting classpath in shell script

please send me format for wriiting classpath in shell script this is my shell script --------------- #! /bin/bash javac /usr/bin/java File1 -------------------------- the script works fine on termianal but in cron it gives me error saying class defination not found ... (1 Reply)
Discussion started by: sari
1 Replies

8. Shell Programming and Scripting

csh fails when setting variable

I have a csh that is called from autosys. It fails when it hits this code env | grep Rep if ( $status == 0 ) then echo "" else setenv REP "" endif However if I run it from the command line, as opposed to from autosys (job schduler) it runs fine. I thought it might be some kind of... (2 Replies)
Discussion started by: gillbates
2 Replies

9. Shell Programming and Scripting

Is this a shell setting problem?

I have a question regarding shell settings. I have one Sun server with Solaris 9 and Oracle 10g R2 on it. DB is up running well. I created a script to start DB automatically when server reboot. It didn't work. I manually run dbstart under $ORACLE_HOME/bin, the server return message like:" dbstart:... (7 Replies)
Discussion started by: duke0001
7 Replies

10. Shell Programming and Scripting

current directory as part of the csh prompt

I would like my csh prompt to behave like the linux csh prompt setting done by linux command (set prompt="%n@%m %c]$ ") how do I do that? What I'm trying to do is that I would like to see what directory I'm in by looking at the prompt. I've figured out that %n is like $user, and %m is like... (3 Replies)
Discussion started by: jamesloh
3 Replies

Featured Tech Videos