Not sure if UNIX is searching for files or not?


 
Thread Tools Search this Thread
# 1  
Not sure if UNIX is searching for files or not?

I am very very new to Unix, working on a shell script for my job and was just trying to come up with the correct find command. I get a > symbol on a new line. I can't exit the program either, it will not go back to the $. I am using Cygwin. I don't know if this means no result, or if the fact none of the exit commands I tried worked, does it mean that it is still searching?

Code:
> find . -type f -name '.nfs*'
> > ls -ltr
> exit
> exit
> :q!
> exit> >
> quit
> :q!
>

# 2  
You seem to be stuck at the secondary prompt (PS2, typically >). Try pressing Control-C to see if you get back to the $ (PS1) prompt, then try running the find command again.

You'd usually see a secondary prompt if the previous command is incomplete (i.e. because it has a missing closing quote, or is expecting user input, etc.).
# 3  
> is a continuation, as in an extended line is being entered. Enter ctrl/D (hold the ctrl button down, touch the d button just once), too many ctrl/D characters will log you out.

Code:
find . -type f -name '.nfs*' -exec ls -l {} \;

find has goofy syntax, but this seems to be what you want.
This User Gave Thanks to jim mcnamara For This Post:
# 4  
Thank you. This code works I think. It takes me to the next line with the $, but I get no results at all.

Code:
find . -type f -name '.nfs*' -exec ls -l {} \;

 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Searching files

i want to search a file bt it not happening i m using #!bin/bash read file if (-e "$file") then echo "asfsafafa" else echo "NO SUCH FILE" fi ....error ./VMC.sh: line 5: : command not found NO SUCH FILE ;;;;;;;;;; its giving correctly no such file found but whats is command not found. (7 Replies)
Discussion started by: console
7 Replies

2. Shell Programming and Scripting

Searching across multiple files if pattern is available in all files searched

I have a list of pattern in a file, I want each of these pattern been searched from 4 files. I was wondering this can be done in SED / AWK. say my 4 files to be searched are > cat f1 abc/x(12) 1 abc/x 3 cde 2 zzz 3 fdf 4 > cat f2 fdf 4 cde 3 abc 2... (6 Replies)
Discussion started by: novice_man
6 Replies

3. Shell Programming and Scripting

Searching the web...unix

Hello, I am writing a command that uses a search-motor in a website... my code is : lynx -dump "http://www.theweathernetwork.com/index.php?product=search&pagecontent=results&prodtype=city&prodname=$1"|grep $1|head -1000>>temp.txt so if the user types myprogram.sh nameofTheCity: it... (0 Replies)
Discussion started by: andrew1400
0 Replies

4. UNIX for Advanced & Expert Users

Searching for files

Hi, I have the following command to list files beginning with a specific name and containing some text... find . -type f -name "dm_merge_domain_adm*" -exec grep -il "Error Message:" '{}' \; -print|xargs ls -ltr It works fine, but seems to list two of each file, when they only exist once...any... (1 Reply)
Discussion started by: chrislluff1976
1 Replies

5. Shell Programming and Scripting

Files searching

I have a list of files in directory and i should write a script if any of these files contains words given in a text file test.txt. the words can be case ignored and word should match. The output should be the name of the directory in which the file is present followed by list of file names Eg:... (1 Reply)
Discussion started by: kinny
1 Replies

6. Shell Programming and Scripting

Searching a substring from a string in UNIX

Hi all. I need help with a command to locate a substring from a string. My problem is I am passing a direcotry name as a command line argument and I need to ensure that user should not pass certain directories. E.g ther are Directories under ==> /opt/projects/* which should not be passed... (3 Replies)
Discussion started by: Veenak15
3 Replies

7. SCO

Searching for Unix bootdisk

Hello. I need to reinstall my Unix Open Server Release: 5 on my Compaq proliant 800, but, my floppy bootdisk Release:5.0.4 is bad. Where can I download that version. That release of Unix is no longer supported by SCO. Thanks. (4 Replies)
Discussion started by: Junior Rod
4 Replies

8. UNIX for Advanced & Expert Users

Searching Files

Hi, I have a file /db01/dat/march 2006/7001DW06.03B Please note, between "march 2006" there is a space/tab. While running the following script, it identifies /db01/dat/march ----> as first file 2006/7001DW06.03B ---> as second file. SRC_PATH = /db01/dat SEARCH_FILENAME =... (12 Replies)
Discussion started by: ronald_brayan
12 Replies

9. UNIX for Dummies Questions & Answers

Searching for HOST NAME in UNIX

Hello, I am new to UNIX OS and I am planning to learn on how to use it since I was granted with the joy of being responsible of SCO UNIX on our network :-) So, can someone please tell me how to search for a particular string on our UNIX box specifying a server name...??? For some reason... (6 Replies)
Discussion started by: George26
6 Replies

10. UNIX for Dummies Questions & Answers

Searching files..?

hi there can anyone tell me how to search and copy files under unix? im writing shell scripts with 'vi' and 'pico' something like read directoryName if then echo Copying the files copy those *.src files to sub1(another directory) using cp else ... (4 Replies)
Discussion started by: nickaren
4 Replies

Featured Tech Videos