Symbolic link

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Symbolic link
# 1  
Old 02-06-2013
Symbolic link

Hi, trying to understand more about symblic link, when I compiled a program called "match" in one folder

I want this program to be accessible like a system command by putting a symbolic link in

Not by setting the $PATH method in .bashrc at this time.
What I did is:
$~/downloadsoftware/match> sudo ln -s match /usr/bin/match

I was hoping to create the command match in /usr/bin/. The fact is the link is there but not executable as in the local folder: ~/downloadsoftware/match which is executable. When I tried:
$>which match

It shows nothing but match is in /usr/bin/. If I go to /usr/bin/ and do
$/usr/bin> sudo ln -s ~/downloadsoftware/match match
$>which match

Why is it like this? I thought
ln -s /path/to/source/file /path/to/destination/file

should work for any circumstances. What did I miss? Thank you!
# 2  
Old 02-06-2013
ls -l /usr/bin/match

to see what you have done.
The /path/to/source/file must be absolute or relative to the /path/to/destination/.
ln -s match /usr/bin/match

would be relative to /usr/bin/ i.e. point to itself.
cd /usr/bin
ln -s ~/downloadsoftware/match match

ln -s ~/downloadsoftware/match /usr/bin/match

is correct, because the /path/to/source/file is absolute.
This User Gave Thanks to MadeInGermany For This Post:
# 3  
Old 02-06-2013
I did noticed sometimes that ls -l indicated the link is actually pointed to itself. It seems to me the trick is this statement
The /path/to/source/file must be absolute or relative to the /path/to/destination/.

but the man page does not provide enough information about this. More care should be taken next time to create a soft link. Thanks a lot!
# 4  
Old 02-06-2013
The trick is, for symlinks, ln takes the path completely literally.

So if you do
ln -s ../whatever path/to/linkname

You might expect a link to ../../../whatever, since it's more folders up, right?

Nope, it just gives a link pointing to the path ../whatever. It doesn't extend it for you.

If you give it an absolute path, it can't make this mistake.

Last edited by Corona688; 02-06-2013 at 05:05 PM..
This User Gave Thanks to Corona688 For This Post:
# 5  
Old 02-06-2013
I think my misunderstanding is the relative path was assumed OK, and was used.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. How to Post in the The UNIX and Linux Forums

How to list all symbolic link?

how to list all symbolic link, can i use find / path -type l (2 Replies)
Discussion started by: avtalan
2 Replies

2. Shell Programming and Scripting

How to list all symbolic link?

how to list all symbolic link can i use find / path -type l (1 Reply)
Discussion started by: avtalan
1 Replies

3. UNIX for Dummies Questions & Answers

[Solved] Symbolic link not allowed or link target not accessible

Hi everybody, I read about treads realted to this issue but they did not resovle issue given below. Please help me resolve issue given below I have html file under /srv/www/htdocs/actual_folder ls actual_folder/ test.html and following link works... (0 Replies)
Discussion started by: newbielgn
0 Replies

4. Shell Programming and Scripting

ls on a symbolic link

Hi all, Can anyone please confirm if the command below is the only way that I can get what the symbolic link is set to? mnlxd110(oracle)/db/posd2/dba$: ls -l | grep "^l" lrwxrwxrwx 1 oracle dba 28 Aug 9 2011 bdump -> diag/rdbms/posp1/posp1/trace mnlxd110(oracle)/db/posd2/dba$:... (7 Replies)
Discussion started by: newbie_01
7 Replies

5. Shell Programming and Scripting

Symbolic Link Help

Hello All, This may be a silly question to some but I am really stuck. Is there a way to reverse the following; sudo rm /bin/sh sudo ln -s /bin/bash /bin/sh It was part of a driver compile/installation procedure by Digi for Ubuntu stating that dash isn't supported and a symbolic link... (2 Replies)
Discussion started by: LAVco
2 Replies

6. Shell Programming and Scripting

symbolic link

Hi, i am trying to create sym links on sles 11 , but it seems i am doing something wrong. oracle@tests:/u01/app/oracle/oradata/ACIS> pwd /u01/app/oracle/oradata/ACIS oracle@tests:/u01/app/oracle/oradata/ACIS> ln -s /db/ACIS/dbase/dbf/ /u01/app/oracle/oradata/ACIS/... (2 Replies)
Discussion started by: tonijel
2 Replies

7. UNIX for Dummies Questions & Answers

need some info about symbolic link and hard link

hello folks how y'all doin well i have some questions about symbolic link and hard link hope some one answer me i open terminal and join as root and i wrote ln -s blah blah then i wrote ls i see red file called blah blah but didn't understand what is this can some one explain and... (2 Replies)
Discussion started by: detective linux
2 Replies

8. UNIX for Dummies Questions & Answers

Symbolic Link Confusion

I have just tried to make my first shortcut aka symbolic link. I entered this command: ln -s /one/two/three/four/help/admin admindirectory to make a link called 'admindirectory' that would take me to: /one/two/three/four/help/admin It seems to have created a directory called... (5 Replies)
Discussion started by: Sepia
5 Replies

9. UNIX for Dummies Questions & Answers

symbolic Link

question abt symbolic link ... i'm doing the following ... ln -s ./scripts/ and cat ./scripts/ it is giving following error cat: cannot open Any reason u an think of ? But it is working fine when i goto scripts directory and cretae the symbolic link. ... (1 Reply)
Discussion started by: bhargav
1 Replies

10. UNIX for Advanced & Expert Users

1 symbolic link to 2 different places?

I was wondering is it possible todo something like following: A) Settings:- - 2 servers on the network - both can be reached via /net/SERVER1/datadir and /net/SERVER2/datadir - i'm running rsync to syncronize the data coming to server1 from whatever application B) Wanted: on other... (2 Replies)
Discussion started by: Bashar
2 Replies
Login or Register to Ask a Question

Featured Tech Videos