Visit Our UNIX and Linux User Community


ttys.. i must be doing something wrong..


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers ttys.. i must be doing something wrong..
# 1  
Old 09-13-2001
Question ttys.. i must be doing something wrong..

SCO Unix OpenServer 5

I have this old impact printer that prints invoices, after about 15 pages it becomes misaligned.

ditty -a ttya04 shows -ixon -ixoff -ixany, which is not the right setting..

so, i type

ditty /dev/ttya04 ixon ixoff -ixany

when i ditty -a ttya04 again, the settings havent changed... am i doing something wrong here???

thanks..

e0--
# 2  
Old 09-13-2001
In case anyone was wondering, I think the problem has been solved.. The port did not remain open after I sent the ditty command.

This should be resolved by: set mode /dev/ttya04

Then: ditty /dev/ttya04 ixon ixoff -ixany ..

The funny thing is that /bin does not have the setmode application.. hmm... So, I am now on the hunt for setmode..

If this doesnt sound right to you, or you have an idea where I can get a copy of setmode, please let me know..

as always, other suggestions are welcome...

thanks,

e0--
# 3  
Old 09-14-2001
I have never worked on a SCO box. And I have never neard of "ditty". But I will describe a similiar sounding problem and solutions involving more mainstream versions of unix and the "stty" program.

Tty ports on systems like hp-ux have a default set of characteristics. You can vary them by opening the device file and issueing an ioctl() call. The
program stty does this. But here is the key...when the last process closes the file, the characteristics go back to the defaults.

So a command like:
stty 9600 < /dev/tty01
changes the baud rate for only as long as the stty command is running.

An ugly but common solution is to run a script like:
( stty 9600 ; sleep 1000000 ) < /dev/tty01
at startup.

A more correct solution is to insure that any program or script that needs to use the port shoulders the responsibility as setting it up the way it need to be. Thus the stty statement should be placed in the interface script used by the lp subsystem to actually do the printing.

Maybe your ditty problem is something like that. But the mere existence of a system command called ditty shows a disregard for unix standards...so maybe not.
 

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Why result is wrong here ? whether break statement is wrong ?

Hi ! all I am just trying to check range in my datafile pls tell me why its resulting wrong admin@IEEE:~/Desktop$ cat test.txt 0 28.4 5 28.4 10 28.4 15 28.5 20 28.5 25 28.6 30 28.6 35 28.7 40 28.7 45 28.7 50 28.8 55 28.8 60 28.8 65 28.1... (2 Replies)
Discussion started by: Akshay Hegde
2 Replies

2. Shell Programming and Scripting

I can't get what I'm doing wrong!

I am making a shell script that will have "shortcuts" to do different tasks and I can't get what I'm doing wrong (this is just a test script) read cake if then echo "1 it is" fiit outputs: 1: : bad variable namecake test.sh: 27: test.sh: Syntax error: end of file unexpected (expecting... (22 Replies)
Discussion started by: kitay
22 Replies

3. Shell Programming and Scripting

Is there anything wrong?

For one of my script, I want one extra parameter needs to be added to one of the Usage option. Below its given #Check Input parameters are valid if ; then function usage() { echo echo "*******************************************" echo " !!! USAGE... (2 Replies)
Discussion started by: raghunsi
2 Replies

4. AIX

all pseudo ttys busy, AIX 5.2

I have several users connecting via a Windows-based SSH\telnet client. The previous sysadmin used FacetTerm to allow certain users to switch between multiple "windows." I'm told there are AIX-native ways to do this but I work with what I inherited. Originally, many users were still connecting... (3 Replies)
Discussion started by: lacroix
3 Replies

5. UNIX for Dummies Questions & Answers

Difference between console and ttys

Sometimes when I open up the terminal (like just now) it says Last login: Wed Jun 17 07:29:25 on console sometimes it says ttys (like when I exit and open a new window/tab). What's the difference? and is something fishy going on? (6 Replies)
Discussion started by: Straitsfan
6 Replies

6. UNIX for Dummies Questions & Answers

can someone tell me what im doing wrong here

Got It Workng Woohoo Edited (2 Replies)
Discussion started by: iago
2 Replies

7. UNIX for Dummies Questions & Answers

what am i doing wrong

#!/bin/bash $1 | cat >> - $2 I am trying to write a script that takes that takes two arguments. The first being a line of text, the second being a file you create. The script should take the first argument and insert it into the very top (the first line) of the file named in your second... (4 Replies)
Discussion started by: iago
4 Replies

8. UNIX for Dummies Questions & Answers

what is wrong here

Hello, I have a simple script such as ----------------------------- #! /bin/sh YEAR=`date -u +%Y`; MONTH=`date -u +%m`; DAY=`date -u +%d`; DATE=$MONTH$DAY$YEAR LOGFILES=auditTrail-$DATE LOGMATCH=$LOGFILES\* ARGUM='' # find all files and write them to a file find . -name... (7 Replies)
Discussion started by: arushunter
7 Replies

9. UNIX for Advanced & Expert Users

Dead pseudo-ttys

We are having a problem on an AIX 4.3 system, whereby users somehow exit the system in a way such that their process continues to run. In the who listing, the user may or may not be listed. Processes are still listed in ps, and are still assigned to the pseudo-tty. Processes continue to... (1 Reply)
Discussion started by: markat2k
1 Replies

Featured Tech Videos