Error in Sudo

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Error in Sudo
# 1  
Old 01-25-2013
Error in Sudo

I have installed sudo on Solaris 10 (sparc). When I try to add a user I get the following:
-bash-3.00$ sudo addusr scarlet sudo
sudo: /usr/local/etc/sudoers.d is owned by uid 2, should be 0

I entered a password, thinking it was for the sudo user but it failed. Then I entered the used the root password and that failed also. I su to root and I got the following:
root# sudo addusr scarlet sudo
sudo: not found

Can someone help me please?

Thank you.

Last edited by Scott; 01-27-2013 at 01:34 AM.. Reason: Code tags
# 2  
Old 01-25-2013
When sudo asks you for a password, it generally asks you for your own password, not somebody else's. Sudo uses it's configuration file to decide who's permitted to do what, and the users only need to prove they are themselves (not some random guy who saw an open terminal and sat down at your computer).
# 3  
Old 01-25-2013
Look at the man pagess of visudo, and sudo for the correct usage...

sudo: /usr/local/etc/sudoers.d is owned by uid 2, should be 0
Meaning it was not correctly installed, sudo is very sensible to file permisssions...

If you scarlet have right to use sudo you can check out by typing:
 sudo -l

# 4  
Old 01-27-2013
After editing sudoers, I keep getting the following error:
sudo: parse error in /usr/local/etc/sudoers near line 74
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

How do I fix this?

Thanks again.


Last edited by Scott; 01-27-2013 at 01:35 AM.. Reason: Please use code tags
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

Sudo error on AIX 7.1

Hello, I tried installing sudo on a lab AIX server. It has been successfully installed. but i still see the below errors. />sudo -V Sudo version 1.8.27 Configure options: --prefix=/opt/freeware --sbindir=/opt/freeware/sbin --libdir=/opt/freeware/lib --mandir=/opt/freeware/man... (8 Replies)
Discussion started by: System Admin 77
8 Replies

2. Shell Programming and Scripting

Error while sudo to instance via bash script

Team , I am trying to sudo to instnace using a shell script .In out put i am getting this error for every line ...I am running this script as root .. sudo su - userid -i db2 "command " Error /etc/profile: shopt: not found how can we overcome this error ? Can someone help on... (1 Reply)
Discussion started by: rocking77
1 Replies

3. Solaris

SUDO error in Solaris: auth.error] fork

I cannot solve the following error bellow. Can someone help me on this please? Mar 31 07:08:45 serverx sudo: fork Mar 31 07:18:50 serverx sudo: fork Mar 31 07:28:45 serverx sudo: fork Mar 31 07:38:47 serverx sudo: fork Mar 31 07:48:45 serverx sudo: fork Mar 31 07:58:45 serverx... (1 Reply)
Discussion started by: pangarano
1 Replies

4. Emergency UNIX and Linux Support

Mail notifications for sudo shows syntax error

Im Using Centos Version $ cat /etc/redhat-release CentOS release 6.4 (Final) I'm Using Sudo Version $ sudo -V Sudo version 1.8.6p3 Sudoers policy plugin version 1.8.6p3 Sudoers file grammar version 42 Sudoers I/O plugin version 1.8.6p3 tried to setup notification mail for sudo,... (2 Replies)
Discussion started by: babinlonston
2 Replies

5. UNIX for Advanced & Expert Users

Error - sudo: no tty present and no askpass program specified

Hi I am trying to automate the deployment of a tar ball onto a set of remote servers and am getting this error from the ssh - sudo: no tty present and no askpass program specified What I have done is add some code into the user's ssh key that does a few things like delete the existing... (2 Replies)
Discussion started by: steadyonabix
2 Replies

6. UNIX for Dummies Questions & Answers

Error message of sudo apt-get

Hi, I am using ubuntu 12.04 and every time I installed new program or do: sudo apt-get install -f I get the following mesage: Download done. sha256sum mismatch jdk-7u3-linux-x64.tar.gz Oracle JDK 7 is NOT installed. dpkg: error processing oracle-java7-installer (--configure): subprocess... (2 Replies)
Discussion started by: programAngel
2 Replies

7. Ubuntu

Need help with a weird sudo error.

I'm fairly new to unix and I was trying to change the name of my host and my user. I changed the name in /hostname using this: gksudo gedit /etc/hostname I then tried changing the name back but it still gave the same error: {env_reset,... (1 Reply)
Discussion started by: H3jck
1 Replies

8. Shell Programming and Scripting

ssh sudo command - Prompts for sudo password as visible text. Help?

I am writing a BASH script to update a webserver and then restart Apache. It looks basically like this: #!/bin/bash rsync /path/on/local/machine/ ssh sudo /etc/init.d/apache2 reloadrsync and ssh don't prompt for a password, because I have DSA encryption... (9 Replies)
Discussion started by: fluoborate
9 Replies

9. UNIX for Advanced & Expert Users

sudo su error

Hello, I am logging to a server using username 'test'. I want to execute some commands as user test2. When I am trying to run `sudo su - test2 -c 'ls'` it gives error user 'test' is not allowed to run sudo in host. But when I login into the account 'test2' using sudo su - test2 all these... (6 Replies)
Discussion started by: karayan
6 Replies

10. AIX

Sudo error

I want give a user "sar" permission, so I modify the sudoers file: unix1 is the group for users can use sar command Cmnd_Alias RUN_SAR = /usr/sbin/sar User_Alias UNIX1_USERS = %unix1 UNIX1_USERS ALL = NOPASSWD:RUN_SAR However, when I run sar command, it shows: $ sar 1 4 sar: The... (1 Reply)
Discussion started by: rainbow_bean
1 Replies
Login or Register to Ask a Question

Featured Tech Videos