Help on commands in sftp using BatchFile


 
Thread Tools Search this Thread
# 8  
This works on target host that is running(SunOS 5.10), Try it like this:
Code:
$ cat test_sftp.sh
sftp -b - -v -o BatchMode=yes user@host <<ENDSFTP
-mkdir test
cd /tmp
pwd
quit
ENDSFTP
rc=$?
if [[ $rc != 0 ]]    then
    print "***Error occurred...$rc" `date "+%Y-%m-%d-%H.%M.%S"`
else
 print "***Successful transfer...$rc" `date "+%Y-%m-%d-%H.%M.%S"`
fi

$ test_sftp.sh
................................
sftp> -mkdir test
Couldn't create directory: Failure
sftp> cd /tmp
sftp> pwd
Remote working directory: /tmp
sftp> quit
................................
***Successful transfer...0 2013-01-12-11.33.50

Note: You will get the message(Couldn't create directory: Failure) if the directory already exists but it will not abort but continue with the next commands.
# 9  
Hi spacebar,

Thank you for your response, i've tried it and it still gives me an error:

$ ./test3.txt
No such file or directory (-).
***Error occurred...255 2013-01-13-20.51.19

Regards,
Choco
# 10  
Post the script your using and the results of this command for both the source and target machine:
Code:
uname -a

# 11  
i've tried your script:

/usr/bin/sftp -b - -v -o BatchMode=yes <id>@<ip address> <<ENDSFTP
mkdir test
cd /test
pwd
quit
ENDSFTP
rc=$?
if [[ $rc != 0 ]] then
echo "***Error occurred...$rc" `date "+%Y-%m-%d-%H.%M.%S"`
else
echo "***Successful transfer...$rc" `date "+%Y-%m-%d-%H.%M.%S"`
fi

Sources:
SunOS 5.10 Generic_144488-11 sun4v sparc SUNW,SPARC-Enterprise-T5220
SunOS u 5.9 Generic_122300-61 sun4u sparc SUNW,Sun-Fire-V890
SunOS u 5.10 Generic_142909-17 sun4v sparc SUNW,T5240

Im not able to get for the target server :
sftp> uname -a
Invalid command.
# 12  
sftp is not shell. You cannot run uname in sftp. Try it in a shell
# 13  
Hi Corona688, spacebar and binlib,

I want to thank all of you for your inputs. I made some modification on the scripts and it is now working, i just create a permanent directory to the destination server and adjust the logname format so it will not be dependent on sftp version.

Cheers!

Regards,
Choco
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Science: Gadgets
Difficulty: Medium
The Western Electric Model 500 telephone uses tone dialing to dial phone numbers.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Sftp using batchfile - storing result local

I'm making an sftp-connection to a remote server. I want the result of an ls-command in a local file and the result of ls on another folder in another local file. Because everything has to go as fast a possible I wan't to do everyting in one connection. The command I use is : psftp -v -batch -b... (4 Replies)
Discussion started by: pistach
4 Replies

2. Shell Programming and Scripting

Batch file for sftp commands

I am trying to automate an sftp command so that it does not stop and ask for the password each time the calling shell script #!/bin/ksh sftp -b tst_1_batchfile.txt GLAXGBUPMPSOUT@204.90.134.116 the batchfile contents : password XXXXXX cd /GLAXGBUPMPSOUT/GSKENT/GLAXGF2FOPFF put... (4 Replies)
Discussion started by: Shrabanti
4 Replies

3. Shell Programming and Scripting

sftp can't fine batchfile "No such file or directory"

Hi, I've got a C program that is using execlp to run a non-interactive sftp (using a batchfile) session to send some files to another system. Just before doing that, I create the batchfile called sftp_batch on the fly: V8_26_1:sun-->cat /workspace/sftp_batch cd /tmp/newsftp put test.file... (2 Replies)
Discussion started by: Fiaran
2 Replies

4. Shell Programming and Scripting

execute shell commands with in sftp

Hi All, Please let me know how do I execute some of the shell commands like cat, find ,grep within sftp. Any help in this regard would be greatly appreciated. Thanks, (5 Replies)
Discussion started by: tommy1
5 Replies

5. Shell Programming and Scripting

Passing variables: sftp using -b batchfile

Hi All, I have created a script for an sftp transfer that works without a date variable being passed, I want it to work with a date variable being passed. So, my initial script, mainsftp.sh, looks like this: ----------------------------------------------------------------------- #... (1 Reply)
Discussion started by: j_miller
1 Replies

6. Shell Programming and Scripting

commands to remote sftp

Hello, Is there a way to use wc, sed or other commands against remote sftp in a regular shell script? wc -c *.* | grep total | sed s/total// ? thanks in advance (0 Replies)
Discussion started by: chm0dvii
0 Replies

7. Shell Programming and Scripting

sftp -b doesn't read the batchfile

Several of our end-users need to send a file to our insurance carrier using ssh and sftp. We've put together a Windows VBS script that opens the ssh tunnel and calls sftp with the -b option pointing to a batch script in the same directory, however sftp doesn't seems to be reading from the... (1 Reply)
Discussion started by: kmw
1 Replies

8. UNIX for Advanced & Expert Users

FTP commands in SFTP

Hi, I am in the process of migrating all my FTP data flows into SFTP to make data more secure... I have used many quote site commands in our FTP sesssion. In SFTP i found that there is no option to do such commands. Does any body here know to overcome the current situation. Regards,... (2 Replies)
Discussion started by: Astra
2 Replies

9. Shell Programming and Scripting

Automate batchfile generation for sFTP

Hey all, I am writing a script for sFTP using batchfile option (-B). My script is supposed to monitor a certain directory for several files and when they are found I will send them to a testing server. So using a static batchfile wouldn't be feasible, I am just wondering if anyone can show... (0 Replies)
Discussion started by: mpang_
0 Replies

10. Shell Programming and Scripting

Need help in sftp basic commands

I'm trying to make use of some common generic functions already present in the scripts loaded in the environment. A variable VAR1 is declared and used in the generic functions. Its value is also set in the generic function. Now I need to use that generic function for PURGING of some old files... (2 Replies)
Discussion started by: livetaurean19
2 Replies

Featured Tech Videos