Visit Our UNIX and Linux User Community


OpenBSD Ftp permissions problems - help!!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers OpenBSD Ftp permissions problems - help!!
# 1  
Old 08-22-2005
Data OpenBSD Ftp permissions problems - help!!

Hello,

Ok I have a couple of little problems that I can't for the life of me work out how to solve. I wasn't involved in setting the server up, I've just "inherited" the support for it. I've done my best to be a good little newbie, researched articles, tried things out and managed to only get so far...

OpenBSD is running Apache and the public_html are in UserA's home folder. UserB wanted to be able to upload docs into public_html too so I managed to setup a group called webuser, put them both in it and managed to make it so that it was the default group in the public_html folder for any uploaded files.

First of all, whenever any user ftp's up a new file, it automatically gives it the permissions 640. This means that people in the group can't edit the file which is what I want them to do! I've tried setting all the folders using CHMOD and trying to use UMASK and things but it doesn't work. I looked at changing the ftp config, but I don't have a login.conf in the /etc so not sure if I should create one. I am also not sure if I should try and run ftpd with the -mask switch or something.

Also, when a user uploads a file, they are the only user that can change the permissions, even when the group is set correctly and the permissions set to 775. Shouldn't anyone in the group be able to change the permissions? Is it possible to set that for just the one folder?

Can anyone offer any helpful pointers, advice, links or anything that might help??

Thanks!
# 2  
Old 08-23-2005
Computer

Ok think I have sorted it now, found I only had to change inetd.conf to read:

ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/in.ftpd -u 007

And then restart the inetd. Now everything works fine!

Thanks to all for reading!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #23
Difficulty: Easy
One Terabyte (1 TB) is equal to 1000 GB.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Qemu Problems: OpenBSD(host) Kali Linux(guest)

As the title suggests I ran into a little problem trying to create a virtual machine of Kali Linux usign Qemu inside OpenBSD. I edited the example Kali Linux gave on their website here to the following for BSD: qemu-system-i386 -hda ./kali.qcow2 -boot d -cdrom ./kali-linux-1.0.5-i386.iso -m... (0 Replies)
Discussion started by: Azrael
0 Replies

2. UNIX for Dummies Questions & Answers

FTP loses write permissions

Hi Guys, i have learned today that when you ftp a file with full write permissions (777) to another destination it loses the w options. so a file that was once -rwxrwxrwx(before FTP) is now -rw-r--r-- (after FTP). why does this happen? and is it configurable? Regards, (8 Replies)
Discussion started by: brian112
8 Replies

3. BSD

OpenBSD pf problems

I am having troubles with this pf configuration, it seems when loaded nothing can access my server on the internal interface for the LAN, I cannot see why, and it's pretty much based off the very standard example in the OpenBSD faq. When I unload the configuration, I can access the DNS server on... (0 Replies)
Discussion started by: John Tate
0 Replies

4. UNIX for Dummies Questions & Answers

Permissions Issues FTP server

Hi all, Quick question, im going to find this a bit hard to explain but ill give it a go. Basically i have an admin account on an FTP server that i want to be able to control ALL files without having to use sudo (as i need to run cron scripts to move files that are owned by a number of... (2 Replies)
Discussion started by: mokachoka
2 Replies

5. UNIX for Dummies Questions & Answers

permissions on ftp...

hi, how can I see permissions through ftp connection ? I can't see them using "ls -l" as in the local system.. thanks (1 Reply)
Discussion started by: aneuryzma
1 Replies

6. AIX

FTP file permissions

Hi all, I am using ftp command to transfer a file from one AIX5.3 box to different box with the same OS level. Is there a way I could change the permissions on the file once its transferred, as I am automating the process but the file permissions on the target does not allow other users to access... (2 Replies)
Discussion started by: sam_78_nyc
2 Replies

7. UNIX for Dummies Questions & Answers

FTP Permissions

Hi Guys, I am trying to grant FTP acccess to my server for a WebDesigner to be able to upload live and see how it looks online. I created a new user (WebDes:tomcatUsers) and created his home dir as /var/lib/tomcat5/webapps/uPhoto/ and then made sure he CHROOT's to his home dir so he only... (1 Reply)
Discussion started by: boarderstu
1 Replies

8. HP-UX

FTP user files permissions problems!!!

Hi, I have a problem with my ftp accounts whereby if any external ftp party connects to our server and puts any file in a directory on our server. The file permissons are always -rw-r----- and no read for others. I have adjusted the ftp user .profile to include 'umask 022' but this only works... (3 Replies)
Discussion started by: budrito
3 Replies

9. UNIX for Dummies Questions & Answers

ftp file with full permissions

I am running sco openserver 5.0.6 and I was wondering if I could ftp files to one of my other servers and that file have full permissions set automatically on the new server. I have searched the internet and manned chmod chown and ftp but they only seem to talk about giving the permissions after... (7 Replies)
Discussion started by: stufine
7 Replies

10. UNIX for Dummies Questions & Answers

ftp permissions error

HI, I am not really even a newbie I'm just posing as one until our sys admin gets back from vacation. I am getting errors downloading certain files from an NT Server onto our inhouse Unix fileserver. Certain files always return errors when downloading to their proper directory.... (2 Replies)
Discussion started by: newbie10
2 Replies

Featured Tech Videos