Trouble setting up a shared folder

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Trouble setting up a shared folder
# 1  
Old 09-09-2012
[Solved] Trouble setting up a shared folder

I'm trying to set up a folder in my home directory that will be shared with another user but for some reason it is not working this is what I've done, I have tried two different ways using ACL's and chown/chgrp etc

I set up a group called say: sharedgroup and added both my user (john) and fred to it so when I run
groups john
john wheel sharedgroup

groups fred
sharedgroup fred 

mkdir /home/john/shared
vim /home/john/shared/hello.txt (typed in some text saved it)
chown -R :sharedgroup shared
chmod -R o=-rwx shared
drwxrwx--- 2 john sharedgroup   4096 Sep  9 21:14 shared
ll shared
-rw-rw-r-- 1 john sharedgroup 7 Sep  9 21:14 hello.txt

(I also tried adding in the s permissions but that didn't help either)

then when I log out of the server and log back in as fred and try these commands they fail
vim /home/john/shared/hello.txt (won't allow me to write opens a blank file)
cd /home/john/shared
ls /home/john/shared

Any idea what I'm doing wrong??

Moderator's Comments:
Mod Comment Please view this code tag video for how to use code tags when posting code and data.

Last edited by vbe; 09-10-2012 at 04:59 AM..
# 2  
Old 09-10-2012
Maybe if you said on what platform you were, it could help...
Some OS, the fact you belong to the group suffice (HPUX...) some will require (Solaris (10)...) that you newgrp <groupname> before... but we dont know what you OS and vesrion you are on...( you said you tried with ACLs but here we see nothing...)
# 3  
Old 09-10-2012
Is /home/John executable for that group or for others?
This User Gave Thanks to RudiC For This Post:
# 4  
Old 09-10-2012
Ahh my bad I'm on RHEL. Either way I fixed it. RudiC you had it right I didn't have the directory permissions for /home/john set. I ran
chown -R :sharedgroup /home/john
chmod g=rwx /home/john

and everything worked fine

Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Setting UID and GID for shared folder using NFS method in Linux system

Hi everyone, have a good day to you. I am trying to use NFS to share a folder between 2 linux systems. Let's say the server which is sharing the folder is server A and the client which need to access this shared folder is server B. In server B, i am having a Joe user which UID and GID is 500.... (1 Reply)
Discussion started by: michael_hoang
1 Replies

2. Shell Programming and Scripting

Trouble with setting a variable with vastool

Hi I have this command that when put on the command line it returns the output the way I want it. /opt/quest/bin/vastool list -a groups | grep testdev_li | grep dev | awk -F"" 'NF>2{print $2}' | cut -c2- | tr '\n' '|' The output of this is ... (2 Replies)
Discussion started by: ajetangay
2 Replies

3. Shell Programming and Scripting

Trouble setting up flag ( getopt) for my script

do case $option in d ) CHEC=true;; # more option processing can go here \? ) echo "Unknown option: -$OPTARG" : ) echo "Missing option argument for -$OPTARG";; * ) echo "Unimplimented option: -$OPTARG";; esac done shift $(($OPTIND - 1)) (2 Replies)
Discussion started by: upenmishra
2 Replies

4. UNIX for Dummies Questions & Answers

Trouble Setting Up Sun Ultra 10 - Displaying Garbage

Hello there, I am new to this forum as well as to the UNIX world. Recently graduated with a degree in Computing and just started learning UNIX & bought 3 Sun Ultra 10 Servers. I was trying to set the Servers up so I can use them; the Servers don't have a VGA card. My laptop, which I would be... (6 Replies)
Discussion started by: frhan2u
6 Replies

5. Shell Programming and Scripting

command to connect the shared folder

Hello, I am using unix through cygwin application in my office machine and here i encounter a problem which i want copy certain big files from a shared folder shared folder--\\Parwvm000154\docs to my local machine c:/ I'm really honor if i clarified with the command. Regards... (1 Reply)
Discussion started by: thelakbe
1 Replies

6. Ubuntu

Trouble setting up Java classpath

Saw an error while setting up an application called i2phex: # ./ java.lang.RuntimeException: Failed to initialize at phex.common.ManagerController.initializeManagers( at phex.Main.main( (0 Replies)
Discussion started by: Israel213
0 Replies

7. IP Networking

Trouble setting up a static IP on NetGear DGN1000

I have been trying to setup a static ip, however everytime I do so my internet disconnects and won't connect untill I switch back to dynamic. My router is a NetGear DGN1000 and I'm using it wired. Could anyone help? (0 Replies)
Discussion started by: zomigosh
0 Replies

8. Shell Programming and Scripting

See shared folder

Hello, I want to list all shared folder in terminal in local. I haven't found the command for, i'm on bash in mac os x. Thanks (2 Replies)
Discussion started by: protocomm
2 Replies

9. Filesystems, Disks and Memory

can folder shared with NFS (/usr/)

hello i wanted to ask you i try to setting: pc server name: A pc user name: B pc user name: C server A is opensuse 11.2 with kde 4.3.5 and last kernel so i create NFS server, i think.. folder (/usr is all softwares and library) because server A can share to PC A. because all... (0 Replies)
Discussion started by: tunjin
0 Replies
Login or Register to Ask a Question

Featured Tech Videos