[Solved] Symbolic link not allowed or link target not accessible


 
Thread Tools Search this Thread
# 1  
[Solved] Symbolic link not allowed or link target not accessible

Hi everybody,

I read about treads realted to this issue but they did not resovle issue given below.
Please help me resolve issue given below

I have html file under /srv/www/htdocs/actual_folder
Code:
    ls actual_folder/
    test.html

and following link works
http://mysystem/actual_folder/test.html

then I created symbolic link
Code:
ln -s actual_folder symbolic_link

But, link with symbolic link folder doesn't work http://mysystem/symbolic_link/test.html
Browser displays Access forbidden! Error 403


A) Created conf file for apache : /etc/apache2/conf.d/myconf.conf
Code:
<Directory "/srv/www/htdocs/actual_folder">
 Options Indexes FollowSymLinks MultiViews
 Allow from all
</Directory>

<Directory "/srv/www/htdocs/symbolic_link">
 Options Indexes FollowSymLinks MultiViews
 Allow from all
</Directory>

Entry inside /etc/apache2/httpd.conf is as follows:
Code:
<Directory />
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

B) Apache log shows: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/symbolic_link

C) Permissions:
Code:
    ls -ld actual_folder/
    drwxrwxrwx 2 root root 80 Sep  3 16:30 actual_folder/

    ls -l symbolic_link
    lrwxrwxrwx 1 root root 13 Sep  3 16:31 symbolic_link -> actual_folder

D) Suse Linux enterprise server 10 sp2


Thanks

---------- Post updated 09-04-12 at 10:21 AM ---------- Previous update was 09-03-12 at 11:43 AM ----------

Issue is resolved.
My /etc/apache2/httpd.conf was including some conf files and in one of them "AllowOverride None" was set, i changed it to "AllowOverride All"
I had already set "Options Indexes Includes FollowSymLinks MultiViews" in conf file
Others if any facing this issue can try out same.

Last edited by vbe; 09-04-2012 at 01:27 PM..
These 2 Users Gave Thanks to newbielgn For This Post:
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #841
Difficulty: Medium
Push technology, or server push, is a style of Internet-based communication where the request for a given transaction is initiated by the publisher or central server.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Moving the target of a symbolic link

Hello all, On a Solaris box, I am trying to move the target of a symbolic link. Let's say the symbolic link looks like the following: /dir1/dir2/link -> /some/dir/target I would like to know of a simple way to move the target of the symbolic link and not the link itself. I'd like to move... (4 Replies)
Discussion started by: ejianu
4 Replies

2. UNIX for Dummies Questions & Answers

Symbolic link

Hi, trying to understand more about symblic link, when I compiled a program called "match" in one folder ~/downloadsoftware/I want this program to be accessible like a system command by putting a symbolic link in /usr/bin/ Not by setting the $PATH method in .bashrc at this time. What I did is:... (4 Replies)
Discussion started by: yifangt
4 Replies

3. Shell Programming and Scripting

ls on a symbolic link

Hi all, Can anyone please confirm if the command below is the only way that I can get what the symbolic link is set to? mnlxd110(oracle)/db/posd2/dba$: ls -l | grep "^l" lrwxrwxrwx 1 oracle dba 28 Aug 9 2011 bdump -> diag/rdbms/posp1/posp1/trace mnlxd110(oracle)/db/posd2/dba$:... (7 Replies)
Discussion started by: newbie_01
7 Replies

4. Shell Programming and Scripting

Symbolic Link Help

Hello All, This may be a silly question to some but I am really stuck. Is there a way to reverse the following; sudo rm /bin/sh sudo ln -s /bin/bash /bin/sh It was part of a driver compile/installation procedure by Digi for Ubuntu stating that dash isn't supported and a symbolic link... (2 Replies)
Discussion started by: LAVco
2 Replies

5. Shell Programming and Scripting

symbolic link

Hi, i am trying to create sym links on sles 11 , but it seems i am doing something wrong. oracle@tests:/u01/app/oracle/oradata/ACIS> pwd /u01/app/oracle/oradata/ACIS oracle@tests:/u01/app/oracle/oradata/ACIS> ln -s /db/ACIS/dbase/dbf/ /u01/app/oracle/oradata/ACIS/... (2 Replies)
Discussion started by: tonijel
2 Replies

6. UNIX for Dummies Questions & Answers

change target of a symbolic link

Hi, Is it possible to change the target of a symbolic link? What I currently have is: /home/Data1 /home/Data2 /home/Stores In the Stores directory, I did: ln -s /home/Data1 /home/Stores/abc $ pwd /home/Stores $ ls -latr lrwxrwxrwx 1 dandy dandy 46 Feb 12 16:38 abc ->... (5 Replies)
Discussion started by: dandyrandy
5 Replies

7. UNIX for Dummies Questions & Answers

ZIP a soft / symbolic link target

Hey, How can one ZIP the target of a soft/symbolic link in unix (if dodag@ is a symbolic link for the path car/reno/*.*, how can I zip car/reno/*.*, with using only dodag as my reference)? Thxnk you. (1 Reply)
Discussion started by: galz
1 Replies

8. UNIX for Dummies Questions & Answers

need some info about symbolic link and hard link

hello folks how y'all doin well i have some questions about symbolic link and hard link hope some one answer me i open terminal and join as root and i wrote ln -s blah blah then i wrote ls i see red file called blah blah but didn't understand what is this can some one explain and... (2 Replies)
Discussion started by: detective linux
2 Replies

9. UNIX for Dummies Questions & Answers

symbolic Link

question abt symbolic link ... i'm doing the following ... ln -s x.sh ./scripts/y.sh and cat ./scripts/y.sh it is giving following error cat: cannot open y.sh Any reason u an think of ? But it is working fine when i goto scripts directory and cretae the symbolic link. ... (1 Reply)
Discussion started by: bhargav
1 Replies

10. UNIX for Advanced & Expert Users

1 symbolic link to 2 different places?

I was wondering is it possible todo something like following: A) Settings:- - 2 servers on the network - both can be reached via /net/SERVER1/datadir and /net/SERVER2/datadir - i'm running rsync to syncronize the data coming to server1 from whatever application B) Wanted: on other... (2 Replies)
Discussion started by: Bashar
2 Replies

Featured Tech Videos